XBMC-plugin Elisa Viihteelle



Näytä ensimmäinen kirjoitus

351 kommenttia

EI vaan toimi EI.

Kokeilin tuota 0.0.5 versiota....

Kokeilen vielä kerran jos ensin poistan ton plugini ja asennan uudestaan.

Mitä sitten?

myllyjo
Kokeiles tätä https://dl.dropbox.com/u/23966445/plugin.video.elisa.viihde-0.0.10.zip

- extra infot ja thumbnailit pistetty valinnaiseks (options)

- common cache lisätty (asentuu automaatisesti)

    - kerran tarvii hakee extra infot ja thumbnailit per tallennus

    - rasperry pi mokkulan päässä on hiiiidas
Käyttäjätaso 4
Kokeiles tätä https://dl.dropbox.com/u/23966445/plugin.video.elisa.viihde-0.0.10.zip

Eipä toimi. Raspberry pi jossa xibian käyttis. Valittaa salasanasta eikä käynnisty. Onko vihjeitä missä vois olla vika?
ite ajelen raspbmc:llä ja voi olla että frodon uus beta on rikkonu sen. Pitää tutkii.
Odex kirjoitti:Raspberry pi jossa xibian käyttis.Mikä versio xbmc:stä?
Asensin uusimman raspbmx, jossa xbmc frodo beta 3 (compiled 7 dec). Toimii hienosti.
toimii myös OpenELEC-RPi.arm-devel-20121124031454-r12577 version kanssa
Käyttäjätaso 4
purtsi kirjoitti:
Odex kirjoitti:Raspberry pi jossa xibian käyttis.Mikä versio xbmc:stä?

12.0-beta. Jännää että muissa  toimii, vaatiikos tuo jotain erikoista asennettavaksi?
pura toi zip ja kato addon.xml juuresta. Siellä on riippuvuudet ja niiden versio numerot. XBMC asentaa automaattisesti noi tarvittaessa.

Voitko pistää debuggerin xbmc:n setup / system /debug (tjsp) päälle. Yritä asentaa plugari zipistä ja sitten kato kotihakemiston .xbmc hakemistosta xbmc.log tiedostoa (muistaakseni temp kansion alla). Sieltä vois selvii mitä tapahtuu.

Joskus auttaa kun poistaa  nuo plugarit addon hakemistosta. Ota kopio ~/.xbmc hakemistosta ennen kun alat testailemaan.
Käyttäjätaso 4
purtsi kirjoitti:
pura toi zip ja kato addon.xml juuresta. Siellä on riippuvuudet ja niiden versio numerot. XBMC asentaa automaattisesti noi tarvittaessa.

Voitko pistää debuggerin xbmc:n setup / system /debug (tjsp) päälle. Yritä asentaa plugari zipistä ja sitten kato kotihakemiston .xbmc hakemistosta xbmc.log tiedostoa (muistaakseni temp kansion alla). Sieltä vois selvii mitä tapahtuu.

Joskus auttaa kun poistaa  nuo plugarit addon hakemistosta. Ota kopio ~/.xbmc hakemistosta ennen kun alat testailemaan.

Tällaisen antaa logille. pitää vielä tuo debuggeri kokeilla.

11:44:39 T:2798175296 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type:
Error Contents: ('tn',)
Traceback (most recent call last):
File "/home/xbian/.xbmc/addons/plugin.video.elisa.viihde/default.py", line 452, in
mainloop()
File "/home/xbian/.xbmc/addons/plugin.video.elisa.viihde/default.py", line 434, in mainloop
show_dir("0", thumbs)
File "/home/xbian/.xbmc/addons/plugin.video.elisa.viihde/default.py", line 347, in show_dir
tn=prog_data['tn'],
KeyError: ('tn',)
-->End of Python script error report<--
11:44:40 T:2890527808 ERROR: GetDirectory - Error getting plugin://plugin.video.elisa.viihde
Purtsi, en tiedä oletko huomannut, mutta laitoin sulle taannoin natsat githubin repoon.
Terve, yritän käyttää pluginiä Raspberry-Piillä käyttäen Raspbmc:tä. Ohjelma kirjautuu hyvin sisälle ja löytää tallenteet melko ripeästi mutta kun yritän katsoa niitä niin ääni kuuluu mutta kuvaa ei näy.

Onko ideoita miten saisin kuvankin näkymään?

Raspbmc:stä on käytössä uusin RC2 versio.
Käyttäjätaso 7
Kunniamerkki +3
DaBug kirjoitti:
Terve, yritän käyttää pluginiä Raspberry-Piillä käyttäen Raspbmc:tä. Ohjelma kirjautuu hyvin sisälle ja löytää tallenteet melko ripeästi mutta kun yritän katsoa niitä niin ääni kuuluu mutta kuvaa ei näy.

Onko ideoita miten saisin kuvankin näkymään?

Raspbmc:stä on käytössä uusin RC2 versio.

Onhan sulla se MPEG2-TS codec ostettu ja asennettu ?
Eipä tietenkään ole, silloinhan teksisin asiat liian helpoiksi itselleni :)

Tilattu on ja koodia odotellessa.
Käyttäjätaso 4
Odex kirjoitti:
purtsi kirjoitti:
pura toi zip ja kato addon.xml juuresta. Siellä on riippuvuudet ja niiden versio numerot. XBMC asentaa automaattisesti noi tarvittaessa.

Voitko pistää debuggerin xbmc:n setup / system /debug (tjsp) päälle. Yritä asentaa plugari zipistä ja sitten kato kotihakemiston .xbmc hakemistosta xbmc.log tiedostoa (muistaakseni temp kansion alla). Sieltä vois selvii mitä tapahtuu.

Joskus auttaa kun poistaa  nuo plugarit addon hakemistosta. Ota kopio ~/.xbmc hakemistosta ennen kun alat testailemaan.

Tällaisen antaa logille. pitää vielä tuo debuggeri kokeilla.

11:44:39 T:2798175296 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type:
Error Contents: ('tn',)
Traceback (most recent call last):
File "/home/xbian/.xbmc/addons/plugin.video.elisa.viihde/default.py", line 452, in
mainloop()
File "/home/xbian/.xbmc/addons/plugin.video.elisa.viihde/default.py", line 434, in mainloop
show_dir("0", thumbs)
File "/home/xbian/.xbmc/addons/plugin.video.elisa.viihde/default.py", line 347, in show_dir
tn=prog_data['tn'],
KeyError: ('tn',)
-->End of Python script error report<--
11:44:40 T:2890527808 ERROR: GetDirectory - Error getting plugin://plugin.video.elisa.viihde

Tämä lähtikin toimimaan kun päivitin xbianin ja xbmc:n. Sen jälkeen piti vielä poistaa plugin ja asentaa uudelleen. Pitänee vielä nuo lisenssit ostaa niin kuvakin näkyisi.
Kiitoksia avusta, Toi lisenssin ostaminen auttoi kummasti. nyt näkyy kuvakin ja vaimo on tyytyväinen.
Käyttäjätaso 7
Kunniamerkki +2
DaBug kirjoitti:
Kiitoksia avusta, Toi lisenssin ostaminen auttoi kummasti. nyt näkyy kuvakin ja vaimo on tyytyväinen.


ja vuosi pelastettu... :smileygrin:
Date: Tue, 19 Feb 2013 13:42:07 +0200
From: Anssi Ylönen <anylonen@gmail.com>
Subject: [Xbmc-addons] [Git Pull] Elisa Viihde plugin
To: xbmc-addons@lists.sourceforge.net

Kuka arvaa? 😉
  1. You need to add a language tag. See http://wiki.xbmc.org/index.php?title=Addon.xml
  2. Invalid end-of-line (CRLF) in plugin.video.elisa.viihde/addon.py Could you please convert that file to unix eol?
  3. BeautifulSoup is available in the official repo. Add a dependency (script.module.beautifulsoup) in you addon.xml and remove the BeautifulSoup.py from your addon.
  4. You have a dependency to script.module.simplejson in your addon.xml. So remove simplejson from your addon.
  5. You can't have the same version number for eden and frodo. Use 0.1.5 for frodo or something similar.
  6. You need xbmc.python set to 2.1.0 for frodo. Seehttp://forum.xbmc.org/showthread.php?tid=151473
  7.  And it would be nice to have the changelog.txt in english
Eli ihan sukkana ei menty virallisiin plugareihin, täytyypäs tuossa tehdä hitusen perkaamista.
Minkäs version meinasit puskee tonne? Tarviiko committaa githubii toi viimesin?
Jaa-a, mun repossa ollut viimeisin  sinne nyt meni. Itse plugarin koodiin en tehnyt muutoksia (pl. vaatimuksen renameta default.py -> addon.py), vaan tuossa selvittiin addon.xml:n tunkkaamisella, changelogin vaihtamisella englanniksi ja BeautifulSoupin ja SimpleJSONin poistamisella (reduntantteja, kun löytyvät suoraan XBMC:stä).

Eli jos olisi muutoksia tulossa, niin melkein kannattaa forkata toi mun HEAD ja jatkaa siitä. Tehdään sit vaikka samantien 0.0.6 versio.
"Added to frodo!

Thanks for the submission."

 

Sitten vaan odotellaan.
Elisa Viihde plugin hyväksyttiin tuonne ja löytyy tällä hetkellä Video-addoneista. Eli ei tarvitse enää asennella erillisestä zipistä.
Hyvin helppo tuo asennus tuolta Video add-oneista.

Sain hyvin toimimaan sen noin kaksi viikkoa sitten kun virittelin pystyyn Rasbperry Pi:stä median katselulaitetta.

Softana Rasbmc paketin XBMC.

Hyvin toimi aluksi ensimmäisen viikon. Vaan tällä viikolla ei enää toiminutkaan :-(

Aina valitta virhettä addon.py scriptistä kun haluaisin mennä katsomaan ohjelmia.

Tarkemmalla selvittetelyllä vaikuttaisi, että ei sisään kirjautuminen onnistu (katsoin sorsista miten yrittää

eikä se tuntunut manuaalisesti selaimellakaan toimivan).

Eli onkohan Elisa Viihteen viime viikon päivitykset muuttaneet jotain joka on sitten rikkonhut tämän XBMC-plugin toiminnan?

Ja jos on, niin onko joku jo aktiivisesti korjaamassa asiaa?

Vai toimiiko se muilla ja mun Rasbmc systeemissä on joku muu asia rikki? (muut pluginit muihin palveluihin toimii hyvin edelleen)
Mitäköhän tuossa on tapahtunut, itsellä toimii edelleenkin ihan normaalisti niin pöytäkoneella kuin Raspberrylläkin.

Osallistu keskusteluun