Vastattu

Hybridimodeemi DN9245W ja WebSocket ongelma

  • 3 lokakuu 2019
  • 7 kommenttia
  • 449 katselukerrat

  • Uusi OmaYhteisön jäsen
  • 8 kommenttia
Olen myös taistellut useasti tuo hybridimodeemin kanssa että bonding pysyy päällä ja nopeudet toimii. Nyt olen havainnut uuden ongelman kun bonding toimii, niin pitkäkestoiset WebSocketyhteydet eivät toimi kunnolla. Tämä aiheuttaa pilven kanssa keskustelevien ohjelmien toimintaa.

Havaintojen perusteella hypoteesini on seuraava:
Kotona oleva applikaatio luo WebSocket yhteyden pilvessä pyörivään palvelimeen ja ne keskustelevat hyvin keskenään. Jokin bonding tunnelissa muuttu ja paketit reitittyvät uudelleen ja tämä aiheuttaa sen että pilvi ei saakkaan enää viestiä kotiin päin vaikka kotona pyörivä ohjelma voi vielä lähettää dataa saman WebSocketin yli pilveen. Eli näyttäisi että WebSocketin kahdensuuntaisuus menee ajoittain bonding tunnelissa rikki.

Vika on ajoittianen (tyyliin joka toinen minuutti toimii ja sitten kohta taas ei) joten hypoteesini todistaminen on hankalaa jalisäksi pitäisi tehdä simppeli applikaatio ja testitapaus.. ja tässä vaiheessa oma aikani ei enää riitä.

Turhauttavaa, sillä Elisan tukipuhelin on aivan ulkona näin teknisistä asioista.
icon

Vastauksen tähän kysymykseen jakoi tsamppa 6 marraskuu 2019, 20:23

No lopulta ratkaisu löytyi kun Elisan asentaja kävi tarkastamassa tilanteen ja lopputuloksena oli että Hybridi-modemi poistettiin ja VDSL linjanopeus nostettiin 75M.

Eli hybridi toimii paremmin, jos ADSL on heikko ja 4G hyvä, mutta jos kiinteä laajakaista on jo nopea, niin hybridistä ei ole kuin haittaa.

 

t.Samppa

Katso alkuperäinen viesti

7 kommenttia

Käyttäjätaso 7
Kunniamerkki +3
Nyt on kieltämättä jo aikamoisen haastava ongelma... Onko toi kuinka usein siis kun tuota tapahtuu, jatkuvasti minuutin sykleissä vai?
Käyttäjätaso 4
Kunniamerkki

@tsamppa

vieläkö ongelmat jatkuu?

Käyttäjätaso 7
Kunniamerkki +3

Onko @tsamppa tohon löytynyt vielä mitään ratkaisua? Minkä kaikkien pilvipalveluiden kanssa tuo on sulla ilmentynyt?

No lopulta ratkaisu löytyi kun Elisan asentaja kävi tarkastamassa tilanteen ja lopputuloksena oli että Hybridi-modemi poistettiin ja VDSL linjanopeus nostettiin 75M.

Eli hybridi toimii paremmin, jos ADSL on heikko ja 4G hyvä, mutta jos kiinteä laajakaista on jo nopea, niin hybridistä ei ole kuin haittaa.

 

t.Samppa

Ai niin, hybriikäytössä myös Elisa viihteen tallenteet lopettivat toimimasta. Aika outoa kun samalla Viihteen Youtube taas toimi.

Vika lienee siinä että joskus WebSocketin paluukaista reitittyy toista kanavaa pitkin, eli bonding ei ole täydellisen transparentti liikenteen suhteen. Aika outoa että tuota ei ole havaittu tai korjatu aiemmin.

Käyttäjätaso 7
Kunniamerkki +3

Ai niin, hybriikäytössä myös Elisa viihteen tallenteet lopettivat toimimasta. Aika outoa kun samalla Viihteen Youtube taas toimi.

Tää on kyllä outo bugi ollut sulla, meinaan noita hybridejä on monilla asiakkailla joilla on myös Viihde eikä tollasta vastaavaa oo ainakaan omille korville asti kuulunut :astonished:  Mutta hyvä kuulla että ongelmaan löytyi vaihtoehtoinen ratkaisu :blush:

Osallistu keskusteluun