Kysymys

Nettiyhteyden ongelmista (Riihimäki)

  • 4 syyskuu 2008
  • 18 kommenttia
  • 1207 katselukerrat

Tässä muutaman kuukauden ajan olen kärsinyt todella heikkolaatuisesta yhteydestä, joka vielä alkuvuodesta toimi moitteetta. Talossa on ollut 8/1Mb liittymä jostain vuodesta 2005 lähtien, joten kyse on todellakin uudesta ongelmasta. Sauniksen aspa on muuttunut Elisa-hankinnan jälkeen täysin onnettomaksi, jonne en 15 minuutissa saanut yhteyttä, joten annoin siltä erää olla. Pistin aiheesta meilitse vikailmoituksen, mutta ilmeisesti tuo oli jo etukäteen tuhoon tuomittu yritys.
Toivon että julkinen kirjoitus verkon heikkolaatuisuudesta herättäisi jonkun tutustumaan aiheeseen.

Eli, paikkana Riihimäki ja yhteys on tuo 8/1 megainen liittymä. Purkkina on käytössä ZyXelin hyväksi havaittu 660H-61 (se WLANiton peruspurkki) ja sen firmiksenä käsittääkseni viimeisin ZyNOS F/W Version: V3.40(PE.10) | 10/28/2005.
Ongelma ei ole kotiverkossani, mutta tiedoksi silti että minulla on muutama aliverkko ja kymmenisen laitetta kiinni netissä niiden kautta.

Isoin ongelma on naurettavuuksiin nouseva packet loss, joka käytännössä estää verkkopelien pelaamisen (omassa tapauksessani EVE Online). Intensiivisurffauksessakin tuon huomaa paikoitellen, kun selain jää rullaamaan puolikkaan sivun ladattuaan, mutta vähänkin nirsomman softan ollessa kyseessä, tyssää yritys muutamaan perättäiseen packet lossiin. Samaten isommissa FTP-siirroissa saattaa tuon huomata, ohjelmasta riippuen.
Olen viimeisen muutaman vuorokauden ajan ottanut ping ja traceroute statistiikkaa ylös ja selvittänyt että ongelma ei todellakaan ole tässä päässä. Juuri tällä hetkellä PingPlotter ilmoittaa tracerouten 6:nnen hypyn kohdalla packet lossiksi ällistyttävät 23% prosenttia viimeisen 20 minuutin ajalta (traceroute 5 sekunnin välein). Serveri joka tätä lukua näyttää on ae1-10.bbr2.hel1.fi.eunetip.net, joka on listassa heti Elisan viimeisen serverin jälkeen (eli 5. hyppy on ae2.heltli-gw1.fi.elisa.net).
Muut PL% kohteeseen www.eveonline.com ovat joko ei mitään, nolla (eli alle 0.5%), yksi tai kahdessa kohteessa kaksi. 14 hypyn matkalla siis ongelmakryyniksi muodotuu tuo em. serveri heti elisan verkon ulkopuolella.

Ideoita? Kysymyksiä? Vastauksia? Apuja?

Tämä keskustelu on suljettu, eikä tätä voi kommentoida.

Kokeile löytyisikö samasta aiheesta toinen tai uudempi keskustelu.
Jos keskustelua tai vastausta ei löytynyt, aloita uusi keskustelu.

HAE KESKUSTELUISTA

18 kommenttia

Käyttäjätaso 1
Siis pingi lopulliseen kohteeseen toimii ok mutta joku kone välillä ei vastaa? Eihän se kuullosta ollenkaan yhteysongelmalta vaan se kone ei ehkä vaan tahdo vastata pingeihin, vai ymmärsinkö viestisi ihan väärin...

Noin äkkiseltään voisi kuvitella, että jos vika on sinun liittymässäsi, niin jo pingatessa default gateway:tä ongelmat tulevat näkyviin. Näin ainakin minulla aluksi kun liittymässä oli jotain vikaa, niin packet lossi oli luokkaa 10-15% jo gatewayllekin. Jos packet lossia tulee vasta elisan verkon ulkopuolella niin sitten voi olla vähän vaikeampaa tehdä asialle mitään...
Kyse on siis traceroutesta, pieni ero mutta kuitenkin.

Joka tapauksessa, ongelmani on toimimaton verkkoyhteys.
Se missä se ongelma on tai se että minä olen itse tehnyt kevyttä analyysiä ei pitäisi kuulua asiaan ollenkaan. Eikö?
Nyt lähinnä metsästän ihmisiä jotka tietävät asiasta enemmän tai jonkun Saunalahden päästä joka voi asialle tehdä jotain. Aion soitella tekniseen tukeen ja aspaan, mutta tähän mennessä soitot ovat olleen hyödyttömiä. Toivon siis että tätä kautta löytyisi oma-apu-paras-apu tyyppistä vihjettä.

Ongelma ilmenee välillä elisa.net-verkko <-> eunetip.net-verkko.
Olettaisin että samoja ongelmia on jossain muuallakin, ellen minä sitten ole ainut kyseisen putken käyttäjä (ja se ei ole kovin todennäköistä).

Tällä hetkellä PingPlotter kertoo että viimeisen 20 minuutin aikana minulta lähimpään elisan jakamoon, on sattunyt yksi virhe mutta packet loss on 0 (eli käsittääkseni alle0.5%, muuten tuo kohta olisi tyhjä). Siitä eteenpäin seuraava PL% löytyy yllä mainitsemastani kohdasta ja on tällä hetkellä 24%.
Käyttäjätaso 1
Ymmärsin siis aivan oikein, ongelmahan on siis selvästi elisan / saunalahden verkossa, ei niinkään sinun tai muidenkaan nettiyhteydessä, tai ainakin niin voisi tuon kuvauksen perusteella päätellä. Asiakaspalvelu on kuitenkin vaan koulutettu selvittämään vikoja ADSL yhteydessä niin tuskin osaavat tuohon mitään sanoa, mutta jospa joku tätäkin lukisi... 😃
Se mikä tuossa valkeni juuri, on että nuohan ovat molemmat Elisan verkkoja, EUnetIP.net on Saunalahden verkkoa, EUnet-nimi vaan jostain lafkan aamuhämäristä.
Eli asia on hyvinkin Saunalahti/Elisa-kombinaatin heiniä ja korjattavissa.

Se mikä tuossa valkeni juuri, on että nuohan ovat molemmat Elisan verkkoja, EUnetIP.net on Saunalahden verkkoa, EUnet-nimi vaan jostain lafkan aamuhämäristä.
Eli asia on hyvinkin Saunalahti/Elisa-kombinaatin heiniä ja korjattavissa.


Juu juuri näin tämä korjaus, mutta aspa tuskin osaa tehdä tuolle mitään.

Kannattaa pommittaa palautelomakkeella (tai siis sähköpostilla) päivittäin ja aina niin että asialle tulee uusi tiketti niin kyllä joku jossain aikanaan havahtuu siihen, että jossain on vikaa.

Vertailutiedoksi oma 24/1 toimii 10/1:nä Riihimäellä, mutta (Saunis HUOM!) en valita, sillä tuokin on senverran enemmän kuin se 6,99/1 jonka 8/1:stä aikanaan sain että kelpaa. Toki jos nopeutta saa hilattua lähemmäs teoreettista maksimia en pane pahakseni. Matkaa dSlamille noin 2,2 km 🙂


Ongelma ilmenee välillä elisa.net-verkko <-> eunetip.net-verkko.
Olettaisin että samoja ongelmia on jossain muuallakin, ellen minä sitten ole ainut kyseisen putken käyttäjä (ja se ei ole kovin todennäköistä).

Tällä hetkellä PingPlotter kertoo että viimeisen 20 minuutin aikana minulta lähimpään elisan jakamoon, on sattunyt yksi virhe mutta packet loss on 0 (eli käsittääkseni alle0.5%, muuten tuo kohta olisi tyhjä). Siitä eteenpäin seuraava PL% löytyy yllä mainitsemastani kohdasta ja on tällä hetkellä 24%.


Sellainen huomio että tuo matkalla olevien purkkien packet loss on ihan normaali ilmiö eikä vaikuta läpikulkevien pakettien välitykseen mitään. Eli jos kohdeosoitteeseen ei tule packet lossia niin kaikki toimii, matkalla olevien purkkien packet loss arvot johtuvat siitä että reitittimissä on rajoitettuna tuota tracerouten vaatimaa ttl expired-käsittelyä tiettyyn rajaan per sekuntti.

Kannattaa testata niin että käsin pingaa noita epäilyttäviä reitittimiä ihan normi komentorivin pingillä, esim 1 paketti sekunnissa. Jos tuosta tulee packet lossia jatkuvasti niin jossain on vikaa. Samoin sitten tietty kannattaa kokeilla sinne kohdeosoitteeseen samaa.

Nuo pingplotterit, traceroutet ja mtr työkalut on kyllä ihan käteviä mutta johtavat helposti väärään diagnoosiin ja kaiken lisäksi jatkuvasti ajettuna monen käyttäjän toimesta kuormittavat entisestään niiden reitittimien kykyä vastata joka hetki oikein :)

Vikaa kannattaa myös tarkistaa adsl-linjan arvoista ja dsl-purkin kuormituksesta (jos purkissa on nat tila päällä).


Ongelma ilmenee välillä elisa.net-verkko <-> eunetip.net-verkko.
Olettaisin että samoja ongelmia on jossain muuallakin, ellen minä sitten ole ainut kyseisen putken käyttäjä (ja se ei ole kovin todennäköistä).

Tällä hetkellä PingPlotter kertoo että viimeisen 20 minuutin aikana minulta lähimpään elisan jakamoon, on sattunyt yksi virhe mutta packet loss on 0 (eli käsittääkseni alle0.5%, muuten tuo kohta olisi tyhjä). Siitä eteenpäin seuraava PL% löytyy yllä mainitsemastani kohdasta ja on tällä hetkellä 24%.

Sellainen huomio että tuo matkalla olevien purkkien packet loss on ihan normaali ilmiö eikä vaikuta läpikulkevien pakettien välitykseen mitään. Eli jos kohdeosoitteeseen ei tule packet lossia niin kaikki toimii, matkalla olevien purkkien packet loss arvot johtuvat siitä että reitittimissä on rajoitettuna tuota tracerouten vaatimaa ttl expired-käsittelyä tiettyyn rajaan per sekuntti.

Sehän tuossa onkin kun se vaikuttaa. Tuo selkeä vika korjaantui, sähköpostiin tuli ensin tiketti vikailmoituksesta ja myöhemmin ilmoitus korjauksesta, jolloin järisyttävät ongelmat poistuivat.


Kannattaa testata niin että käsin pingaa noita epäilyttäviä reitittimiä ihan normi komentorivin pingillä, esim 1 paketti sekunnissa. Jos tuosta tulee packet lossia jatkuvasti niin jossain on vikaa. Samoin sitten tietty kannattaa kokeilla sinne kohdeosoitteeseen samaa.

Komentorivin pingi ja PingPlotter (1 trace per 5 sekuntia, eli erittäin rauhassa) antaa samoja tuloksia, edelleen tuosta samasta kohdasta ja se näkyy ihan selkeästi jumittamisena ja katkoksina. Varsinkin MMORPG reagoi siihen kymmenien sekuntien reagoimattomuudella tai sitten heittämällä ulos vikaviestillä "Connection Lost".

Korostettakoon nyt siis että ennen korjausta lossit olivat joka puolella pitkin karttaa, nyt sitä tulee vain tuosta yhdestä kohdasta. Se johtuuko tämä servun asetuksista vai ei on eri asia. Tosin, koska erittäin yhteysherkkä peli reagoi, oletan että jotain häikkää vielä on jossain.


Korostettakoon nyt siis että ennen korjausta lossit olivat joka puolella pitkin karttaa, nyt sitä tulee vain tuosta yhdestä kohdasta. Se johtuuko tämä servun asetuksista vai ei on eri asia. Tosin, koska erittäin yhteysherkkä peli reagoi, oletan että jotain häikkää vielä on jossain.


Eli niinkuin yritin ensimmäisessä viestissä hieman epäselvästi selittää niin jos sinne viimeiseenkin kohdeosoitteeseen asti tulee packet lossia niin sitten vikaa on jossain kohtaa - ilmeisesti jossain linjan/dlamin tasolla on ollut jos sitä on koko matkalla tullut.

Mutta ne yksittäiset elisa.net tain eunetip.net osoitteiset reitittimet tiputtavat "tunnettuna ominaisuutena" noita pingplotterin/tracerouten/mtr:n paketteja. Voit testata packet lossia komentoriviltä pingaamalla sitä samaa reitittimen ip:tä, pitäisi mennä puhtaasti läpi koska suorat ping echo requestit käsitellään eri tavoin kuin ttl expiroinnit laitteissa.

Parasta tosiaan olisi saada hieman pidemmältä ajalta suoraan esim pingillä testi sinne varsinaisen peliserverin osoitteeseen - silloin voisi varmistua että tosiaan jossain tippuu pakettia (tosin kohdekonekin voi tiputtaa tietyn rajan yli meneviä icmp paketteja joten koko totuutta sekään välttämättä kerro).
Yritän paremmalla ajalla pingailla tuota. Tosin juuri muutaman tunnin pelisession aikana useamman kerran jumautti koneen ja pari kestaa pisti yhteyden poikki, eli kyllä siellä jotain on. Tämä on siis uutta, en muista paria kuukautta kauempaa tästä kärsineeni.
Tässä pingituloksia Google.fi serverille, edustaa aika tyypillistä tulosta tässä viimeaikoina.

Ping statistics for 209.85.129.104 (saunalahti.fi):
Packets: Sent = 249, Received = 220, Lost = 29 (11% loss),
Approximate round trip times in milli-seconds:
Minimum = 38ms, Maximum = 67ms, Average = 44ms

Aiemmin ottamissani otoksissa 5-10 tuhannen pingin (maksimissaan 1 ping per sekunti, PingPlotterilla otetut siis 1 per 5 sekuntia) keskiarvoissa Saunalahden domainia pingatessa keskiarvoisesti packet lossit ovat tuollaista 4-7%, joka on aika hitonmoinen määrä hukattuja paketteja. Ensimmäiset tallentamani pingi statistiikat ovat päivämäärältä 7.8.2008 ja näyttävät tälläisiltä:

Ping statistics for *.*.*.*:
Packets: Sent = 613, Received = 568, Lost = 45 (7% loss),
Approximate round trip times in milli-seconds:
Minimum = 8ms, Maximum = 2404ms, Average = 37ms

Pakettien alhainen määrä johtuu siitä että tuossa vaiheessa vain kokeilin mitä ping sanoo.

Juuri tällä hetkellä kun tätä kirjoitan on verkko tilassa joka estää sen käyttämisen oikeastaan kokonaan. Latasin vastaus-sivua 7 kertaa ennen kuin "tärppäsi" ja nyt jännitän miten kirjoittamani tekstin lähettäminen tulee onnistumaan.
Kaveri toiselta puolelta Riihimäkeä valittaa samantyyppisistä ongelmista. "Netti pätkii helvetisti" oli siellä se ongelmakuvaus :)
Erona minun ja kaverin välillä noin 5 kilsaa (Hirsimäki - Peltosaari) sekä mulla Saunalahden liittymä ja kaverilla Elisan.

Kaveri toiselta puolelta Riihimäkeä valittaa samantyyppisistä ongelmista. "Netti pätkii helvetisti" oli siellä se ongelmakuvaus :)
Erona minun ja kaverin välillä noin 5 kilsaa (Hirsimäki - Peltosaari) sekä mulla Saunalahden liittymä ja kaverilla Elisan.


Tolla Saunis/Elisa liittymällä ei pitäisi olla mitään merkitystä, kun molemmat saavat IP:nsä Elisan IP-avaruudesta.

Mulle tulee Uramoon 24/1:stä tällä hetkellä noin 10,5/0,8 ja käsittääkseni DSLAmi jossa oon kiinni on Maisterinkadulla. Tänne ei pätki yhteys, kuparin pituus noin 2 km. Eli vika on selvästi sinne Peltsikka/Hirsimäki suuntaan. Mulla ei oo tietoa, onko Peltosaaressa oma DSLAmi, mutta ahkeraa pommitusta vaan edelleen tonne SaunaElisan suuntaan, että tulee kuntoon. Äkkisään tulis mieleen että kuparissa tapahtuu ylikuulumista, joka sotkee sun ADSL-päätelaitetta ja siksi noita paketteja katoaa.
Tästä puolestä mä en tiedä mitään, mutta pastetaan nyt kuitenkin tosta mun purkin diagnostiikasta.
Upstream Noise Margin:
noise margin upstream: 13 db
output power downstream: 19 db
attenuation upstream: 18 db

Downstream Noise Margin:
noise margin downstream: 6 db
output power upstream: 12 db
attenuation downstream: 32 db


Just oli tossa sellanen 5 minuutin hetki jossain packet loss ylitti 30% muutaman minuutin ajan, sitten taas rauhoittui. Noise marginit on sen jälkeen kun se rauhottui.
Yhteys aiheuttaa edelleen harmaita hiuksia ja tekee etätyöskentelystä aikalailla ikävää touhua.

Tässä tänään otettua ping statistiikkaa:
Ping statistics for (yhteyskriittinen serveri):
Packets: Sent = 4070, Received = 4016, Lost = 54 (1% loss),
Approximate round trip times in milli-seconds:
Minimum = 53ms, Maximum = 1897ms, Average = 75ms


Prosentin packet loss ja melkein 2000 millisekunnin vasteaikoja. Ei hyvä.
Veikkaisin että se ongelma on siinä Zyxelissä: http://palsta.saunalahti.fi/index.php/topic,10730.0.html

Itse vaihdan uuden purkin (ei Zyxeli) ja katson lähteekö toimimaan.
Sen verran tähän kuolleeseen aiheesen, että tuo ongelma selvisi lopulta ja syynä oli kastunut kaapelipari. Se vaihdettiin ja ongelma korjaantui ainakin omalta osaltani.

Tosin nyttemmin (6kk myöhemmin) hieman samantyyppisiä oireita on alkanut taas ilmenemään.
Joo 24/1 nopeus toteutuu enää 0,9-5/0,3 M   >:(

Kyrsii....

Lisätty 21.4.:
Zykkeli 660, jonka Saunalahti joskus 2006 oli toimittanut päätelaitteeksi vaihdettu Wippies homebox blackiin, minkä jälkeen toteutuu 9,6 / 0,84 M. Eli kaukana ollaan edelleen 24/1:stä, mutta nyt sentään taas nopeus on kuin ennen nopeuden mystistä putoamista ja kotitotaaliin kuuluva Saunavision levytila toimii taas normaalisti (=voi katsoa tallenteita).

Vanha Zykkeli taitaa lentää tässä vaiheessa kuikkaan...
No voihan kekkula. Taas on nopeudet alhaalla.

http://www.speedtest.net/result/456939056.png

Ja tämän pitäisi olla 24/1 M. Katsele tässä sitten tallenteita 😞