Kysymys

VDSL VMG3925-B10B – UPnP ei toimi

  • 18 maaliskuu 2018
  • 1 kommentti
  • 738 katselukerrat

Minulla on VDSL-yhteydessä modeemina VMG3925-B10B ja ethernet-portissa piuhalla kiinni QNAP TS-879 Pro NAS.
Aiemmin olen käyttänyt ko. NASia menestyksekkäästi DNA:n kaapelimodeemin takana L2TP VPN -palvelimena siten, että NAS on tehnyt modeemiin tarvittavat porttien ohjaukset ja palopuuripolicyt UPnP-ominaisuudella, eli minun ei ole tarvinnut konfiguroida ohjauksia.

VMG3925-B10B -laitteelle tuo QNAP ei onnistu tekemään UPnP-asetuksia; modeemin oletusasetuksilla QNAP ei tunnista verkosta UPnP reitittimiä. Kun naksuttelen VMG3925-B10B asetuksissa Network Setting / Home Networking / UPnP -välilehdellä UPnP State ja UPnP NAT-T State -asetuksia päälle ja pois ja haen samalla QNAPilla aina uudelleen verkosta UPnP-reitittiä, löytyy reititin lopulta kun UPnP on päällä ja UPnP NAT-T pois päältä – tosin siitä ei ole mitään apua sillä ko. välilehden NATtaus -tauluun ei tule näkyviin mitään ohjauksia ja NAS antaa tuloksena vain erroria…
QNAPin diagnoosityökalu kertoo silloin seuraavaa:

------ NAT PMP Diagnostics ------
initnatpmp() returned 0 (SUCCESS)
using gateway : 192.168.10.1
sendpublicaddressrequest returned 2 (SUCCESS)
readnatpmpresponseorretry returned -7 (FAILED)
------ UPnP Diagnostics ------
upnpc : miniupnpc library test client. (c) 2006-2011 Thomas Bernard
Go to http://miniupnp.free.fr/ or http://miniupnp.tuxfamily.org/
for more information.
List of UPNP devices found on the network :
desc: http://192.168.10.1:38400/description.xml
st: urn:schemas-upnp-org:device:InternetGatewayDevice:1

Found valid IGD : http://192.168.10.1:38400/WANIPConnection:1
Local LAN ip address : 192.168.10.61
Connection Type : IP_Routed
Status : Connected, uptime=1316s, LastConnectionError : ERROR_NONE
Time started : Sun Mar 18 18:33:53 2018
MaxBitRateDown : 0 bps MaxBitRateUp 0 bps
ExternalIPAddress = 91.152.230.66
GetGenericPortMappingEntry() returned 401 (Invalid Action)
INFO: No any UPnP port mapping entry is found.






Sain homman pelaamaan käsipelillä osittain:
Tein NAT-asetukset itse käsin Network Setting / NAT / Port forwarding -välilehdellä, mutta vain tuo portin 444 TCP ohjaus (joo, vaihdoin kokeilumielessä 443:n 444:ään) toimii moitteetta.

500, 4500 ja 1701 UDP porttien ohjaus ei toimi kunnolla. Siinä missä https://www.yougetsignal.com/tools/open-ports/ kertoo, että 444 TCP on auki, se kertoo että em. UDP-portit ovat kiinni.
Silti onnistun ottamaan L2TP-yhteyden toiselta QNAPin NASilta tuolle purkille. Yhteys pysyy yllä hetken ja katkeaa, eikä automaattinen uudelleenyhdistäminen toimi. Miten tämä on mahdollista?

Joten:
1. Miksi UpnP ei toimi?
2. Miten on mahdollista, että vaikka mielestäni olen tehnyt porttiohjaukset käsin oikein, niin porttiskannaus sanoo, ettei ko. portit ole auki (etenkin kun ko. porttien kautta saa yhteyden. Joka tosin ei ole käyttökelpoinen, koska se katkoo)?

1 kommentti

Käyttäjätaso 5
Kunniamerkki +2
MJHeikkinen, nyt ei kyllä itselläni ole tähän valitettavasti osaamista lähteä vastaamaan. 😕 Onko muilla palstalaisilla parempaa tietoa asiasta?

Osallistu keskusteluun