Kysymys

E353, Hi-Link ja reitittimet

  • 19 kesäkuu 2012
  • 23 kommenttia
  • 7316 katselukerrat

Käyttäjätaso 3
Kun kaikki vanhat modeemit alkoivat porsia, hommasin uuden E353:n ja iskin sen kiinni

TP-Linkin reitittimeen. Ei yhteyttä. Asensin sitten uusimman modeemitiedoston, jonka sai

TP-Linkin sivustolta. Ei yhteyttä.

Ajattelin sitten kokeilla laitetta Dovadossa, mutta ensin hain hiukan tietoja, vaikka laite olikin

listattu yhteensopivuusluettelossa. Dovadon edustaja kertoi tällaista eräällä palstalla:

"We (DOVADO) only support a certain flavor of the Huawei E353. What we DO NOT support is the variant containing a feature called "Hi-Link". This is a hurdle which renders the modem incompatible with any router on the market today that wants to use it as a conventional modem."

Suomeksi:  Hi-Link -malli E353:sta on vekotin, jota ei tue yksikään markkinoilla oleva reititin juuri tuon hiivatin Hi-Link -ominaisuuden vuoksi. Tanakele tämän tekniikan kanssa. 

Onkohan joku löytänyt vippaskonstia, jolla tuo tikku toimisi yhdenkään reitittimen kanssa?

23 kommenttia

Käyttäjätaso 6
Kunniamerkki +3
Saunalahdelta/Elisalta saatava E353 ei ole tuo Hi-Link -versio. Soneralta saatava sen sijaan on.

E: kokemusta ei ole mutta jos rauta on sama niin voisi mennä flashaamalla tuon ei-hilink-version firmis tikkuun.
Käyttäjätaso 3
day1 kirjoitti: E: kokemusta ei ole mutta jos rauta on sama niin voisi mennä flashaamalla tuon ei-hilink-version firmis tikkuun.

Ei pitäisi antaa "ehkä voisi" -neuvoja, jos niistä ei ole mitään kokemusta. Tuon ohjeen

avulla voi nimittäin olla yhtä laitetta köyhempi. Kauan sitten tein väsyneenä modeemiin päivitystä

ja sen tehtyäni huomasin ajaneeni väärän tiedoston. Se laite menikin sitten kerralla roskiin, sillä

palautuksen olisi voinut hoitaa vain valtuutettu huolto, jos sekään.
Käyttäjätaso 7
Kunniamerkki
Wnap(c) + HiLink E353 toimii. A-Linkin sivuilta löytyy erillisohje tuon nimenomaisen tikun asentamiseksi.

Villein ominaisuus ko. yhdistelmässä on se, että routterin läpi pääsee käsiksi tikun hallintasivuun. Harmi vain, että se on ainakin vielä puutteellinen esim. signaalinäytön ja säätämisen suhteen.

OffT: Vaikka tuossa HiLink-versiossa on omat puutteensa, niin enemmän kyllä käytössä painaa ajurittomuus, yhdistämisnopeus yms. Ei ole paljon järkeä päivittää ajuriversioon vai eikö E367:a ole enää kaupan missään? Ovat muilta ominaisuuksiltaan hyvin lähellä toisiaan...
Käyttäjätaso 3
KoTe60 kirjoitti:
OffT: Vaikka tuossa HiLink-versiossa on omat puutteensa, niin enemmän kyllä käytössä painaa ajurittomuus, yhdistämisnopeus yms. Ei ole paljon järkeä päivittää ajuriversioon vai eikö E367:a ole enää kaupan missään? Ovat muilta ominaisuuksiltaan hyvin lähellä toisiaan...

Arvaapa kahdesti, olisinko e367:n ottanut, mutta kun niitä ei löytynyt mistään enää kuukausikaan

sitten. Viimeinen, jonka sain, oli malli, jossa oli vain 2100 MHz verkko.

Sen 353:n p*läjän saa näköjään toimimaan TP-Linkissä joten ja kuten, kun muuttaa reitittimen IP:n samaan

aliverkkoon, johon 353 väen väkisin asettuu (sen kiinteä osoite on 192.168.1.1 ja en keksinyt, miten sen voisi

ehkä muuttaa). Tämän jälkeen koko verkko onkin sitten konffattava uusiksi, jotta kaikki toimisi satavarmasti.

Tulee mieleen Zyxelin romujen kanssa tappelu 5+ vuotta sitten.

Verrattuna E367-malliin ja jopa ZTE:n MF363:een se vaikuttaa kuitenkin aika keskinkertaiselta laitteelta ja

vauhti on selvästi huonompi, lieneekö syynä tuo ylimääräinen NAT-kerros.

Melko kypsä alkaa olla tähän tekniikan kanssa leikkimiseen, kun muutakin tekemistä olisi.

Tähän kun lisää vielä sen, että A-Linkin laatulaite tipauttaa taas joka toisella käynnistyskerralla APN:stä pois Saunalahden tarvitseman lisärimpsun niin jo on kivaa.
Käyttäjätaso 3
joesmith kirjoitti: Tähän kun lisää vielä sen, että A-Linkin laatulaite tipauttaa taas joka toisella käynnistyskerralla APN:stä pois Saunalahden tarvitseman lisärimpsun niin jo on kivaa. 

Mikä tuo lisärimpsu on?
Käyttäjätaso 6
Kunniamerkki +3
Tulppu kirjoitti:
joesmith kirjoitti: Tähän kun lisää vielä sen, että A-Linkin laatulaite tipauttaa taas joka toisella käynnistyskerralla APN:stä pois Saunalahden tarvitseman lisärimpsun niin jo on kivaa. 

Mikä tuo lisärimpsu on?

Internet.saunalahti.
Käyttäjätaso 7
Kunniamerkki +3
joesmith kirjoitti:
Verrattuna E367-malliin ja jopa ZTE:n MF363:een se vaikuttaa kuitenkin aika keskinkertaiselta laitteelta ja

vauhti on selvästi huonompi, lieneekö syynä tuo ylimääräinen NAT-kerros.

Vai tarkoitatko hukkainvestointia MF636?
Ainakin Telewellin TW-EA510 3G/4G mallin kanssa tuo kyseinen Hi-Link tikku toimii kuin unelma. Boxi piti ensin päivittää uusimpaan versioon mutta sen jälkeen se toimii suoraan mitään asetuksia muuttamatta.
Käyttäjätaso 3
Hyvis kirjoitti:Vai tarkoitatko hukkainvestointia MF636?

MF636:tta juuri, mutta yli melkein kolme vuotta päämodeemeina käyttämiäni (kyllä, kaksi niitä on)

en ihan hukkainvestoinniksi sanoisi. Vasta nyt ne alkavat porsia kunnolla. No, en kyllä kehukaan

jos vertaan E367-tikkuun.
Käyttäjätaso 3
day1 kirjoitti:
Tulppu kirjoitti:
joesmith kirjoitti: Tähän kun lisää vielä sen, että A-Linkin laatulaite tipauttaa taas joka toisella käynnistyskerralla APN:stä pois Saunalahden tarvitseman lisärimpsun niin jo on kivaa. 

Mikä tuo lisärimpsu on?

Internet.saunalahti.

Tarvitseeko sitä lainkaan kun olen käsittänyt että kun sen kerran at-komennolla antaa modeemille, niin eikö se pysy modeemin muistissa jolloin alustuskomentoa ei tarvitse?
Käyttäjätaso 3
poko kirjoitti:
Ainakin Telewellin TW-EA510 3G/4G mallin kanssa tuo kyseinen Hi-Link tikku toimii kuin unelma. .

Mille IP-alueelle tuo Telewellin vekotin oli asennettu( siis 192.168.1.x vaiko jokin muu)? TP-Link toimii nyt myös, mutta kuten sanoin, se ei osannut reitittää oletusverkostani (192.168.0.x) E353:n ainoaan vaihtoehtoon eli 192.168.1.1. Vasta kun vaihdoin sen verkkoasetukset, homma alkoi toimia, mutta samalla piti sitten muuttaa verkossa olevien kaikkien laitteiden verkkoasetukset.

Jos joku tietää, miten tuon E353:n pakko-ip:n saa muutetuksi joksikin muuksi kuin 192.168.1.1, kertokoon, kiitos.
Käyttäjätaso 3
Tulppu kirjoitti:
TArvitseeko sitä lainkaan kun olen käsittänyt että kun sen kerran at-komennolla antaa modeemille, niin eikö se pysy modeemin muistissa jolloin alustuskomentoa ei tarvitse?

Heh, ei se ihan noin ole. Reititin antaa  APN:n modeemille ennen yhteyskomentona ja muisti modeemi sen tai ei,

se antaa sen joka kerralla.  Tässä hiukan lokitiedostoa, josta näet, kuinka homma etenee. Päiväyksestä ei kannata välittää, sillä A-Link valitsee myös minkä päivän huvittaa ja yrittää hakea tuoretta päiväystä Internetistä ennen yhteyden syntymistä. Fiksua, eikö totta?

Tuo lihavoitu ensimmäinen "send" muodostuu siis asetuksissa olevasta APN-asetuksesta ja ilmeisistä oletuskomennoista. Sitä ei minun ymmärrykseni mukaan voi poistaa. Ja kun A-Linkin laatulaite poistaa itsestään tuon ".saunalahti", yhteys ei synny ennen sen korjaamista (ja vekottimen boottia).

Nov 16 17:44:20 192.168.0.100 chat[9241]: send (AT+ZSTART^M)
Nov 16 17:44:20 192.168.0.100 chat[9241]: expect (OK)
Nov 16 17:44:20 192.168.0.100 chat[9241]: ^M
Nov 16 17:44:20 192.168.0.100 chat[9241]: AT+ZSTART^M^M
Nov 16 17:44:20 192.168.0.100 chat[9241]: OK
Nov 16 17:44:20 192.168.0.100 chat[9241]: -- got it
Nov 16 17:44:20 192.168.0.100 chat[9241]: send (AT+CGDCONT=1,"IP","internet.saunalahti"^M)
Nov 16 17:44:21 192.168.0.100 chat[9241]: expect (OK)
Nov 16 17:44:21 192.168.0.100 chat[9241]: ^M
Nov 16 17:44:21 192.168.0.100 chat[9241]: AT+CGDCONT=1,"IP","internet.saunalahti"^M^M
Nov 16 17:44:21 192.168.0.100 chat[9241]: OK
Nov 16 17:44:21 192.168.0.100 chat[9241]: -- got it
Nov 16 17:44:21 192.168.0.100 chat[9241]: send (ATDT*99#^M)
Nov 16 17:44:21 192.168.0.100 chat[9241]: expect (CONNECT)
Nov 16 17:44:21 192.168.0.100 chat[9241]: ^M
Nov 16 17:44:21 192.168.0.100 chat[9241]: ATDT*99#^M
Nov 16 17:44:21 192.168.0.100 chat[9241]: CONNECT

Tuotakaan lokia ei A-Linkistä saa suoraan, vaan se on kerätty lokipalvelimena tomivalta Linux-palvelimelta, joka tallentaa sen nätisti, kun A-Link ei osaa.
joesmith kirjoitti:
poko kirjoitti:
Ainakin Telewellin TW-EA510 3G/4G mallin kanssa tuo kyseinen Hi-Link tikku toimii kuin unelma. .

Mille IP-alueelle tuo Telewellin vekotin oli asennettu( siis 192.168.1.x vaiko jokin muu)? TP-Link toimii nyt myös, mutta kuten sanoin, se ei osannut reitittää oletusverkostani (192.168.0.x) E353:n ainoaan vaihtoehtoon eli 192.168.1.1. Vasta kun vaihdoin sen verkkoasetukset, homma alkoi toimia, mutta samalla piti sitten muuttaa verkossa olevien kaikkien laitteiden verkkoasetukset.

Jos joku tietää, miten tuon E353:n pakko-ip:n saa muutetuksi joksikin muuksi kuin 192.168.1.1, kertokoon, kiitos.


Telewell antaa osoitteita muotoa 192.168.0.x

192.168.0.254 osoitteella pääsee Telewellin asetuksiin ja 192.168.1.1 osoitteella taas E353:n. Mitään ei tarvitse muuttaa välissä.
Käyttäjätaso 3
joesmith kirjoitti:
Heh, ei se ihan noin ole. Reititin antaa  APN:n modeemille ennen yhteyskomentona ja muisti modeemi sen tai ei,se antaa sen joka kerralla.  
Ok, mulla on vaan yhden kaverin reititin (edup) ollut lainassa enkä näitä itse tarvitse, niin voi olla väärä käsitys. Mutta ainakin ilman reititintä E367 on ottanut yhteyden ihan nätisti antamalla komennon +CGDCONT=1 ilman tuota lisäkomentoa koska se on modeemin muistissa.

Edit: kokeilin äsken eikä tuo aiemmin kirjoittamani toimi vaan nollaa koko 1 kontekstin. Mutta kun sen on kerran antanut ja testannut +CGDCONT? -komennolla että näkyy, niin sen jälkeen sitä ei tarvitse toistaa vaan ainakin  E367 yhdistää komennolla ATDT *99# ilman ongelmia. Itse olen tosin siirtynyt käyttämään ndis:iä koska se tuntuu yhdistävän hieman nopeammin. Kiitos vielä KoTe60:lle neuvosta. 🙂
Käyttäjätaso 7
Kunniamerkki +3
joesmith kirjoitti:
Hyvis kirjoitti:Vai tarkoitatko hukkainvestointia MF636?

MF636:tta juuri, mutta yli melkein kolme vuotta päämodeemeina käyttämiäni (kyllä, kaksi niitä on)

en ihan hukkainvestoinniksi sanoisi. Vasta nyt ne alkavat porsia kunnolla. No, en kyllä kehukaan

jos vertaan E367-tikkuun.

Tuo hukkainvestointi oli oikeastaan vitsinä heitetty, koska MF636 ei taida olla kovin hyvämainennen. Minullakin on sellainen ollut käytössä, enkä huomannut siinä mitään erikoista ongelmaa verrattuna esimerkiksi tikkuun MF668. Tuo E367 on minunkin mielestäni ihan kelpo tikku.

Oletko muuten koskaan kokeillut entistä Saunalahti Prepaid Mobiiliilaajakaistan mukana tullutta tikkua olikohan se E353? Kuulemani mukaan toimisi ainakin kaupungin keskustassa vauhdikkaammin kuin E1820?
Käyttäjätaso 7
Kunniamerkki
En tiedä, osaako muut reitittimet muuttaa tuon E353:n SIM:miin mukaisen profiilin APN:ää, mutta Wnap(c) ei ainakaan osaa. On siis ihan sama, mikä APN-asetus Wnapissa on; tikku yhdistää tallennetun profiilin mukaiseen APN:ään. Todella kätevää, jos usean operaattorin "loukussa".

Hyvis kirjoitti:
Oletko muuten koskaan kokeillut entistä Saunalahti Prepaid Mobiiliilaajakaistan mukana tullutta tikkua olikohan se E353? Kuulemani mukaan toimisi ainakin kaupungin keskustassa vauhdikkaammin kuin E1820?

Vai oliko E153? Ja jos E153 on jossakin paikassa nopeampi kuin vanha kunnon E1820, on jotakin verkon tms. suhteen pahasti pielessä. Yleensäkin noihin kuulopuheisiin jonkin laitteen paremmuudesta toiseen verrattuna pitää suhtautua samalla varauksella kuin verkkovertailuihinkin: käyttöpaikan merkitys on liian suuri, eikä mitään varmoja johtopäätöksiä kannata tehdä. 
Käyttäjätaso 7
Kunniamerkki +3
Oletko muuten koskaan kokeillut entistä Saunalahti Prepaid Mobiiliilaajakaistan mukana tullutta tikkua olikohan se E353? Kuulemani mukaan toimisi ainakin kaupungin keskustassa vauhdikkaammin kuin E1820?
Vai oliko E153? Ja jos E153 on jossakin paikassa nopeampi kuin vanha kunnon E1820, on jotakin verkon tms. suhteen pahasti pielessä. Yleensäkin noihin kuulopuheisiin jonkin laitteen paremmuudesta toiseen verrattuna pitää suhtautua samalla varauksella kuin verkkovertailuihinkin: käyttöpaikan merkitys on liian suuri, eikä mitään varmoja johtopäätöksiä kannata tehdä. 


Luultavasti se juuri tuo on kun en muista. Epäilin sitä kyllä itsekin ja aika vahvasti. Olisin antanut eräälle kaverille lainaksi juuri tuon E1820:n ja oli sitten testaillut. Sattui löytämään itseltään sen Prepaid-tikun. Mutua kyllä, koska ei varmasti ole mitään nopeustestejä tehnyt. Oli kuulemma tosi hidas lataamaan YouTubea. Mutta sehän on hetkittäistä, eikä varmasti ole testannut sitä kaikkina aikoina. Paikka on kyllä haastava, sillä kyseessä on kivitalo keskellä Oulun keskustaa.Olen varma, että siinä on soluja ihan riesaksi asti.
Käyttäjätaso 7
Kunniamerkki
Hyvis kirjoitti:
Paikka on kyllä haastava, sillä kyseessä on kivitalo keskellä Oulun keskustaa.Olen varma, että siinä on soluja ihan riesaksi asti.
Ainakin paikka on tyypillisesti sellainen, jossa hitaampi tikku voi hyvinkin olla nopeampi. Mutta juuri näitä tilanteita varten minäkin vinkkailen testaamaan taajuus- ja kaistalukituksia ym. säätöjä. Niillä löytyy useissa paikoissa sen verran lisävauhtia, että "mopo-tikut" jää jalkoihin.

OnT: Ei TP-MR3420:nkään kovin kranttu ollut tuon HiLink-tikun suhteen. Päivitin purkkiin uusimman firmiksen, hain TP-Linkin Bin File Centeristä tikulle tarkoitetun filun ja asensin sen, ja muuta ei sitten tarvittukaan.

Mielenkiintoista tuossa on se, että TP-Link ei ilmeisesti tajua tuota tikkua reitittimenä (kuten Wnap(c)) vaan verkkokorttina, koska näyttää Sauniksen NAT-ip:n ulkoverkkoyhteyden osoitteena. Elikkäs vaikuttaa siltä, että tässä systeemissä EI ole kahta sisäverkkoa "perätysten". Eikä myöskään pääse käsiksi tikun hallintasivuun, mutta tuolla eipä siellä kummoisia säätömahdollisuuksia olekaan. 

Vaikutuksesta nopeuteen tms. on paha mennä sanomaan; samaa 10-15M dl näyttää tulevan, mitä kaikilla muillakin vehkeillä. Ja tuo näin mökkikäytössä riittää vallan mainiosti.
Käyttäjätaso 3
KoTe60 kirjoitti: OnT: Ei TP-MR3420:nkään kovin kranttu ollut tuon HiLink-tikun suhteen. Päivitin purkkiin uusimman firmiksen, hain TP-Linkin Bin File Centeristä tikulle tarkoitetun filun ja asensin sen, ja muuta ei sitten tarvittukaan.

TP-MR3220:n kanssa oli taas niin, että yhteys syntyi ilman modeemitiedostoja. Kun asensin tuon File Centeristä saadun, se e i luonut yhteyttä ollenkaan. Sitten kun poistin modeemitiedoston ja boottasin, yhteys syntyi ja vekotin oli tunnistanut E353:n (kuten ensimmäiselläkin kerralla).

En tuohon enää jaksanut paneutua, kun oli riittävästi ongelmaa sen aliverkon kanssa. Vasta kun reittimen konffasi siten, että se näki myös 192.168.1.1:n, pystyin pingaamaan sekä Huaweita että ulkoverkkoa. Ilman modeemitiedostoa status on tämä:

3G USB Modem:Identified successfully
IP Address:10.170.12.15
Subnet Mask:255.255.255.255
Default Gateway:10.170.12.15
DNS Server:195.197.54.100 , 195.74.0.47
Online Time:1 day(s) 06:41:04
No, nyt se pelaa sen verran hyvin, että saa jäädä tuohon tilaan. En aio enää testailla modeemitiedostoilla, ehjää ei kannata korjata.
Käyttäjätaso 7
Kunniamerkki
On nää villejä veitikoita, sekä purkit että tikut.

Täytyy kyllä myöntää, etten edes kokeillut tikkua ennen tuon modeemitiedoston asennusta. Sellainenkin tuli mieleen, että onkohan näistä HiLink-tikuistakin useampia versioita maailmalla. Erään hys-hys-softan valikoista löytyi muistaakseni 5 eri versiota tästä E353:sta. 

Purkitkin taitaa wlanin mimo-tukea lukuunottamatta olla yks-yhteen.

Tuota reitittimen konftausta en ymmärrä: Vaihdoitko purkin lan-avaruuden joksikin toiseksi vai miten?

Palautetta purkki-tikku -yhdistelmän toimivuudesta - tai ainakin huonosta sellaisesta - kuulen varmaan pian, koska tuuppasin yhdistelmän paremman puoliskon käyttöön. Aikaisemmin purkissa oli kiinni E1820 viimeiset reilut puoli vuotta ja sen kanssa sai "korvat olla rauhassa"...;)
Käyttäjätaso 3
KoTe60 kirjoitti:
Tuota reitittimen konftausta en ymmärrä: Vaihdoitko purkin lan-avaruuden joksikin toiseksi vai miten?

Joo, purkki oli alun perin samassa 255 osoitteen aliverkossa kuin ~10 muuta päätelaitetta eli 192.168.0.xxx. Sitten muutin sen aliverkkoon 192.168.1.xxx ja saman tien kaikkien päätelaitteiden netmaskiksi 255.255.254.0, jotta niistä pääsisi myös tarpeen tullen tuon reitittimen kautta ulos.
Käyttäjätaso 7
Kunniamerkki
Roger that.

Epäilen muuten tuon modeemitiedoston suhteen, että se on jo mukana tuossa uusimmassa firmiksessä. On tuo tikku sen verran poikkeuksellinen, että vaatii purkin firmikseltä täyden tuen. Tai sitten TP-Link on keksinyt jonkin ihmeellisen keinon päästä "sisään" tuohon tikkuun. Se kun ei millään vehkeellä näytä suoraan noita sisäisiä laitteitaan.
Käyttäjätaso 3
Kyllä tuossa Elisan verkossa on nyt jotakin merkillistä tekeillä. ZTE:n kaksi modeemia lakkasivat toimimasta kunnolla vähän ennen tuon E353:n hankkimista. E353 on toiminut kohtuullisen hyvin tuon TP-Linkin kanssa, mutta nyt alkaa tulla sellaisia ilmiöitä, että ei enää minun järkeni riitä selittämään niitä.

Tänä aamuna olikin pakko vaihtaa Soneran täysnopeusnettiin kun työnteosta ei tullut enää mitään. Jos Saunalahden ongelmat jatkuvat, se on kohta minun 20 euroani/kk köyhempi.

Mutta asiaan. E353 ottaa nätisti yhteyden TP-Linkin avulla ja kaikki näyttää olevan kunnossa. Vaan ei ole. TP-Linkissä on mahdollisuus pingata haluamaansa palvelinta tai IP-osoitetta. Katsotaanpa, testaan omalla palvelimellani:

Ensin IP-numerolla : 92.48.88.31:

Pinging 92.48.88.31 with 64 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Tätä en sitten enää käsittänyt: Testataa nimellä ns1.indeedsir.com:

Pinging ns1.indeedsir.com [92.48.88.31] with 64 bytes of data:

Reply from 92.48.88.31: bytes=64 time=119 TTL=54 seq=1
Reply from 92.48.88.31: bytes=64 time=109 TTL=54 seq=2
Reply from 92.48.88.31: bytes=64 time=117 TTL=54 seq=3
Reply from 92.48.88.31: bytes=64 time=119 TTL=54 seq=4

Miten ihmeessä tuo voi olla mitenkään mahdollista? Toistin tuon kolme kertaa peräkkäin ja tulos on aina sama. Hassuinta on, että kun työasemalta pingaa, molemmat toimivat hyvin. Vika saattaa hyvinkin olla TP-Linkin ja E353:n välissä, mutta merkillistäkin merkillisempi se on.

Oudoksuttaa kyllä myös tuo kahden ZTE:n toimintahäiriöiden alkaminen juuri ison verkkohuollon jälkeen, aivan kuin jokin olisi muuttunut koko verkossa. Ja juuri tätä tämä tappelu on ollut parisen viikkoa:

1861st day 22:27:02PPPERRORLCP down
1851st day 22:27:02PPPERRORUser request
1841st day 22:27:023GWARNINGDetect 3G link failed, 3G link is down
1831st day 22:16:173GNOTICE3G connected
Muutaman minuutin välein yhteys poikki, teki mitä tahansa. Sitten pari minuuttia ja taas mennään vähän aikaa yhden ja kahden megan vauhdeilla. TeliaSoneralla ja väärin suunnatulla antennilla vauhti on kymmenkertainen.

Osallistu keskusteluun