Vastattu

Huawei b315 ja ipv6 julkinen ip ongelmia (reititys?)

  • 2 lokakuu 2015
  • 20 kommenttia
  • 3869 katselukerrat

  • Satunnainen osallistuja
  • 11 kommenttia
Laitteena Huawei B315 ja Super 4G liittymä.

Ongelmana on että julkiset ipv6 osoitteet eivät toimi ajoittain.

viimeimpänä ne toimivat useamman päivän putkeen, ja tänään noin 11.20 jonka jälkeen en päässyt mihinkään ipv6 osoitteeseen, esim ipv6.google.com ja test-ipv6.com antoi ettei ole julkista ipv6 osoitetta. Boottasin reitittimen, ei vaikutusta, boottasin uudestaan noin 16.00 ja ipv6 osoitteet alkoivat toimia uudestaan. (joka bootilla b315 ja sisäverkon laitteet saavat ipv6 osoitteen) mutta reititys ei vaan toimi ulospäin? en nyt huomannut kokeilla, mutta aikaisemmin esim ipv6 traceroute ei päässyt gatewaytä pidemmälle

sisäverkossani on esim. raspberry pi jossa on B315:n antama julkinen ipv6 osoite, johon en täten aina pääse kiinni ulkoverkosta.

kyseessä on joko ongelma B315 reitittimessä tai sitten todennäköisemmin elisan päässä että ipv6 osoitteet eivät reitity oikein? onko muut huomanneet samanlaisia ongelmia tai osaako joku kertoa kuinka tehdä vakaampi yhteys.

(ipv4:sta en halua maksaa)
icon

Vastauksen tähän kysymykseen jakoi atnu 4 lokakuu 2015, 12:23

Nyt taisi alkaa syy selviämään,

seurailin b315 system - device information signaalien voimakkuuksia ja painelin refresh nappulaa

hetken päästä WAN ipv4 ja ipv6 osoitteeksi tuli unknown ja parin sekunnin päästä tästä se sai uudet ip osoitteet. (cellid pysyi samana kokoajan)

tämän jälkeen aliverkosta ei enää päässyt ipv6 osoitteisiin (koska b315 oma ipv6 julkinen osoite päivittyi ja reititys ei enää toiminut. (tod. näk. Elisa invalidoi aikaisemmat aliverkon julkiset ipv6 osoitteet?)

Nyt kun aliverkon laitteilla haki uudet osoitteet (interface disable enable jumppa)  (ipv4 pysyi samana kuten pitikin, mutta sai uuden julkisen ipv6 osoitteen) ja tämän jälkeen alkoi ipv6 osoitteet toimimaan taas.

eli ongelma on se että kun b315 saa jostain syystä uuden WANipv4/6 osoitteen elisalta vaikkei yhteys katkea, ja koska myös aliverkon uudet ipv6 osoitteet tulee elisalta ei b315 osaa kertoa aliverkon laitteille että pitäisi hakea uusi ipv6 osoite.

onko vika sitten b315:ssä vai elisan konfiguraatiossa en osaa vielä sanoa, mutta lähtökohtaisesti ongelma pääsisi eroon jos ipv4/v6 osoite ei vaihdu kesken kaiken ja jos se jostain syystä vaihtuisi pitäisi b315 osata välittää tämä tieto aliverkoille laitteille.

Tarvitsee tutustua ipv6 autoconfiguratioon yms spekseihin jos tämän saisi aliverkon linux koneissa handlattua jotenkin automaattisesti.

Tarvitsee varmaan silti tehdä vika ilmo elisalle että he voisivat tutkia ja mahdollisesti ratkaista ongelma ettei asiakkaan tarvitse tehdä työtä heidän puolesta..

Katso alkuperäinen viesti

20 kommenttia

Käyttäjätaso 5
  • ? Tervetuloa Palstalle :)

    En osaa suoraan vastata, mistä voisi johtua. Onko Palstalaisilla vastaavia kokemuksia?

    Täällä jotain aihetta sivuavaa, ainakin porttiohjauksia kannattaa testata. http://yhteiso.elisa.fi/t5/Mobiililaajakaistat/Huawei-B315-ja-julkinen-ip-osoite/m-p/460908
  • Jokainen b315 taakse kytketty laite saa myös automaattisesti julkisen ipv6 osoitteen, joten NAT ja porttiohjaukset on lähinnä jäänne ipv4 ajoista jota ko. linkki koskee :)

    Sellaisen huomasin kun ongelma toistui jälleen, että kun b315 vaihtaa 1800 ja 800Mhz välillä mastoa/keilaa ongelma tulee esille useammin, voisiko olla jotain handover reititys ongelmia joko b315:ssä  tai operaattorilla?

    Kokeilin nyt ltewatchilla että b315 käyttäisi vain 800MHz taajuutta että yhteys pysyisi samassa tolpassa, ja seurailen onko parannusta.
    Käyttäjätaso 4
    Tyhmä kysymys:

    Jos taajuus vaihtuu, vaihtuuko IP samalla? Tuli vain mieleen, jos sillä olisi yhteys tähän NAT ongelmaan.
    Nyt ipv6 osoitteet toimivat taas vain noin 2h ja b315 rebootti ratkaisi ongeman..

    vaikka b315 tajuus on lukittu 800Mhz silti se vaihtelee yhteyttä kahden eri maston välillä..

    tarvitsee kehittää lisää foliota antennin ympärille ettei se vaihele ja tutkia lisää...

    pikaisesti kun katsoin niin kahden 800Mhz maston välillä kun vaihtui yhteys (cellid) ip osoite pysyi samana,

    mutta tässä varmaan ongelmaksi tulee kun se vaihtaa tuota mastoa minuutinvälein ja siitä tulee ongelmaa ajankuluessa?

    Tsekkaan huomenna tarkemmin kuinka useasti ip vaihtuu ja löytyykö jotain korrelaatiota kun on paremmin aikaa..

    mutta ei tälläistä ongelmaa pitäisi lähtökohtaisesti olla tuotteessa johonka vain reboottii auttaa...
    Käyttäjätaso 6
    Kunniamerkki +3
    atnu kirjoitti:
    Nyt ipv6 osoitteet toimivat taas vain noin 2h ja b315 rebootti ratkaisi ongeman..

    vaikka b315 tajuus on lukittu 800Mhz silti se vaihtelee yhteyttä kahden eri maston välillä..

    tarvitsee kehittää lisää foliota antennin ympärille ettei se vaihele ja tutkia lisää...

    pikaisesti kun katsoin niin kahden 800Mhz maston välillä kun vaihtui yhteys (cellid) ip osoite pysyi samana,

    mutta tässä varmaan ongelmaksi tulee kun se vaihtaa tuota mastoa minuutinvälein ja siitä tulee ongelmaa ajankuluessa?

    Tsekkaan huomenna tarkemmin kuinka useasti ip vaihtuu ja löytyykö jotain korrelaatiota kun on paremmin aikaa..

    mutta ei tälläistä ongelmaa pitäisi lähtökohtaisesti olla tuotteessa johonka vain reboottii auttaa...

    Nuo mastovaihtelut voit poistaa kahdella hyvällä suunta-antennilla.
    Liittymä ollut vasta viikon käytössä, ja suunta-antennit ovat työn alla, foliovirityksillä siihen asti. nyt on taas ipv6 verkot toimineet ongelmitta eilen yöstä asti, tarvitsee katsoa jos se taas illan tullen alkaa pätkimään.
    nyt illalla about 22.00 aikoihin taas ipv6 osoitteet lakkasivat toimivasta:

    traceroute -6 ipv6.google.com
    traceroute to ipv6.google.com (2a00:1450:4010:c08::8a), 30 hops max, 80 byte packets
    connect: Network is unreachable

    kun b315 boottasi alkioi taas toimivaan ok, pitäisikö tästä tehdä vikailmoitus jonnekin vai minkä takia tämä on näin epästabiilia?

    kenelläkään ideoita, tämä tekee elisan ipv6 käytöstä ihan käyttökelvottoman, koska reititintä saa bootaat jatkuvasti ja etänä se ei onnistu..
    Käyttäjätaso 7
    Kunniamerkki +2
    Ehkä pitäisi kokeilla toisellakin päätelaitteella? Etäbuutti onnistuu, kun laitat sähkönsyöttöön etäohjattavan kytkimen, eli voit tekstiviestillä katkaista sähkön ja laittaa takaisin päälle.
    Nyt taisi alkaa syy selviämään,

    seurailin b315 system - device information signaalien voimakkuuksia ja painelin refresh nappulaa

    hetken päästä WAN ipv4 ja ipv6 osoitteeksi tuli unknown ja parin sekunnin päästä tästä se sai uudet ip osoitteet. (cellid pysyi samana kokoajan)

    tämän jälkeen aliverkosta ei enää päässyt ipv6 osoitteisiin (koska b315 oma ipv6 julkinen osoite päivittyi ja reititys ei enää toiminut. (tod. näk. Elisa invalidoi aikaisemmat aliverkon julkiset ipv6 osoitteet?)

    Nyt kun aliverkon laitteilla haki uudet osoitteet (interface disable enable jumppa)  (ipv4 pysyi samana kuten pitikin, mutta sai uuden julkisen ipv6 osoitteen) ja tämän jälkeen alkoi ipv6 osoitteet toimimaan taas.

    eli ongelma on se että kun b315 saa jostain syystä uuden WANipv4/6 osoitteen elisalta vaikkei yhteys katkea, ja koska myös aliverkon uudet ipv6 osoitteet tulee elisalta ei b315 osaa kertoa aliverkon laitteille että pitäisi hakea uusi ipv6 osoite.

    onko vika sitten b315:ssä vai elisan konfiguraatiossa en osaa vielä sanoa, mutta lähtökohtaisesti ongelma pääsisi eroon jos ipv4/v6 osoite ei vaihdu kesken kaiken ja jos se jostain syystä vaihtuisi pitäisi b315 osata välittää tämä tieto aliverkoille laitteille.

    Tarvitsee tutustua ipv6 autoconfiguratioon yms spekseihin jos tämän saisi aliverkon linux koneissa handlattua jotenkin automaattisesti.

    Tarvitsee varmaan silti tehdä vika ilmo elisalle että he voisivat tutkia ja mahdollisesti ratkaista ongelma ettei asiakkaan tarvitse tehdä työtä heidän puolesta..
    Itselläni on ollut ongelmia ipv6:n kanssa. Laitteistoissa oli oletuksena kyseinen palvelu päällä verkkoasetuksissa ja ajoittain se toimi hyvin, mutta suurimman osan ajasta nettiselailussa sivujen aukeamiseen tuli tuli noin 4-6 sekunnin viive. Tämän ongelman takia kaikista tietokoneista piti kytkeä verkkoasetuksista ipv6 pois päältä ja toimia ipv4:n varassa jolloin hitautta ei ole. Modeemi sama eli Huawei b315-22.
    Tuo ongelma johtuu ainakin itsellä juuri tuosta, että kun julkinen ip vaihtuu b315 boksiin, aliverkon laitteiden ipv6 osoitteet vanhenevat ja tämän jälkeen mikään ipv6 ei toimi, esim google.com.

    Koska suurin osa selaimista huomaa että ipv6 on käytössä,yrittää se käyttää sitä ja koska se ei toimi, yhteys timeouttaa ja siirtyy ipv4:lle ja käyttäjät huomaa tämän viiveenä.
    Ainakin Linuxissa voi laittaa täpän repoissa kohtaan 6tunnel. Pelaa TCP- välipalvelimella ipv6:sta ymmärtämättömillä sivuilla. On vaihtuva IP-osoite, mutta voihan sen ipv6:n ottaa pois. Mulla juurikin tuo purkki.
    Käyttäjätaso 4
    Kunniamerkki
    sama purkki ja samat ongelmat.piti ottaa ipv6 pois päältä koneista kun ei jaksanu sivuja vartoilla.ja itsellä operaattorivapaa malli 21.311.03.00.983 ohjelmistolla.muuten toimii hyvin ja vakaasti.ja aikas kehnosti löytyy ladattavia firmiksiä tähän vehkeeseen että vois vähän testailla.
    Miten B315 saa lukittua tietylle taajudelle mulla olis1800mhz
    Käyttäjätaso 6
    Kunniamerkki +3
    http://www.lte-anbieter.info/ltewatch/huawei.php

    Käytä tuota jos ei valintaa asetuksista löydy.
    Hei moi!

    Ellen ihan väärin ymmärrä, niin minulle on ruvennut tulemaan samanlaista oireilua sen jälkeen kun Elisalla siirryttiin IPv6-aikaan. Nettiyhteys hukkuu johonkin ja tulee takaisin kun käynnistää B315:n uudelleen. Tapahtuu minusta vähintään pari kertaa tunnissa.

    Hmm?
    Kokeilin tätä uudestaan 8kk jälkeen ja ipv6 toimii aivan yhtä surkeasti kuin aikaisemminkin. mitään parannusta tähän ei ole tullut. tyhmää mainostaa ipv6:sta kun se ei 8kk jälkeen toimi vieläkään.
    Käyttäjätaso 3
    Joko tuo ipv6 toimii b315 purkeilla? Ajattelin hankkia sellaisen mökille ipv6 ip-kameroille.
    Käyttäjätaso 6
    Kunniamerkki +1
    Todella vanha ketju, mutta asiaa kylläkin. Mitenköhän toiminta lienee tänä päivänä? Tuosta yltä ei löytynyt mainintaa, että olisi kertaakaan esim. vikaria tehty, joten jos edelleen ongelmia on, niin ihan ehdottomasti vikailmoitusta kehiin.
    Tein tuosta vikailmon silloin 2v sitten nettilomakkeella, mutten koskaan saanut vastausta ja disabloin koko ipv6:en sen auheuttaman ongelman vuoksi. En ole sitä sen jälkeen enabloinut enkä testannut.
    6kk sitten tilasin "Julkisen IPv4 osoite -lisäpalvelun", olin ehkä pessimisti enkä jaksanut ees kokeilla joskos se ipv6 olisi toiminut.

    Tässä välissä B315 firmware on kyllä päivittynyt jossa on muutoslogin perusteella fiksattu jotain ipv6 juttuja

    16.3.2917 näemmä Elisa on viimein saanut ipv6 osoitteen myös internet4 APN:lle, joten sitäkin voisin toki kokeilla.

    Voisin tätä lähiviikkoina testailla, olisko tämä jo viimein korjaantunut.

    Osallistu keskusteluun