Huawei E3372 kokemuksia?



Näytä ensimmäinen kirjoitus

232 kommenttia

Käyttäjätaso 7
Kunniamerkki
Normi-firmiksellä (siis ei HiLink) varustettu tikku vaatii mobiililaajakaistalaitteena toimiakseen ns. 2718-rivin muutoksen ajuriasennukseen. Tai näin ainakin Mint17:ssä ja ilmeisesti myös Ubuntussa; Fedoralle muistelen myös nähneeni jonkin vastaavan ohjeen, joka löytynee hakemalla Huawein ndis-ajurin asennukseen ohjeita. Saman muunnoksen vaatii usbilla toimiakseen myös E5776.

Uppi-nopeudessa on kylläkin jotain häikkää, yhdisti sitten mlk-yhteytenä tai wvdialilla.
E3372 tukee MBIM ja NCM standardeja. Linuxin mukana tulee tarvittavat ajurit (cdc_ether, cdc_mbim).

MBIM ei vaan satu toimimaan ja Huaweita ei voisi vähemmän kiinnostaa Linux-tuki.
Löysin Ubuntulle tehdyn ohjeen:

http://askubuntu.com/questions/323031/how-to-install-ndis-driver-for-huawei-mobile-broadband-devices

Tuon avulla sain käännettyä Huawein oman ajurin, mutta en ainakaan vielä saanut IP-osoitetta yhteydelle. Blacklistasin kernelin mukana tuleen ajurin, joten sen ei pitäisi vaikuttaa.
tpahula kirjoitti:
Löysin Ubuntulle tehdyn ohjeen:

http://askubuntu.com/questions/323031/how-to-install-ndis-driver-for-huawei-mobile-broadband-devices

Tuon avulla sain käännettyä Huawein oman ajurin, mutta en ainakaan vielä saanut IP-osoitetta yhteydelle. Blacklistasin kernelin mukana tuleen ajurin, joten sen ei pitäisi vaikuttaa.

Miksi blacklistasit kernelin mukana tulleen toimivan cdc_ether ajurin?
Ymmärsin, että huawei_cdc_ncm ja hw_cdc_driver eivät toimi samaan aikaan.

EDIT:

dmesg-lokin mukaan hw_cdc_driveria ei käytetä, jos kernelin huawei_cdc_ncm ei ole blacklistattu.

[  109.772958] huawei_cdc_ncm 1-3:1.2: MAC-Address: 00:1e:10:1f:00:00
[  109.772961] huawei_cdc_ncm 1-3:1.2: setting rx_max = 16384
[  109.773295] huawei_cdc_ncm 1-3:1.2: cdc-wdm0: USB WDM device
[  109.773453] huawei_cdc_ncm 1-3:1.2 wwan0: register 'huawei_cdc_ncm' at usb-0000:00:14.0-3, Huawei CDC NCM device, 00:1e:10:1f:00:00
[  109.773605] usbcore: registered new interface driver huawei_cdc_ncm
[  109.794795] usbcore: registered new interface driver option
[  109.794970] usbserial: USB Serial support registered for GSM modem (1-port)
[  109.795201] option 1-3:1.0: GSM modem (1-port) converter detected
[  109.795429] usb 1-3: GSM modem (1-port) converter now attached to ttyUSB0
[  109.795445] option 1-3:1.1: GSM modem (1-port) converter detected
[  109.795507] usb 1-3: GSM modem (1-port) converter now attached to ttyUSB1
[  109.835104] hw_cdc_driver: module verification failed: signature and/or  required key missing - tainting kernel
[  109.835693] usbcore: registered new interface driver huawei_ether
[  109.860359] huawei_cdc_ncm 1-3:1.2 wwp0s20u3i2: renamed from wwan0
Ei tarvitse sählätä ZTE:n vanhojen ajureiden kanssa, blacklistaa cdc_mbim ja asenna usb_modeswitch ja usb_modeswitch-data
cdc_mbim blacklistauksen sijaan voi kokeilla:

# cat /etc/usb_modeswitch.d/12d1:157d
# Huawei E3331
TargetVendor=0x12d1
TargetProduct=0x14db
HuaweiNewMode=1
NoMBIMCheck=1
Katselin lsusb:lla mokkulan tietoja ja listauksessa näkyy 12d1:1506.

Moduli cdc_mbim ei ollut aikaisemminkaan ladattuna.
tpahula kirjoitti:
Katselin lsusb:lla mokkulan tietoja ja listauksessa näkyy 12d1:1506.

Moduli cdc_mbim ei ollut aikaisemminkaan ladattuna.

Mikäs Huawei sinulla on? Tämä ketju on Huawei E3372:lle omistettu.
Minulla on Huawei E3372. Tässä on 21.x sarjan firmis, joten vaikuttaisiko se asiaan ?
Vai niin, Huawei antaa eri laitteille samoja USB ID-numeroita.. :smileycry:

Minulla on

Hardware CL1E3372SM
Software 22.298.03.00.07

oletko usb_modeswitchiä ajanut, kun olet laittanut tikun kiinni koneeseen? USB ID vaihtuu, jos usb_modeswitch vaihtaa moodia..

Voithan sinä kokeilla, jos kopsit 12d1:157d tiedoston myös nimelle 12d1:1506 ja laitat tikun kiinni koneeseen uudestaan.

EDIT: btw, vastaanotto/lähetysnopeus mulla on max 50/20 Mbit/s
Eipä ollut noistakaan kikoista apua.
Mitens tuosta E3372:sta saa otettua pois käytöstä tuo automaattisen yhteyden katkaisun roumatessa? Nyt on valittavissa vain 5-120min ja Saunalahden liittymä roumaa Elisassa. HiLink tilassa joudun käyttämään kun ROOter käytössä ja se ei kait vielä tue E3372:sta.

Toinen, saako tästä pois käytöstä tuota tikun pseudo CD:tä, tai mikä tuo on nimeltään? Niin että ROOter ei näkisi sitä.

Onko Saunalahdella omaa firmistä näihin? Tämä on LMT brandätty ja olen tuosta Tools-paketista pistänyt tuon HiLink firmiksen sisään.
Käyttäjätaso 7
Kunniamerkki
Yhteyden katkaisua ei saa pois päältä. Se ei kylläkään liity roamaukseen, vaan on samalla tavalla päällä aina. En kylläkään ole havainnut siinä mitään ongelmaa, vaikka "nousu" tuosta sleep-modesta luultavasti kestää jonkun sekunnin kymmenyksen.

ROOterissa ei normi-E3372:sta saa toimimaan kuin ppp-forcella ja hieman alennetuilla nopeuksilla.

Miten pseudo-CD muuten näkyy ROOterissa, ja vaikuttaako sen näkyminen jotenkin toimintaan? Ei ole tullut koskaan edes ajateltua asiaa.

EI ole tainnut tähänkään keskusteluun kukaan laittaa tietoa Saunis-version firmiksestä?
Ok sitten tuo mun yhteyden katkeaminen littyy johonkin muuhun kuin tuohon sleep modeen. Sekun ei avaa yhteyttä ennen kun käy Hilink UI:n kautta uudelleen avaamassa.

CD tarvis saada pois kun sotkee ext-ROOteria eli koitan saada tikun sd korttipaikasta apuja reitittimen muistilaajennukseen. No tuo on tuollainen matkareititinkokeilu TP-MR3020:sella ja OpenVPN:n opettelua varten joko tuon saisi toimimaan. Tuo pseudo CD on muistikortin edellä levyissä jotka ROOteri näkee ja lisämuistilevyn tarvisi olla eka. On tuossa kyllä jotain muutakin ongelmaa eli ei välttämättä liity e3372:seen mitenkään.

Pääsen pääsiäisenä testaamaan vanhempien TP-Link WRD4300:sella, jos siinä toimisi paremmin. Paljonko tuo ppp-force vaikuttaa nopeuteen? Käytössä 50M liittymä ja ei tuolla mitään niin kovin vauhtikriittistä touhuta eli jos tuolla saisi paremmin pelaamaan voisi vauhdissa ottaa vaikka vähän takkiin.
Ainakin esim MF823D kärsii tästä LTE:llä http://ofmodemsandmen.com/powert.html

If the router can not supply the required amount of power to the modem you may experience degraded performance or even disconnections and erratic behavour.
Käyttäjätaso 7
Kunniamerkki
Onkait se data-roaming sallittuna hallinnassa? Tuon pitäisi olla ainoa asetus, joka estää automaattisen uudelleenyhdistämisen sleepin jälkeen. WebUI:na lienee se paketissa oleva 16-sarjalainen?

En näin pikaisesti keksi ratkaisua tuohon cd-juttuun. Setporttauksen voi tehdä vain normi-firmiksellä, mutta se nollautuu, kun firmiksen vaihtaa takaisin HiLink:iin, eikä ole edes varmaa, pysyykö setport-asetus muuttumattomana purkkiin kytkettynä. Mutta eikö ROOterin modeswitch flip-floppaa cd-rommin pois päältä, kun tikku tunnistuu, ja vain muistikortin pitäisi jäädä käyttöön noista sis. muisteista? Tai sitten tuossa on jotain, mitä en tajua.

Ppp-pakotus ei enää nykyään paljoa dl-nopeuteen vaikuta, uppiin ennemminkin, eli saattaisi tarjota aivan riittävän vaihtoehdon. Ja normi-tikulla voisi sitten "säätää" nuo muistijututkin kohdilleen. Tai ainakin pitäisi voida, mutta sillä varauksella, että nyky-kerneleissä tuntuu olevan aika aggressiivista näiden ncm-tikkujen käsittely (ks. em. setport).
Joo WebUI on 16:nen ja data-roaming on sallittu. Joudun kuitenkin aina hyväksymään että käytetään roaming yhteyttä UI:lta. Tuo vaikuttaa hieman oudolta. Vai onko tuolle joku muu paikka säätää kuin WebUI:n enable/disable?

Tuo mut testeissä oleva simmi on tosin ihan normi puhelin liittymä jossa 256k 3G eli tilanne voi vähän muuttua kun saan 4G kortin koneeseen. Mutta ei kait tuon pitäisi vaikuttaa? Ehkä tappelen tuon kanssa vasta su lisää. Mutta ainakin tuon osaa nyt vääntää HiLink ja normi tilan välillä, kiitos tämän ketjun.
Käyttäjätaso 7
Kunniamerkki
jaripetteri kirjoitti:
Joo WebUI on 16:nen ja data-roaming on sallittu. Joudun kuitenkin aina hyväksymään että käytetään roaming yhteyttä UI:lta. Tuo vaikuttaa hieman oudolta. Vai onko tuolle joku muu paikka säätää kuin WebUI:n enable/disable?

...

Tarkoitatko, että myös heti tökkäsyn jälkeen pitää käydä yhteys laittamassa päälle UI:ssa?

Jos alueella on myös LTE-verkko tarjolla, ja verkonvalinta on automaatilla, niin se sekottaa tuon automaattisen yhdistämisen. Olen huomannut, että taajuusvalinnan ollessa pielessä (siirtynyt 1800-alueelta 800-alueelle, ja tikku pakotettu 1800:lle), niin hallinta heittää automaattisesti mobiilidatan offiin. Kun taajuus/verkonvalinta on ok, yhdistää aina automaattisesti, kun roaming-rasti on paikallaan.

Todennäköisesti 4G-liittymällä homma toimii ok, koska silloin voi suoraan rekisteröityä myös siihen 4G-verkkoon.

Tai voi siinä olla jotain muutakin, mutta joka tapauksessa oma tikkuni samoilla "sisuskaluilla" yhdistää aina automaattisesti, kun vaan asetukset on ok.
Kyllästyin taistelemaan OpenWRT:n kanssa ja hommasin Dovado Pro reitittimen. Huawei E3372 lähti heti toimimaan ja nopeus on hyvä korvessakin (36/14). OpenWRT:ssä on vain monta hyvää ominaisuutta, joita jäin kaipaamaan. Dynaaminen DNS ei toiminut suoraan dy.fi-palvelimen kanssa. Sen asetuksia piti kokeilla muutaman kerran. Ratkaisevin tieto on Service URL:

http://www.dy.fi/nic/update?hostname=omapalvelin.dy.fi

Dovadon asetuksista en löydä kuin kolme ennalta määriteltyä web-hallintaporttia. DNA:n liittymässä on estetty lähes kaikki yhteydet ulkopäin, joten kolme valmiiksi määritettyä porttia eivät ainakaan toimineet. Kokeilin myös tehdä porttiohjausta, mutta sitä ei saa tehtyä paikalliselle osoitteelle, kuten OpenWRT:ssä. Sisäverkossa on toinen OpenWRT-tukiasema, joten pitää varmaan kierrättää web-hallinnan liikenne sen kautta tai sitten käyttää PPTP:tä.
Käy avautumassa tuolla dovadon fb ryhmässä niin ehkä asiaan saadaan muutos tulevien firmwarejen aikana koskien web hallintaa...
KoTe60 kirjoitti:
jaripetteri kirjoitti:
Joo WebUI on 16:nen ja data-roaming on sallittu. Joudun kuitenkin aina hyväksymään että käytetään roaming yhteyttä UI:lta. Tuo vaikuttaa hieman oudolta. Vai onko tuolle joku muu paikka säätää kuin WebUI:n enable/disable?

...

Tarkoitatko, että myös heti tökkäsyn jälkeen pitää käydä yhteys laittamassa päälle UI:ssa?

Jos alueella on myös LTE-verkko tarjolla, ja verkonvalinta on automaatilla, niin se sekottaa tuon automaattisen yhdistämisen. Olen huomannut, että taajuusvalinnan ollessa pielessä (siirtynyt 1800-alueelta 800-alueelle, ja tikku pakotettu 1800:lle), niin hallinta heittää automaattisesti mobiilidatan offiin. Kun taajuus/verkonvalinta on ok, yhdistää aina automaattisesti, kun roaming-rasti on paikallaan.

Todennäköisesti 4G-liittymällä homma toimii ok, koska silloin voi suoraan rekisteröityä myös siihen 4G-verkkoon.

Tai voi siinä olla jotain muutakin, mutta joka tapauksessa oma tikkuni samoilla "sisuskaluilla" yhdistää aina automaattisesti, kun vaan asetukset on ok.

Joo tuo 3G liittymä tarvi aina käydä hyväksymässä UI:lta että käytetään roumausta. Nyt kun sain tuon 4G simmin sisään niin ei enää näytä että roumaa ja yhteys toimii hienosti ja aukeaa automaattisesti HiLinkillä, muuten en nyt edes ehdi kokeilemaan. Vanhemmilla netti nyt kunnossa, hämäsi lisäksi se että ROOTer oli jostain syystä heittänyt wlanit pois päältä. Tarvii täällä olla ihan pommin varma systeemi kun käyttäjät eivät osaa tehdä oikeen edes opastaen noille purkeille mitään.

Tarvii tuota omaa systeemiä nyt jossain välissä ihmetellä lisää.
Tuli hommattua myös kyseinen tikku B593s tilalle.

Yhden illan yritin tuskailla Linux purkin (PC rautaa) kanssa että saisi yhteyden jollain muulla tapaa auki kuin PPP kanssa, mutta eipä tuo tunnu toimivan vaikka mitenpäin vääntää, kokeilin varmaan kaikki eri firmwaretkin mitä vaan vastaan tuli mutta bitti kun ei liiku niin ei liiku vaikka yhteys on päällä. Päätin sitten että olkoon tuolla PPP:llä kunnes tulee jotain toimivaa tilalle mutta nopeudet yllättikin aikamoisesti.

Tässä ensimmäinen testi säätöillan päätteeksi, upload rajoitus unohtu tuohon 30Mbps mikä oli käytössä B593s kanssa, ilman rajoitusta tarjoilee sellaista 45Mbps. Aika hurja ero B593s (~30ms, ~80/30) verrattuna, jopa PPP:n kanssa.

4275556275.png

Jostakin lukasin jonkun maininneen cdc_ether toimivuutta, jos jollain on asiasta toimivaa tietoa niin voisiko jakaa tarkemmin kuinka homma tehdään. Itse en tuota saanut pelittämään vaikka eri ajureilla wwan0/ethX verkkolaitteet tuli näkyviin.
lisäsin /etc/usb_modeswitch.d/12d1:157d  tiedostoon rivin

NoMBIMCheck=1

niin cdc_ether toimii kernel.org kernelin ajureilla
lkjh kirjoitti:
lisäsin /etc/usb_modeswitch.d/12d1:157d  tiedostoon rivin

NoMBIMCheck=1

niin cdc_ether toimii kernel.org kernelin ajureilla

Jos viitsit niin laitatko vielä lsmod ja dmesg noilta osin, näkisi mitä siellä pitäisi näkyä. Näitten lisäksi jos vielä kerrot millä firmiksellä ajat ja onko at^setport asetettu jotain ja ajatko suoraan jollakin ethX/wwanX/tms dhcp clienttiä vaiko mbimcli?

Tuotakin jippoa testasin, mutta ei muuttunut tilanne miksikään.

Osallistu keskusteluun