Huawei E3372 kokemuksia?


Käyttäjätaso 2
Huawein uutuustikku näyttää tulleen saataville myös Saunalahdella ja DNA:lle. Näyttää olevan CAT4-luokan laite, kuten E3276, mutta sisältää uudemman piirisarjan. Kiinnostaisi onko virrankulutukseen saatu muutoksia. Dovado lupaa reitittimilleen tukea tälle tikulle lokakuun aikana, joten olisikohan aika päivittää E392 tuoreempaan.

232 kommenttia

Onko kellään tietoa kuinka poistaa HiLink-moden tikusta MAC:illä? Onko edes mahdollista
Käyttäjätaso 7
Kunniamerkki
...Lataus nopeus on 0.7-3.5 mutta uppi on 5-7 ja ping 12-19. Ekalla kerralla kokeilin speedtestistä niin upload/ping samoissa mutta download oli lähes sata megaa. Sijaintina oli Turku, kuten olimmekin mutta kun testasin uusiks (20krt) niin paikka oli ja pysyi helsingissä ja latausnopeus tippui murto-osaan. Missä mahtaa olla vikaa? Yhteys oli koko ajan 4g yhdellä tai kahdella palkilla.
...


Ensimmäisenä tulee mieleen "tuttu juttu" eli tikku jämähtänyt väärälle taajuudelle. Onko siis taajuuspakotuksella testattu se toimivin taajuus?

Palkit on kovin huono mittari signaalille, joten selvitä hallintasivulta (jos tiedot sieltä löytyy) tai kokeile http://hallinnan_ip/api/device/signal -välilehdellä, kertooko tikku tarkempia arvoja. Joka tapauksessa 1-2 palkkia kertoo signaalin olevan heikko.

Speedtest.netin sijainneistako tuossa on kyse? Niistä ei tarvitse välittää oikeastaan sen kummemmin, koska ne kertoo vain operaattorin palvelimen sijainnin ja se riippuu siitä, kuinka yhteys kulloinkin satutaan reitittämään.
Isoveljellä olisi ongelma johon en ite tiedä vastausta joten jos täältä saisi apua

Lataus nopeus on 0.7-3.5 mutta uppi on 5-7 ja ping 12-19. Ekalla kerralla kokeilin speedtestistä niin upload/ping samoissa mutta download oli lähes sata megaa. Sijaintina oli Turku, kuten olimmekin mutta kun testasin uusiks (20krt) niin paikka oli ja pysyi helsingissä ja latausnopeus tippui murto-osaan. Missä mahtaa olla vikaa? Yhteys oli koko ajan 4g yhdellä tai kahdella palkilla.

Tikku kiinni läppärissä

Laitteen nimi: e3372
Laitteistoversio: cl2e3372hm
ohjelmistoversio: 22.317.01.00.260
web ui-versio: 17.100.1400.260
rssi: -61
LAC: 5618
Kokeilinpas omasta E3372H-153 tikusta poistaa tuota hilinkkiä, että pääsisin eroon natista. Ohjeena käytin näitä: http://blog.asiantuntijakaveri.fi/2015/07/convert-huawei-e3372h-153-from.html

Nyt tikkuni jäi ilmeisesti jumiin download tilaan ja vilkuttaakin koko ajan tuota vihreätä lediä. Mitähän tuolle voisi tehdä, että se siitä tokenisi? Onko joku palstalainen onnistunut muuttamaan hilinkkiä stick modeen näissä Suomen E3373h-153 tikuissa?
En viitti omasta E3372S-153 vielä poistaa Hilinkkiä, jos ei tule verkonpainoa laitteesta.
Nyt on mielessä itselläkin ADSL vaihto 4Ghen. Asus RTN56U löytyy mikä hoitanut ennen kaiken mutta näköjään tää mokkulakin oli reititin.

Onkos kellään nyt kunnon yksinkertaista ohjetta miten saada vähintään nuo DMZ ja portinohjaus asetukset näkyviin. Tämä on tuo e3372s -153 hilink (v. 22.x) versio DNA malli. Löyty tuo zippi missä on tiedostoja vaihtoon 22 > 21 ja toisinpäin. Tarviinko asentaa tuosta muutakuin tuo modded WEBUI vai täytyykö asentaa myös firmis? Ja pitääköhän noi pari muutakin ennen sitä ([1] Mobile Broadband HL Service, [2] DataCard driver)?

Ei uskalla vielä kokeillakkaan kun jossain luki että voi jäädä jumiin odottelemaan päivitystä tilaan ja sitte ei toimi ollenkaan.

Paras olisi jos olisi siltaavaksi saanu (vissiin toi stick mode v. 21.x ois?) mutta ilmeisesti ei toimi ku windowsissa eikä reitittimessä enää sen jälkeen...
Kasasin tuolta Itävaltalaiselta foorumilta toimivan hilink paketin jossa voi säätää DMZ, DHCP pois päältä, taajuuden lukitus jne. (samat löytää sieltä foorumiltakin mutta ei tarvitse suomentaa jos ei saksa taivu).

Todettu toimivaksi myös Linuxissa cdc-ether ajurilla, joku mainitsi joskus aiemmin ettei kaikki firmikset toimi suoraan eli pitäisi toimia myös openwrt heittämällä hieman mukavemmilla säädöillä suoraan webui:sta.

Linkki pakettiin alla. En ota mitään vastuuta jos ryssit tikkusi tai poltat koneesi, itsellä toimii kun numeroidussa järjestyksessä tiedostot ajelee (joko non-hilink tai hilink moodissa).

https://www.dropbox.com/s/icytvz5a2890kx9/e3372-hilink.rar?dl=0 EDIT: google drive -> dropbox -------------------------------------------------Oisko jollain tota pakettia vielä? Tai muuten ohjeita? Itse en oikein saa millään asennettua noita lteforum.at firmiksiä tohon e3372h-153:een. Jotain error 19 valittaa.
Testasin 21.300.05.00.00 firmiksen ja ei ainakaan yhteysnopeus huonontunut :)



Tikku on kiinni Netgear WNDR3700v2 reittimessä, jossa OpenWRT CC 15.05. Samalla tuli löydettyä ratkaisu ongelmani originaalin OpenWRT:n kanssa. Kahdella komennolla yhteysongelma ratkesi.

echo 6000 > /sys/class/net/wwan0/cdc_ncm/tx_max

echo 0 > /sys/class/net/wwan0/cdc_ncm/min_tx_pkt

Lähde:

http://lists.freedesktop.org/archives/modemmanager-devel/2016-January/002489.html
Etsin e3372s-mallin firmiksiä ja uusin löytämäni oli 21.300.05.00.00. Huawein Release Notesin mukaan tämä on viides firmware versio. Paketti löytyy osoitteesta:

http://turbobit.net/download/free/xqmn4h3yjo2r#

Onko kukaan kokeillut tämän toimintaa ?
Mikäs olisi hyvä non-hilink firmis e3372s tikulle? ROOter multiweb käytössä reitittimessä. Tarvisi saada lukittua tuo tikku tiettyyn soluun.
jamu kirjoitti:
Itse-itselleni vastaten, ilmeisesti IPv6 tuki tosiaan puuttuu tästä 21.180.01.00.00 general firmwaresta.

En ole löytänyt E3372h-153:lle uudempaa general firmistä, ja operaattori spesifisten firmwarejen, kuten 21.200.07.00.209, flashaus tämän general firmwaren päälle ei ainakaan suoraan onnistu.

Onko kellään kokemusta miten tuon uudemman non-hilink firmwaren saisi flashattua tähän?

Ei ole kokemusta h-mallista, mutta oletko katsonut seuraavalta sivulta löytyviä firmiksiä ja ohjeita ?

http://www.lteforum.at/mobilfunk/firmware-versionen-hi-non-hilink-e3372h-inkl-mod.2691/
jamu kirjoitti:
tpahula kirjoitti:
Ainakin Openwrt 15.05 versiolla toimii IPv6 dna:n liittymällä. Käytössä tosin s-versio tikusta.
Toimiiko myös IPv6 prefix delegaatio? Eli saatko /56 blockin, vai /64:sen? Aikaisemmalla E3276:lla sain kyllä /64 osoitteen, mutta en saanut PD:tä toimimaan.

DNA:lta tulee /64 osoite. Minulla on 21.286.03.01.209 Megafon firmis tikussa ladattuna.
Onko kellään kokemusta Zyxel SBG3300 ja Huawei E3372 yhtennsopivuudesta?

Kuulin että joku oli saanut ne toimimaan yhdessä mutta Zyxell ei tue sitä virallisesti.
Itse-itselleni vastaten, ilmeisesti IPv6 tuki tosiaan puuttuu tästä 21.180.01.00.00 general firmwaresta.

En ole löytänyt E3372h-153:lle uudempaa general firmistä, ja operaattori spesifisten firmwarejen, kuten 21.200.07.00.209, flashaus tämän general firmwaren päälle ei ainakaan suoraan onnistu.

Onko kellään kokemusta miten tuon uudemman non-hilink firmwaren saisi flashattua tähän?
tpahula kirjoitti:
Ainakin Openwrt 15.05 versiolla toimii IPv6 dna:n liittymällä. Käytössä tosin s-versio tikusta.
Toimiiko myös IPv6 prefix delegaatio? Eli saatko /56 blockin, vai /64:sen? Aikaisemmalla E3276:lla sain kyllä /64 osoitteen, mutta en saanut PD:tä toimimaan.
Ainakin Openwrt 15.05 versiolla toimii IPv6 dna:n liittymällä. Käytössä tosin s-versio tikusta.
Onko E3372h:n IPV6 tuesta käytännön kokemuksia vielä?

Hankin tuollaisen hiljattain, ja konvertoin non-hilink firmwaren käyttöön näiden ohjeiden mukaisesti. Tikku toimii hienosti Openwrt:n perässä (Rooter), mutta IPV6 tuki näyttää puuttuvan.

AT+CGDCONT=? näyttää tukevan vain IP ja PPP tyyppejä, eikä laisinkaan IPV6 tai IPV4V6 tyyppejä. Ymmärtääkseni IPV6 käyttö on mahdollista vain näitä käyttämällä.
Kokeilin asennella tarvittavat paketit puhtaaseen OpenWRT:n. Tikku näkyy ja wwan0 interface nousee ylös, mutta se ei saa IP-osoitetta. Sama ongelma on ollut aikaisemminkin, kun olen kokeillut trunk-versiota. Voihan tosin olla, että lataan jonkun väärän modulin järjestelmää. /etc/config/network-tiedosto on muuten samanlainen, mutta /dev/cdc-wdm0 laitenimellä ei wwan0 interface nouse ylös. Kokeilin myös syöttää sinne komentoja minicomin kanssa, mutta ei sekään toiminut, vaikka laitenimi näkyy dev-hakemistossa.

Tässä vielä kokeilemani komennot:

opkg update

opkg install usb-modeswitch chat comgt-ncm kmod-usb-net-cdc-ncm kmod-usb-serial kmod-usb-serial-option kmod-usb-net-huawei-cdc-ncm

uci delete network.wan
uci set network.wan=interface
uci set network.wan.ifname=wwan0
uci set network.wan.proto=ncm
uci set network.wan.device=/dev/ttyUSB0
uci set network.wan.pincode=1234
uci set network.wan.apn=internet
uci commit network
reboot

Nettiyhteyden tarkistamiseen olen käyttänyt Siptunen vanhaan Asusin reitittimeen tehtyjä skriptejä, joka on OpenWRT-pohjainen. OpenWRT on GPL-lisenssin alainen, joten skritit voinee laittaa tänne näkyviin:

/usr/sbin/wan-wd:

#!/bin/sh

# WAN watchdog by Anttu v.100915
# Inner 1 min loop inits modem, outer 1+2 min loop reboots

    sleep 60
    while :
    do
      modinit=0
      while [ $modinit -eq 0 ]
      do
        sleep 60
        RESP=`ping -c 3 google.com`
        if [ "$RESP" = "" ]
        then
          /etc/init.d/network restart
          modinit=1
        fi
      done  
      sleep 120
      RESP=`ping -c 3 google.com`
      if [ "$RESP" = "" ]
      then
        reboot
      fi
    done

/etc/init.d/wan-watchdog:

#!/bin/sh /etc/rc.common
# Modeemien asetukset, ATu 100911

START=98
start() {
    wan-wd &
}

Tuo wan-watchdog pitää sitten pistää päälle esim. komennolla:

/etc/init.d/wan-watchdog enable
Olihan se vähän hakuammuntaa mitä paketteja piti asentaa ennen kuin lähti toimimaan. Mitään dokumentaatiota näistä kun ei ole. En edes tajunnut kirjata ylös kaikkia paketteja mitä erikseen asensin, mutta tässä listaus koko setupista josko siitä olisi jollekulle apua: http://pastebin.com/buA3qjsU

ja /etc/config/network:

config interface 'wan'
option proto 'ncm'
option ifname 'wwan0'
option device '/dev/cdc-wdm0'
option apn 'internet'
option pincode '1234Jotain skriptiä itsekin suunnittelin, joka tekisi rebootin mikäli yhteys katkeaa. Miten testaat yhteyden tomintaa? Pingaat jotain palvelinta, esim. Googlen dns 8.8.8.8 ?
Pitää kokeilla vakioimagea uudestaan, mutta mielestäni se ei toiminut vastaavalla konfiguraatiolla. Tuossa puolalaisessa imagessa on vielä kaikki tarvittava valmiiksi asennettuna.

Tikkujen jumitukseen olen käyttänyt skriptiä, joka testaa yhteyden toimintaa ja resetoi reitittimen tarvittaessa. Reset ei tosin auta kaikkiin tapauksiin, jos reititin ei katkaise USB-portin sähköä resetin yhteydessä. TP-Linkin WDR4300 osaa ainakin katkaista sähkö USB-väylästä resetin yhteydessä, joten sen kanssa saa hyvin toimivan yhteyden rakennettua.
Heinäkussa 27. päivä ajettiin trunkkiin patchi, joka korjasi E3372:n käyttöön liittyneen ongelman ncm-ajurissa: https://lists.openwrt.org/pipermail/openwrt-devel/2015-July/034723.html (selaa ketjua taaksepäin jos haluat tarkempaa tietoa).

CC 15.05 paketit on buildattu 15.9. joten tämän patchin pitäisi löytyä myös siitä. Itse käytän tällä hetkellä nightly buildia r46815 joka buildattu joskus syyskuun alkupuolella ja ncm hyrrää kuin junan vessa.

Tosin sellainen pikkuvika vielä on, että jos mokkula jostain syystä tiputtaa yhdeyden, sitä ei saa takaisin ylös mitenkään muuten kuin boottaamalla koko reitittimen. Onneksi pätkimistä ei ainakaan tällä hetkellä juurikaan ole (ehkä kerran kadessa viikossa). Tämäkin ongelma on kehittäjien tiedossa: https://lists.openwrt.org/pipermail/openwrt-devel/2015-February/031461.html

Tuossa aiemmin laittamani kommentti liittyy siis PPP-protokollan käyttöön, jonka itsekin lopulta totesein hitaaksi. Etenkin uppikaista jäi puoleen siitä mitä tikku antoi suoraan pc:hen kiinnitettynä tai nyt ncm:n kanssa. En suosittele.

LTE-pakotuksen voi tehdä myös siten, että laittaa tikun kiinni windows koneeseen ja käyttää MDMA-nimistä softaa: http://www.nerve.org.za/mdma/
Tällä pitäisi onnistua myös taajuuspakotukset. Näitä asetuksiahan muutettaessa, ne jäävät modeemiin "päälle" eli eivät muutu vaika tikun vaihtaa laitteesta toiseen.
OpenWrt Chaos Calmer 15.05 on julkaistu, mutta sen NCM-tuki E3372:lle on edelleen rikkinäinen. Puolalaiselta sivustolta löytyy onneksi toimiva versio. Sivuston osoite on: http://eko.one.pl/

Tuolta kannattaa ladata CC:n luci-versio.

http://dl.eko.one.pl/luci/chaos_calmer/

Esim. Netgear WNDR3700v2:

http://dl.eko.one.pl/luci/chaos_calmer/ar71xx/luci-15.05-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin

Firmiksen asennuksen jälkeen pääteyhteyden kautta esim. komennot:

uci delete network.wan
uci set network.wan=interface
uci set network.wan.proto=ncm
uci set network.wan.device=/dev/ttyUSB0
uci set network.wan.pincode=1234
uci set network.wan.apn=internet
uci commit network
reboot

Nämä komennot korvaavat eth1:ssä olevan wan-yhteyden. Yhteyden tilasta saa tietoa, kun asentaa 3ginfo-nimisen ohjelman komennoilla:

opkg update
opkg install  3ginfo

Minun osalta puolen vuoden tappelu E3372:n on loppunut. Väliaikaisena ratkaisuna ollut Dovado lähtee pois, koska sen toiminta on ollut WLAN-verkon ja DDNS-palvelun osalta epävakaa. 

Lisäyksenä vielä, että mikäli yhteyden haluaa pakottaa LTE-moodiin, niin seuraava komento pitää ajaa:

uci set network.wan.option=lte
uci commit network

Nopeus Soneran täysnopeusliittymällä on 90/25Mbps ja ping 22ms Speedtestin mukaan, joten asetukset näyttäisi olevan kunnossa.
Laitetaanpa tännekin tiedoksi, kun löytyi hyvin toimiva combo tälle tikulle. Toimii ihan heittämällä OpenWRT:n uusimman RC:n kanssa (Chaos Calmer 15.05-rc3). Purkkina D-Link DIR-825 rev. B2. Tikku on Elisalta ostettu non-HiLink ja täysin koskematon tehdasfirmis.

OpenWRT:ssä en muuta tehnyt kuin asentanut usb-ajurit

opkg update
opkg install comgt kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwansekä 3G guin

opkg install luci-proto-3gjonka jälkeen kaikki konffaus hoitui suoraan web-liittymän kautta.

Yhteys tuntuu pysyvän vakaasti ylhäällä ja se myös muodostuu noin 15 sekunnissa vaikka tikun ottaisi lennosta irti ja takaisin kiinni (jopa senkin kerran kun vaihdoin lennosta Elisan simmin dna:n simmiin, molemmissa sama PIN).

Ainoa huono puoli on, että OpenWRT:n kälistä ei irtoa käytännössä mitään dataa yhteyden tilasta. Jos tuonne vielä saisi jotenkin puukotettua ROOterin inforuudut...
Moi,

onko mahdollsita saada E3372 Huawei ja TP-LINK TL-MRSA3420 toimimaan yhdessä? ei näytä yhdistyvän, vaikka reitittimen sivuilla näyttäisi asetukset olevan ok.
Eli tiedoksi muillekin, että nyt minulla on E3372h-153 (edellisen viestin FW:llä ja UI:lla) kiinni TP-Linkin TL-MR3420 reitittimessä johon on asennettu ROOter FunnelWeb 2014-04-14a / LuCI Trunk (svn-r9964). ROOter tuntuu nielevän tikun mukisematta ja sitten tikkuun kiinni WebUI:n kautta (192.168.8.1) ja sinne asetukset kohdalleen. Netti pelittää hienosti 🙂 Aiemmin minulla oli tikku kiinni TL-WR1043ND reitittimessä jossa oli myös ROOter (uusin Multiweb) jossa se itse asiassa toimi myös, mutta taitaa tuon reitittimen WLAN olla olla jotenkin viella (tai muu vika reitittimessä).

Yksi syy fw päivitykseen tosin minulla oli alunperin, että saisin yhteyden sisäverkkoon ulkoa päin. No siihen vaivaan pitäisi toimia myös reverse ssh ja siihen tunnelointi. Kun noilla operaattoreilla on usein vielä portit kiinni tai 4G kokonaan natattuna.

Osallistu keskusteluun