IPv6 asetukset OpenWRT/LEDE reitittimille

  • 14 heinäkuu 2017
  • 18 kommenttia
  • 2868 katselukerrat

Yritän saada IPv6:tta toimimaan OpenWRT reitittimellä jossa Huawei E398 USB tikku.

IPv4 toimii ongelmitta, mutta en ole saanut millään ilveellä v-kuusi osoitetta yhteydelle.

Kaikki vinkit ovat tervetulleita.

18 kommenttia

Hei, tuli hankittua D-Link DWR-921 ja laitettua siihen OpenWrt 18.06.2 ja kahden päivän kamppailujen jälkeen löysin siihen toimivat asetukset jolla IPv4 ja IPv6 toimivat.

En tiedä onko tässä oleva plmn arvo sama koko suomessa toinen voi olla 244021 mutta se ei ainakaan minulla toiminut.

uci set network.wwan=interface
uci set network.wwan.ifname='wwan0'
uci set network.wwan.proto='qmi'
uci set network.wwan.dhcpv6='1'
uci set network.wwan.device='/dev/cdc-wdm0'
uci set network.wwan.apn='internet'
uci set network.wwan.auth='none'
uci set network.wwan.modes='lte'
uci set network.wwan.delay='30'
uci set network.wwan.pdptype='ipv4v6'
uci set network.wwan.plmn='244005'
uci commit network

ifup wwan

Näiden asetuksien lisäksi pitää vielä määrittää wwan palomuuriin jotta sisäverkko pääsee internettiin

uci set firewall.@zone[1].network='wan wan6 wwan'
uci commit firewall

Jotta qmi interface näkyy oikein www käyttöliittymässä piti asentaa seuraava paketti

opkg update
opkg install luci-proto-qmi

Tässä vielä asetukset /etc/config/network asetus tiedostosta.

config interface 'wwan'
option ifname 'wwan0'
option proto 'qmi'
option dhcpv6 '1'
option device '/dev/cdc-wdm0'
option apn 'internet'
option auth 'none'
option modes 'lte'
option delay '30'
option pdptype 'ipv4v6'
option plmn '244005'
Elisa:n tuki & myynti kehoittaa etsimään ongelmaan ratkaisua palstalta, onko käynyt niin että osaavat henkilöt Elisalla on kyllästyneet merkonomeihin ja ekonomeihin jotka eivät ymmärrä mitä ovat myymässä, asiaa auttaa kun asiakkaat ei ymärrä,....

Asiaan, jos elisa kertoisi minkä standardien, käytäntöjen,.. mukaan nuo julkiset IP:t jaetaan, yhteyskäytäntöjen kuvaukset,.... niin olisi helpompaa arvata miten saisi toimimaan.

Eli jos Elisa jakaa kuten moimobiilikin ipv6 osoitteen niin että modeemi & reititin joutuu olemaan siltana en ole saanut konfiguraatiota toimimaan ( voi siis toimia, joku väittäää että ei toinen että kyllä). Jos osoite tulee natiivina sen pitäisi toimia.

Jos Elisa toimittaa liittymän testattavaksi ja jos sen saa toimii niin voin jatkaa tilausta, tänne voin kanssa kirjoittaa, Elisa voi maksaa työstä myös korvauksen mikä kuuluisi heille, huonoa myyntiä kun asikkaalle ei pystytä edes kertomaan mitä myy!!! Siis tietoliikenteen speksit mitkä käytössä.

Elisa voisi tarjota rahaa vastaan Avointa nettiä kiintein osoittein jos kyseessä on liketoiminta eikä asikkaiden kiusaaminen. Tosin kilpailijat suoriutuvat kiusaamisessa paremmin.
Käyttäjätaso 2
Elisa tarjoaa /64:n, josta riittää jaettavaa. NAT:ia ei tarvita. LEDE:n QMI-protokolla osaa konfiguroida jaon LAN:iin oikein. ROOter ei käytä uqmi:ta eikä osaa tuota tehdä.
No, prefix delegation selvittelin ja sen pitäisi toimia openwrt:ssä ja vahvistuksen sain
7pä'ivän odottelun jälkeen, kysyin asiaa yhtiön hallituksen jäseneltä kun tuki ja
tekniikka ei ole vastannut.

Mobiili liittymässä dhcpv6 jaetaan vain yksi ipv6 osoite.

Ei tilanne on viestintäviraston määräysten vastainen, no se on sitä myös muilla operaattoreilla ja
esim. moimobiililta en saanut vastausta 2kk odottelun jälkeen.

Eli toimiva konfiguraatio syntyy:
-ipv4 julkinen paketti (tiedon siirto rajoitettu 3-5mb !)
-saat myös ko.kikalla yhden ipv6:Sen

Kokeilematta on , eli laitaan ipv6 NAT:in ja jotta on myös julkinen pysyvä osoite
niin se sitten tunnelin kautta Huricanelta. Nää pitäisi toimia kun eivät ole operaattorin vaan oipwnwrt ominaisuuksia,... tosin voihan ne estää liikenteen hurricanelle!!


Olisi kiva kun ficoraa, lkm:ää ja puhelinyhtiöitä olis johtamassa ihmiset jotka ymmärtää
mitä ovat myymässä. Nää pellet ei ole myymässä tiedonsiirtoa vaan yksisuuntaista viihdepalvelua !
Voihan tuo olla ihan poliittisesti johedettua tarkoituksellista toimintaa, siinäkin tapauksessa
jäänyt tajuamatta kuinka se hodastaa ja estää innovaatioita, toimintaa,.. Tässä on jo kyse
muustakin kuin osoitteesta kun näin simpeliä asiaa ei haluta toteuttaa. Asioita hoitamassa ihmisiä
joilla vippaa korvien välissä.
Käyttäjätaso 4
Kunniamerkki
Olisiko tästä ketjusta mitään apua: https://palsta.elisa.fi/mobiililaajakaistat-8/ipv6-asetukset-asukselle-493403
Elisa tarjoaa /64:n, josta riittää jaettavaa. NAT:ia ei tarvita. LEDE:n QMI-protokolla osaa konfiguroida jaon LAN:iin oikein. ROOter ei käytä uqmi:ta eikä osaa tuota tehdä.
Tämän ongelma on se, että jos mobiilireitittimen perässä on jotain muuta (kuten esim Unifin USG) kuin suoraan tietokoneita/tabletteja ei homma pelitä.
Myöskään mobiilireitittimet eivät tunnu osaavaan oikeasti sillata IPv6 yhteyttä eli modeemi vie aina tuon ainoan 1 kpl ipv6 osoitteen ja koska se saa itse /64 prefixin joka on pienin ipv6:ssa jaettava osoitealue ei se voi antaa prefixejä sen takana oleville muille laitteille jotka sitten jakaisivat siitä osoitteita oman konfiguraationsa mukaan.
Moi,
Millähän parametreilla Elisa 4G Mobiilin IPV6 osoitten jako onnistuisi LAN:n puolelle?
Mulla on pieni konfiguraatio ongelma 😉 Eli Elisa 4g+, jossa LTE7460-M608 (joka sillattuna) sen takana Unifin USG (security gateway) joka toimii palomuurina ja jakaa ipv4 osoitteita sisälle päin. Nyt haluaisin tuohon ipv6 osoitteiden jaot myös päälle. Ja tuo USG vaikka muuten onkin aivan loistava peli, ei siinä ole kunnon käliä josta ipv6 laittaisiin päälle, eli homma pitää tehdä komentoriviltä/json tiedostosta. Ohjeiden https://help.ubnt.com/hc/en-us/articles/115005868927-UniFi-How-to-Implement-IPv6-with-DHCPv6-and-Prefix-Delegation-on-USG mukaan koitettu, mutta ei toiminut..

Esim: ipv6 prefix arvo, onko käytössä ipv6 Prefix Delegation vai joku muu systeemi, jos niin mikäköhän?
Käyttäjätaso 2
Käytä QMI protokollaa, eli asenna paketti uqmi. Sitten konffaa modeemi käyttämään sitä, ja aseta option pdptype ipv4v6. Valitettavasti ei onnistu webbikäyttöliittymästä.
Käytä QMI protokollaa, eli asenna paketti uqmi. Sitten konffaa modeemi käyttämään sitä, ja aseta option pdptype ipv4v6. Valitettavasti ei onnistu webbikäyttöliittymästä.


Moi. Voisinko pyytää kertomaan hiukan yksityiskohtaisemmin miten tuon saa konffattua?

QMI:llä yhteys nousi ylös ilman mitään konffausta, mutta IPv6 osoitetta en saanut.

Koitin laittaa tuota option pdptype ipv4v6 wwan interfacelle confiksissa mutta ei auttanut.


Kiitos!
moi, Koska elisan tulki ei tiedä miten heidän verkkonsa ipv6 jakaa niin arvataan että modemiisi pitää olla silatussa tilassa. Näin ollen ei openwrt + huawei modeemi voi toimia. Huawein vastaus on että eivät tue millään modeemilla siltausta. Siis oletamme että elisa ei anna loputtomasta ipv6 avaruudesta omaa osoitetta vaan modeemin pitää olla siltana, jos näin ei ole joskus joku elisalta sitten korjaa tämän jos elisa sittenkin jakaa ihan poikean ipv6 osoite avaruuden modeemille!!! Siltaava konfiguraation tiedetään olevan epävakaa ja sitä ei ole tarkoitettu operaattoreille ipv6 yhdistämiseen. Kuitenkin operaattorteilta löytyy näitä välkkyjä jota tekee vastoin yleistä tietoa, suosituksia,... tälläsiä virityksiä. Kysymykseen voisiko ipv6 toimia tuossa kopnfiguraatiossa vastaus on kyllä mutta sun pitää muuttaa johonkin sivistys valtioon, vaihtaa operaattoria,...
Katsoin viestintä viraston suositusta ja jos sen mukaan elisan liittymä tehty
niin musta sen pitäisi toimia ei siltaavana, dhcpv6-pd,....

DNA/moimobiili ovat silattuja nd käyttäviä ja siis siksi ei ipv6 toimi 100% varmasti.

https://en.wikipedia.org/wiki/Prefix_delegation

https://www.viestintavirasto.fi/attachments/suositukset/200_2014_S_Suositus_IPv6_n_kayttoonotosta_kuluttajaliittymissa.pdf

https://www.ipv6ready.org
Käyttäjätaso 4
Kunniamerkki
Miten etenee, oletko saanu ipv6 prefixit pelittämään? Saatko siis "internet" APN:llä sekä natatun nelosiipeen sekä julkisen kutosiipeen samaan aikaan vai vain jomman kumman kerrallaan?
IPV6, edeleenkään sieltä ei tule osoite avaruutta vaan yksi osoite jolle pitää reitittimessä laittaa oma NAT, ei tule osoiteita jaettavaksi omille laitteille ipv6 puolella !!! Rooterissa 909s-120 tarvitsemat muutokset ovat ehkä seuraavassa rooter päivityksessä ja tuoreimmassa LEDE versiossa. Huawei 398 varten kaikki tarvittava on kunhan ei halua kuin yhden ipv6 ja ipv4 osoitteen joista omaan julkiseen ipv4 pitää tehdä sopimus 2egee/kk !!! Yhteys on samalla puolet hitaampi kuin omalla julkisella ipv4:sella,..... niin ja neljä kertaa hitaampi kuin moimobiililla meidän osoitteessa,... mutta julkinen IPV4/IPV6 on työ asioissa välttämätön.
Käyttäjätaso 6
Kunniamerkki +3
Onko palstalaisilla kokemusta vastaavasta järjestelystä?
Joo ketjusta löytyi idea joka sai IPv6 ja IPv4 ainakin 909s-120 reittimelle
molemmat julkisina.

AT^SYSCFGEX="0302",3FFFFFFF,1,2,7FFFFFFFFFFFFFFF,,
AT+CGDCONT=1,"IPV4IPV6","internet"
AT+CGDCONT=2,"IPV4IPV6","internet"
AT^NDISDUP=1,1,"internet4"
AT^NDISDUP=2,1,"internet"

En viellä ole kuitenkaan saanut IPV6 onnistuneesti prefixiä jotta
saisi verkon laitteille jaettua omat ipv6:set.

root@Garrage:~# ifstatus wan6
{
"up": true,
"pending": false,
"available": true,
"autostart": true,
"dynamic": false,
"uptime": 1489,
"l3_device": "usb0",
"proto": "dhcpv6",
"device": "usb0",
"updated": [
"addresses",
"routes"
],
"metric": 0,
"dns_metric": 0,
"delegation": true,
"ipv4-address": [

],
"ipv6-address": [
{
"address": "2001:999:10:e201:1e:10ff:fe1f:0",
"mask": 64
}
],
"ipv6-prefix": [

],
"ipv6-prefix-assignment": [

],
"route": [
{
"target": "::",
"mask": 0,
"nexthop": "fe80::4e54:99ff:fe45:e5d5",
"metric": 512,
"valid": 7501,
"source": "2001:999:10:e201:1e:10ff:fe1f:0\/64"
}

====

eli apn internet4 antaa julkisen IPV4 mutta ei ipv6
apn internet antaa ipv6:sen mutta prefix ei välity tai tule,...

 

Nämä asetukset toimivat hyvin melko pitkään, mutta sitten menin hölmönä päivittämään Huawei E398 firmiksen ja nyt IPv6 lakkasi toimimasta. Nyt pdptype asetusta ei voi enää käyttää, jos laitan siihen mitään niin wwan ei nouse ylös lainkaan. Ilman sitä IPv4 toimii.

 

Tämä viesti antoi vaikutelman että päivitys olisi syytä tehdä, nyt täytyy etsiä löytyisikö jostain vanhempi firmis tikulle, että saisi IPv6 osoitteen taas toimimaan ainakin joksikin aikaa.

https://yhteiso.elisa.fi/mobiililaajakaista-8/lte-m-tulee-paeivitae-laitteesi-515336

Käyttäjätaso 4
Kunniamerkki +1
Yritämme auttaa asiassa parhaan osaamisemme mukaan. Käyttämäsi nettitikku ei ole itselle ihan se kaikista tutuin ja siksi on hyvä kysellä myös muiden käyttäjien kokemuksia.
Tämän asiakastukisivun kautta löytyy vastaukset IPV6 aiheisiin kysymyksiin sekä verkkokaupassamme myytävien mallien asetusmuutokset: http://elisa.to/2iyWUou .
arvoisa Prinsessapomi jotain pitää myös osata. Ei riitä että on tohtorin paperit kauppatieteessä, ei siitä tuu mitään jos myy netti liitymiä, on ihan ulkona liiketoiminnasta ja tulee palkanneeksi kaltaisiaan jota on viellä enemmän ulkona liiketoiminnasta. Sen verran selkoa on saatu että voisi olla dchpv6-pd , tilasin liittymän ja testaan sen tuossa TO-MA välissä. Huawei E398 on yksi yleisimmistä tikuista eiköhän se löydy toisella nimellä ihan elisan myydymmistä tuotteista. Testaan wg3526 reittimellä Huawei 909s-120 modeemilla. E398 löytyy kyllä täältä mutta testaus tapahtusi A5-V11 MIFI reitittimellä ja edellisessä rooter versiossa ei olllut ipv6 saatu mahtumaan, en tiedä onko uusimassa, kokeilen jos kerkeän. Jos DHCPv6 ei tule PD:nä niin saat ipv6 luultavasti julkisen ipv4 ja Hurrican Electricin tunnelin kautta. Julkinen IP4 maksaa jonkun euron kuussa lisää ja löytyy "lisäpaveluista" . Julkinen IPV4 tai IPV6 on välttämätön työ käytössä, tunnistauduttaessa,... viellä kun portti 25 saataisiin auki jotta salattu sähköposti toimii, portti 80 auki jotta sovellukset toimii. Suomessa kun myydään venamolaiseen perinteeseen yksisuuntaista nettiä jotta voisi käyttää elisa viihde palvelua, operaattorin mielestä muuta käyttöä netilllä ei ole!

Osallistu keskusteluun