Kysymys

Satunnaisten sivujen aukeamisessa ongelmia. (apn:internet4 - julkinen ip)

  • 7 kesäkuu 2012
  • 36 kommenttia
  • 2834 katselukerrat

Eli ongelma on seuraavanlainen.

Alkamisaika keskiviikko 6.6 iltapäivä

Eli ihmettelin kun ainakaan seuraavat sivut ei auenneet ollenkaan.

-ampparit.com

-elisa.fi (saunalahti toimi)

-microsoft.

Testasin nopeuden ftp.funet.fi/dev tiedostolla ja nopeus oli noin 2 megaa silloin. Eli siitä ei ollut kyse että olisi ollut yhteys huono. ties mitä temppuja yritin jotta saisin sivut aukeneen. Mainittakoon että tikku  on 3g wlan-reitittimessä kiinni mutta vika ei ole kuitenkaan siinä. Lopuksi sitten yhdistin nettitikun uudestaan verkkoon. No sivut alkoivat pelittään resetin jälkeen. No ongelmia tuli jälleen. Nyt ei muista mitkä sivut oli vuorostaan lopettaneet toimintansa resetin jälkeen. No sama peli jatku resettiä peliin ja sivut jälleen aukesivat.

Sitten tänään (7.6) töiden jälkeen tulin kotiin niin en saanut auki gmailia ollenkaan. Testasin jälleen nopeuden funetin palvelimelta ja hieman päälle 2 megaa nopeus. Mainittakoon että kyllä muut sivut aukesivat jälleen. No taas resettiä niin johan alkoi postit aueta taas. No resetin jälkeen testailin taas muutamilla sivuilla niin jälleen ampparit.com on jumissa ja nyt en pääse ftp.funet.fi palvelimelle lainkaan. Myös palsta.elisa.fi on lopettanut toimintansa vaikka elisa.fi toimii.

Nyt ei mene ollenkaan mun ymmärrykseen että mikä voi tehdä tämän. Ongelma ei voi olla nimipalvelussa.  Ainoa mikä tulee mieleen on ipv6 käyttöönoton alkaminen eilen että voisiko se sotkea nyt jotain?? Nyt resetoin uudestaan tuon tikkuni ja päivitän tämän postini uudestaan että onko jokin muuttunut taas.

Mainittakoon että käytän apn: internet4 eli julkista iposoitetta. NAT:in takaa en ole testannut tätä. Tosin puhelimessa on multisim kortti ja sen 3g puolella näitä ongelmia ei ole. Siellä käytössä NAT. Heti kun laittaa wlan puolelle puhelimen niin toimii sivut aukee yhtä hyvin / huonosti kun tällä tietokoneella eli sama vika puhelimessa wlan puolella. Ainoa mikä muuttuu resetin aikana on iposoite joten jotaiin ihmeellistä jossain on. Tätä nyt on kuitenkin varmaan 20 kertaa testattu ja en usko omassa päässäni vikaa  enää olevan, vaikka sitä jo kerkesin epäillä. :smileyshocked:

PÄIVITYSTÄ resettien jälkeen

Eli ekan resetin jälkeen google pingasi mutta mitään muuta ei tapahtunut.

Toisen kerran jälkeen pääsen ampparit.com sivustolle sekä ftp.funet.fi palvelimelle, jossa testasin nopeudeksi n 1.5 megaa. Tälle palstalle en päässyt ollenkaan joten piti jälleen resetoida tuo mobiililaajakaista.

Kolmannen resetin jälkeen pääsin jälleen tänne foorumille. Nyt näyttäisi toimivan kaikki sivut jälleen. Muutaman sivuston olen testannut ja ei ongelmia juuri nyt.

PÄIVITYS:

eli tämän kolmannen resetin jälkeen ei toimikkaan www.google.fi mutta www.google.com/en toimii

"Palvelin osoitteessa google.fi vastaa pyyntöihin liian hitaasti." eli firefoxi ei aukaise sitä. Nyt siis käytän jo toista tietokonetta mitä tuoss aikaisemmin.

Jotenkin tuntuu että ei edes kannata lähestyä saunalahden / elisan asiakaspalvelua tällä vialla. En tiiä saako sieltä kautta muutakun käsien levittelyä. Eli jos tämä ongelma vaikka tätä kautta leviäisi jonnekkin asiantuntijoille. Selvää on kuitenkin että jokin on pielessä. Soitan kyllä asiakaspalveluun jos tämä vika nyt vielä jatkuu viikonlopulle.

Tässä vielä tuo normaali Firefoxin herja kun sivu ei vaan aukene.

"The connection has timed out

The server at www.ampparit.com is taking too long to respond.
The site could be temporarily unavailable or too busy. Try again in a few
moments.
If you are unable to load any pages, check your computer's network
connection.
If your computer or network is protected by a firewall or proxy, make sure
that Firefox is permitted to access the Web."

36 kommenttia

Käyttäjätaso 5
Tätä täytyy tulla komppaamaan. Eilen illalla kytkin omiin liittymiin julkisen ip:n päälle, ja vaihdoin internet4 -yhteysosoitteen käyttöön, eikä mitään ongelmia ole ollut.

Kehoitin kaveriani tekemään samoin, ja hänellä lakkasi toimimasta saman tien Gmail, Kotikokki ja Oma Saunalahti nyt ainakin. Sama jatkuin tänään, ja kun hän vaihtoi käyttöön takaisin internet.saunalahti -yhteysosoitteen, kaikki alkoi toimia saman tien.
Ongelmat alkoivat tiistaina ja eilen huomasin tämän saman asian, että internet4 tökkii ja internet.saunalahti toimii.

Tehkää myös vika-ilmoitus! Itsellä Sierra wireless 762S käytössä.
Käyttäjätaso 7
Kunniamerkki
Paikalliset mobiiliverkon sotkut eivät taida liittyä millään tavalla otsikon mukaiseen ongelmatilanteeseen, jota tapahtuu oli kuuluvuus jne. miten hyvä tahansa. Samaa satunnaisten sivujen aukeamattomuutta esiintyi edellisen kerran viime vuonna syys-kesällä, ja silloin siinä vaiheessa, kun siirryttiin nattaukseen. Eikä vika kait silloinkaan ollut itse mobiiliverkossa vaan muissa verkon laitteissa/ohjelmistoissa/asetuksissa. Sitä ei taidettu syksylläkään käyttäjille asti kertoa, missä se ongelma oli.

Anyway: Oli ongelma sitten sama eli ei, vikailmoitushan tietenkin kannattaa tehdä. Joku tukiasema/solu voi olla pimeänä tai ns. katatoonisessa tilassa (lähettää kantoaaltoa ja vast.ottopäässä kaikki näyttää olevan ok, mutta data ei liiku sitten kirveelläkään kuin korkeintaan lyhyitä hetkiä).
Käyttäjätaso 4
Sisäverkon ip-osoiteet ovat 10.xx.xx.xx alkuisia (eli NAT-osoitteenmuunnoksen takana ). Kaikilla muilla aluilla olevat osoitteet ovat julkisia, ilman osoitteenmuunnosta, osoitteita (esimerkiksi 193.xx.xx.xx tai 86.xx.xx.xx).
hpguru kirjoitti:
Moi, Antero,

Menepä tuossa ohjelmassa Asetukset - Lisäasetukset - Yhteydet - Ominaisuudet - Ominaisuudet - Käyttöpisteen nimi (APN). Sieltä muokkaat internet.saunalahti muotoon internet4. Siitä osaat varmaan eteenpäin eli asetuksien tallennus vielä ja netti katki ja uudestaan päälle. :)


Kiitos:)

Nyt löytyi  (pitää varmaan mennä silmälääkärille) ja ulkoinenkin ip toimii.:smileygrin:
Käyttäjätaso 6
Kunniamerkki
Puutarhuri kirjoitti:
Juuri tulleen tiedon mukaan tämä vika on saatu korjattua. Pahoittelen vikatilanteesta aiheutunutta haittaa.

Vai muka korjattu, tänään ilmennyt APN = internet4 yhteydessä tökköilyä sivujen aukaisussa ja aina ei yhdisty APN = internet.saunalahti asetuksellakaan, paikka Meri-Pori 4 km Yyteriin ja 3G alue.

Onneksi DNA dataprepaid toimii:

Käyttäjätaso 5
193.66.*.* voivat olla julkisia osoitteita siitä huolimatta. Oletko tarkastanut mikä on koneen verkkoliitännälle annettu ip osoite. Ne tiedot saa kai ulos windowsissa netconfig  ipconfig komennolla. (Uudemmista Windowseista en tiedä)

Yhtään porttia ei ole auki, jos sinulla on palomuuri käytössä ja yhtään ohjelmaa ei toimi tietyssä portissa.

Nuo sivujen aukeamisongelmat viittaisivat ehkä samoihin pätkimisongelmiin mitä nopsassa on tänä vuonna nähty. Yhteydet eivät enää ole jatkuvia, niitä pätkästään katki heti kun tulee vähäkään taukoa ja sitten tulee jatkuvia aikakatkaisuja, kun yhteys on sammahtanut... Aiemmin toimi paremmin.

Sen lisäksi jotkut palvelut saattavat estää pääsyn, jos samasta ip:stä on paljon yhteyksiä. Youtubekaan ei laske natin takaa välillä, koska luulee, että siellä joku botti tekee palvelunestohyökkäyksiä. 🙂 Pitää tehdä captcha tarkistus, että varmasti olet ihminen.  Se on näitä NATin hienouksia...  Toki NATin takaa käyttö on toiminut ihan ongelmitta ja tuota pätkimistä ilmenee olipa apn mikä tahansa.
Samoja ongelmia edelleen myös täällä (Pohjois-Pirkanmaa), ei ole vielä korjautunut eli internet4 -käyttö mahdotonta.
Tuntuu nyt vaihtelevan tuo tilanne. Toisessa koneessa oli tänään portit auki, ja toisessa taas kiinni. Eli tukiasemien välillä ilmeisesti eroavaisuuksia tai sitten osui sopiva osoite. Isäukkoa en pääse nyt SSH-yhteydellä auttamaan, kun ei saa yhteyttä. Porttiskanneri näyttää että siellä on portit "closed"-tilassa, paitsi portti 53 (DNS!), mikä ei kyllä voi pitää paikkaansa alkuunkaan, varsinkin kun siellä on palomuurikin päällä.

IP-osoite on kyllä oikein tunnistettu, portit olen skannannut www.grc.com porttiskannerilla. Tälle toimivalle koneelle porttiskanneri antaa juuri oikeat tulokset; palomuuri päällä portit ovat "stealth"-tilassa ja vain se portti on auki minkä olen vuoroin avannutkin. Traceroutekin jopa pääsee perille, toisin kuin tuolle isäukon koneelle.

Molemmat IP-osoitteet ovat siis 193.66.*.* -sarjaa.

Viime viikolla kun ei toiminut, oli vielä molemmat koneet vierekkäin, palomuurit pois ja käynnistin eri palveluja satunnaisiin portteihin (esim. iperf) ja ei tullut mitään vastausta koskaan. Kyllä siellä joku NAT tai joku muu vänkää vastaan.
Käyttäjätaso 5
Oletko varma, että APN on varmasti internet4.

Oletko katsonut ipconfig komennolla mikä ip-osoite on verkkolaitteelle annettu paikallisesti. (Ei netconfig, kuten aiemmin olin horissut)

Jos ip alkaa 10.x.x...  jtn. niin tällöin olet NATin takana. Jos taas  paikallisesti (verkkolaitteelle annettu) ip-osoite on tuo 193.x tms alkuinen, niin sulla on ei-nat yhteys.   (Ja myös jos  tuon ip:n hostnamessa ilmenee nat, niin olet natattu.)

Joskus aiemmin muistan jonkun maininneen, ettei 900mhz taajuusalueella toimivissa mobiilikaistoissa portit ole auki tai niissä olisi paljon rajoituksia. Tästä ei SL ole kertonut.
APN on internet4. Yhteyden olen ottanut sekä wvdialilla, että Linuxin omalla network-managerilla.

ifconfig antaa ppp0-yhteydelle IP-osoitteeksi juurikin tuon 193.66.*.* osoitteen, joka ilmenee myös osoitteesta www.whatismyip.org eli se ei ole koskaan noita 10.*.*.*-luokan osoitteita. Hostnamessa ei myöskään ole mitään mainintaa natista, vaan se on *.gprs.sl-laajakaista.fi -päätteinen aina.

Syynä ei siis päättelyn jälkeen ole NAT, vaan jokin tukiasemien ongelma. Ei kuitenkaan paljon lohduta omistaa julkista IP-osoitetta, kun ei ole sisään tulevia portteja avoinna.
Käänsin antennin toiseen tukiasemaan, nyt tuntuu, että toimii. Voi olla, että on sattumaa. Mutta olisi hyvä kuulla oikea selitys tälle ongelmalle.
Ihan samanlaisia kokemuksia ja samanlaisella setupilla. Routerissa pyörii OpenWRT, internet4, jotkin sivut aukeaa joskus ja hetkenpäästä toiset, reconnect auttaa hetkeksi--- sekunneista tunteihin. Eilis iltana kuvittelin että tikun resetointi koneessa olisi antanut pidempiaikaisen avun, mutta tänään se ei auttanut.

Ongelmat alkoi ti tai ke. Voisi kokeilla VPN:ää työpaikalla ja sen kautta surffausta...
Samoja kokemuksia täälläkin. Tikku kiinni suoraan koneessa ja julkisella ip:llä (internet4) ei kaikki sivut aukene, mutta natin (internet.saunalahti) takaa toimii mainiosti.
Käyttäjätaso 4
Juuri tulleen tiedon mukaan tämä vika on saatu korjattua. Pahoittelen vikatilanteesta aiheutunutta haittaa.
Käyttäjätaso 6
Kunniamerkki
:)

Sama päätelaite ja  havainnot, lisään nyt mökillä Ylöjärvellä lyö Saunis DC päälle ja kenttä ei riitä niin putoaa GPRS nopeuteen. Pätkimiset jatkuvat molemmilla asetuksilla internet4 sekä internet.saunalahti, vaikka pakottaa 3G verkkoon mokkulan ja siinä on verkon täydet kentät.

Samoin Saunis tökkii Huawei E1762 tikulla ja vaihdoin kokeeksi molempiin päätelaitteisiin TeleFinland  netti perusnopeudella SIM:in, niin toimii esim. tikulla ->

Puutarhuri kirjoitti:
Sisäverkon ip-osoiteet ovat 10.xx.xx.xx alkuisia (eli NAT-osoitteenmuunnoksen takana ). Kaikilla muilla aluilla olevat osoitteet ovat julkisia, ilman osoitteenmuunnosta, osoitteita (esimerkiksi 193.xx.xx.xx tai 86.xx.xx.xx).

Mikäs osoite tämä sitten on, kun pitäisi olla julkinen, mutta Elisan sivu väittää sen olevan nat, mutta ei ala 10.xx?

"Julkinen (vaihtuva) IP-osoite tilattu liittymään . Palvelun käyttöä varten vaihda yhteysosoite internet4 päätelaitteesi asetuksiin. T.Saunalahti"

:smileyhuh:



REMOTE_HOST = 212-226-58-152-nat.elisa-mobile.fi
REMOTE_ADDR = 212.226.58.152
Käyttäjätaso 7
Kunniamerkki +5
Elisalta vissiin loppunut kaikki IP:t. 😉
IP vaihtui nyt korjauksen jälkeen 85-alkuisesta 193-alkuiseen... Eikös 193-alkuiset ole suoraltaan NATin takana...? Ja julkisella ip:llä ei näin muistaakseni pitänyt olla...
Tuskinpa kyse on yksittäisistä tukiasemista, koska moni on nyt kohdannut saman ongelman ja vieläpä samoina päivinä. Taitavat vanhat purkit hyytyä IPv6 päivityksen jälkeen 🙂 Sehän päivitys tapahtui tiistaina.
Käyttäjätaso 7
Kunniamerkki
antero kirjoitti:
Mikäs osoite tämä sitten on, kun pitäisi olla julkinen, mutta Elisan sivu väittää sen olevan nat, mutta ei ala 10.xx?

"Julkinen (vaihtuva) IP-osoite tilattu liittymään . Palvelun käyttöä varten vaihda yhteysosoite internet4 päätelaitteesi asetuksiin. T.Saunalahti"

:smileyhuh:



REMOTE_HOST = 212-226-58-152-nat.elisa-mobile.fi
REMOTE_ADDR = 212.226.58.152
On ilmeisesti todella ip:t lopussa, jos ei enää saa julkista, vaikka tilattu.

Natatuissa osoitteissa se 10.-alkuinen näkyy sisäverkkoon päin eli esim. käyttistasolta yhteyden tilaa tarkasteltaessa. Tuo myip-palvelu näyttää ulkoverkkoon päin näkyvän osoitteen, jotka voivat alkaa 193., 212. jne.
Itselläni sama ongelma. Olen korvessa, joten hyvin todennäköisesti liikenne hoituu saman tukiaseman kautta sekä kännykälläni että mokkulallani. Molemmissa on Saunalahden liittymä ja internet4 APN.

Kummallista kyllä, kännykän kautta tuntuu toimivan kaikki sivut, mutta tuon mokkulan kautta ei. Traceroutea kun vetää niin Elisan linkin jälkeen katoaa paketit monilta sivuilta. Eilen illalla ei oikeastaan mikään sivu toiminut, mutta ei-HTTP-liikenne kyllä. Kyllä siellä on jotain konfiguroitu nyt pahemman kerran päin mäntyä Saunalahden/Elisan päässä. 
KoTe60 kirjoitti:
On ilmeisesti todella ip:t lopussa, jos ei enää saa julkista, vaikka tilattu.

Natatuissa osoitteissa se 10.-alkuinen näkyy sisäverkkoon päin eli esim. käyttistasolta yhteyden tilaa tarkasteltaessa. Tuo myip-palvelu näyttää ulkoverkkoon päin näkyvän osoitteen, jotka voivat alkaa 193., 212. jne.

Niinhän se näkyy olevan omassa koneessa 10.xxx.;)

Oli vain Saunalahdella  linkki tarjolla ja katsoin siitä:

"

Saadun IP-osoitteen voi tarkastaa osoitteesta http://myip.kolumbus.fi:8000/myip

"

Voisiko tässä kuitenkin olla vain jokin viive sille, milloin ulkoinen ip-tulisi voimaan?
Käyttäjätaso 3
KoTe60 kirjoitti:On ilmeisesti todella ip:t lopussa, jos ei enää saa julkista, vaikka tilattu.

Huomasin tuon jo aikaa sitten. Vuoron perään tuli oikeita IP-numeroita tuli ja jaettuja. Oli pari juttua, jossa tarvitsin turvallisuussyistä oikean numeron ja nyt tuli sitten ei-oota.

Ehkäpä se IPV6 sitten joskus...
Käyttäjätaso 6
Kunniamerkki
Tahmis kirjoitti:
Samoja kokemuksia täälläkin. Tikku kiinni suoraan koneessa ja julkisella ip:llä (internet4) ei kaikki sivut aukene, mutta natin (internet.saunalahti) takaa toimii mainiosti.
Juu vaihdoin Sierra mokkulaan nyt tuon internet4 tilalle -> internet,saunalahti APN:ksi niin jytkii kaverin mökillä ??????Virrat Vaskivesi ja sivut aukeilevat (ainakin toistaiseksi), nyt nopeus:

Osallistu keskusteluun