Vastattu

Saunalahden mokkulan kautta vain osa nettisivuista aukeaa?

  • 18 kesäkuu 2013
  • 66 kommenttia
  • 10758 katselukerrat


Näytä ensimmäinen kirjoitus

66 kommenttia

Käyttäjätaso 3
Olen saannut Saunalahdelta ei roamaava simkorttia (multisim2 ja puhelinnumero löytyy Palstan profiilitietoista) mutta en edelleen pääse ftp://ftp.funet.fi/dev sivulle kun apn on internet4. Jos käytän internet.saunalahti sivu aukeaa joka kerta.

Olen nyt yrittänyt päästä sivulle 8.7.2013 kello 14.00-15.00 välisenä aikana ja sivu ei ole avautunut kertaakaa. Lokitietoista löydätte varmasti tätä.

Kaikki muut verkkusivut mitä olen kokeillut avautuu normaalisti.

Palstalla käyttäjällä garfield69 on sama vika (ongelmatilanne) kun minulla. 
Käyttäjätaso 4
hellqvist kirjoitti:
Olen saannut Saunalahdelta ei roamaava simkorttia (multisim2 ja puhelinnumero löytyy Palstan profiilitietoista) mutta en edelleen pääse https://ftp://ftp.funet.fi/dev" rel="nofollow sivulle kun apn on internet4. Jos käytän internet.saunalahti sivu aukeaa joka kerta.

Kokeileppa APN:ää internet, toimii ainakin minulla tällä uudella kortilla (joka siis ei enää näyttäisi roamaavan) ja sillä näyttäisi tulevan samantyylinen ulkoverkon IP kuin tuolla internet4:llakin. Itse ainakin pääsen sillä suoraan myös Funetin FTP:lle. Ja hassua että tuolla internet4:lla toimii mm. ftp://ftp.mpoli.fi ja ftp://ftp.sunet.se
Käyttäjätaso 3
Tosiaan apn internet toimii uudella simkortilla (ja myös sillä roamaavalla kortilla joka tuli muutama päivää sitten).

Aikaisemmin en ole voinut käyttää apn internet.

Pääsen ftp://ftp.funet.fi/dev  sivulle kun apn on internet, internet.saunalahti.

En pääse sivulle kun apn on internet4.

Pääsen ftp://ftp.mpoli.fi ja ftp://ftp.sunet.se sivuille ilman ongelmia vaikka käytän apn internet4.

Melko hassua kyllä että jotkut ftp sivut toimivat mutta jotkut ei.

Huomaan myös että pingplotterilla reitti on 7 askelta kun käytän internet4 (ping.funet.fi).

Jos käytän internet tai internet.saunalahti pingplotterin reitti on 6 askelta.

Voisiko tämä aiheuttaa että ftp://ftp.funet.fi/dev sivua ei aukea kun käytän internet4???

Totean siis samaa asiaa kuin garfield69
Käyttäjätaso 7
Kunniamerkki +2
Vika on ilmiselvästi jossain päin Elisan reititystä, ei tuo mitenkään muuten noin toimi. Nyt kun vaan saataisiin Elisan verkkojen ylläpitoon tuo tieto oikealle henkilölle, niin korjaus olisi varmasti ihan simppeli tehdä. Mutta miten, niin se onkin sitten hyvä kysymys. Veikkaanpa, että vikailmoitus lähtee palloilemaan ympäri ämpäri Elisaa ja se mihinkään johda.
Käyttäjätaso 6
Kunniamerkki +1
Minulla funetin ftp-palvelin toimii kaikilla sim-korteilla, jopa kaikkein uusimmallakin (roaming-vapaa kortti).
Käyttäjätaso 1
Morjens!

Olipa hyvä että huomasin tämän keskustelun. Olin nimittäin jo aiemmin selvittänyt ongelman syyn, mutta vian sijainti oli epäselvä. Epäilin omia päätelaitteitani jne. mutta nyt tilanne on täysin selvä.

Voin vahvistaa, että ongelma on vain internet4 APN:ssä ja internet.saunalahti toimii ok.

Mutta se ongelma. Ongelma on se, että jos käyttää internet4 APN:ää, eivät maksimi kokoiset paketit (1500 tavua) mene läpi Saunalahden/Elisan verkosta. Tästä johtuu se, että vaikkapa DNS-kyselyt toimivat samoin kuin ping-vastaa, koska nämä sovellukset käyttävät pieniä pakettikokoja. Jos taas alat siirtää webbisivua tai katsomaan videota käytetään tyypillisesti mahdollisimman isoa pakettikokoa, jotta siirto olisi tehokasta ja kun nämä isot paketit eivät pääse läpi, tökkii yhteys pahemman kerran tai ei toimi ollenkaan.

Ongelman voi kiertää asettamalla omiin päätelaitteisiin pienemmän MTU arvon. Näin tein itsekin Windows laitteisiin, mutta eihän tämä konsti onnistu vaikkapa puhelimissa tai tableteissa tms. eksoottisimmissa laitteissa. En jaksanut hakea sitä suurinta pakettikokoa mikä toimii, vaan laitoin kerralla riittävän pienen MTU arvon eli 1400.

Ja jos siis käyttää internet.saunalahti APN:ää, niin mitään ongelmia ei ole millään päätelaitteella.

On siis aivan turha etsiä vikaa omista päätelaitteista, kun se on Elisan verkossa internet4 APN:ää käytettäessä.

Ja jos haluat kiertää ongelman siihen saakka kun Elisa sen korjaa, niin vaihda päätelaitteesi MTU arvo vaikka 1400 tavuun, mikäli se vaan on mahdollista. Tai käytä internet.saunalahti APN:ää.

Olen tänään tehnyt vikailmoituksen Saunalahdelle ja pyrin saamaan ongelman mahdollisimman pian oikeiden henkilöiden tietoon Elisalla, jotta ongelma saadaan korjauttua. Tyypillisesti MTU-ongelmat johtuvat konfigurointivirheestä runkoverkossa ja ovat näin ollen helppo korjata, kunhan vain se vikakohta ensin löytyy. Se voi olla kiinni vain yhdestä yhteysvälistä ja sen asetuksista.
Käyttäjätaso 7
Kunniamerkki +3
Asiaa on näköjään pohdittu täällä Palstalla pitkin poikin, mutta kukaan ei ole vielä selittänyt asiaa noin kansantajuisesti. 

:worship::worship::worship:
Käyttäjätaso 3
Kiitos PulinatBoys. Toivottavasti Saunalahtii saa tätä korjattu. :worship::worship::worship:

 

 
Käyttäjätaso 3
Moi!

Laitoin tästä vielä kyselyä eteenpäin milloin tilanteeseen on tulossa korjausta. Vastailen tänne, kun saan asiasta lisätietoa. 

Hieno juttu että yhteyden saa toimimaan pienellä säädöllä paremmin! Tarkoitus olisi tietenkin saada palvelun sellaiseen kuntoon ettei ylimääräistä kikkailua tarvita. :)

Kiitos tästä!
Käyttäjätaso 3
Oletko saanut lisätietoa?

Edelleenkin en pääse ftp://ftp.funet.fi/dev sivulle kun APN on internet4. Jos käytän internet tai internet.saunalahti pääsen sivulle joka kerta.
Käyttäjätaso 3
Odottelen edelleen tarkempia tietoja tilanteesta.
Käyttäjätaso 3
Montako viikkoa luulet että kestää ennen kuin saat tarkempia tietoja?
Käyttäjätaso 1
Kyselin avaamastani vikailmoituksesta reilu viikko sitten ja uudestaan tänään.

Mitään sen ihmeempää tietoa ei vikailmoituksen merkinnöistä selvinnyt kuin että keikkaa on viety eteenpäin oikealle henkilölle ja että asia on käsittelyssä. Tänään kuitenkin asiakaspalvelija kertoi, että laittoi jonkun merkinnän, että asian käsittelyä kiirehdittäisiin.

Siispä tiedoksi muillekin, että ainakaan minun tietojeni mukaan ongelmaan ei ole tehty vielä mitään korjausta, mutta uskotaan ja toivotaan että kohta joku tekee...
Käyttäjätaso 3
PulinatBoys, sinulla on yksityisviesti.
Käyttäjätaso 5
PulinatBoys kirjoitti:

Kyselin avaamastani vikailmoituksesta reilu viikko sitten ja uudestaan tänään.

Mitään sen ihmeempää tietoa ei vikailmoituksen merkinnöistä selvinnyt kuin että keikkaa on viety eteenpäin oikealle henkilölle ja että asia on käsittelyssä. Tänään kuitenkin asiakaspalvelija kertoi, että laittoi jonkun merkinnän, että asian käsittelyä kiirehdittäisiin.

Siispä tiedoksi muillekin, että ainakaan minun tietojeni mukaan ongelmaan ei ole tehty vielä mitään korjausta, mutta uskotaan ja toivotaan että kohta joku tekee...



Tällaista viestiä sain itsekin kun kyselin asiasta. Tapaus on edelleen selvityksessä, eikä sitä ei todellakaan ole unohdettu. Vian ja sen juurisyyn rajaaminen on valitettavasti ollut haastavaa. Vikailmoituksesi perusteella sinuun ollaan kyllä yhteydessä kun tapaus on saatu selvitettyä mikäli ilmoitit yhteystietosi ilmoitusta jättäessä. 🙂
Käyttäjätaso 4
Oma arvioni on että tämä on jokin IPv6 DNS-pohjainen ongelma, näyttäisi siltä että APN=internet4 ohjaa jostain syystä DNS-kutsut IPv6:n puolelle jossa taas IPv6 DNS-palvelinta ei sitten löydykään.

Joku jolla on ylimääräistä aikaa, voisi kokeilla miten tämä APN=internet4 toimii käyttöjärjestelmässä jossa ei ole mitään purkka&liima IPv4_to_IPv6-tunnelointia käytössä tai IPv6-verkkoprotokollia edes asennettuna.

Lisäksi myös yli 1Mt tiedostot korruptoituu netin kautta siirrettynä.

Vika alkoi 7.3.2013 klo 02-> ja kai vieläkin odotellaan korjausta ( hidasta sanoisi härmäläinenkin ).

APN=internet4 normaalikäyttö on tosiaan ollut jo usean kuukauden käyttökelvottomassa tilassa, ellei muuta verkkolaitteen MTU asetusta 1500 -> 1400. Kaikki ei sitä kyllä osaa tehdä ja käyttöjärjestelmäkin voi kyseistä MTU arvoa säädellä automaattisesti.
Käyttäjätaso 1
Lisää väliaikatietoja...

Viime viikon keskiviikkona tuli tekstari missä kerrottiin, että häiriöilmoitus on käsitelty ja että liittymästä ei löydetty vikaa.

Soitin tietysti asiakaspalveluun ja varmistin mitä on tehty jos on tehty ja selvisi, että ongelmaa ei oltu onnistuttu toistamaan ja niinpä mitään korjaustakaan ei oltu tehty.

Avasin luonnollisesti uuden tiketin samasta ongelmasta. Selvittelin miten oli testattu ja testaus oli ilmeisesti tehty läppärillä missä on tikku kiinni. Kerroin, että ainakin itselläni on käytössä 3G-reititin missä tikku on kiinni ja en tiedä miten ongelma näkyy, jos testaus tehdään niin, että tikku on suoraan kiinni läppärissä. Testaukseen kun vaikuttaa käyttis ja sen asetukset ja mobiililaajakaista-ohjelmiston toiminta jne.

En nyt tarkkaan muista missä järjestyksessä asia aina vähitellen eteni, mutta testit aioittiin tehdä Saunalahdella nyt myös 3G-reitittimellä. Sain myös yhteydenottoja normaalia useammin ja tavoite oli siis ensivaiheessa se, että toistetaan ongelma myös Saunalahdella.

Viikonlopuna aikana testasin itsekin vielä asiaa todetakseni samat asiat vielä tarkemmin:

- n. 1440 tavun MTU-asetuksessa homma toimii ja n. 1450 tavun MTU-asetuksella homma ei toimi

- Analysoin Wiresharkilla liikennettä ja näin selkeästi, että IP-paketit fragmentoituvat jos MTU on isompi ja näistä fragmentoituneista paketeista osa ei tule serveriltä omalle läppärilleni asti ja lopulta läppäri lähettää ICMP:llä viestin palvelimelle, missä se kertoo, että aika, minkä kuluessa kaikkien fragmenttien pitäisi tulla läppärilleni, meni umpeen, joten siirto pitää tehdä uudestaan (mikä ei tietysti sekään auta asiaa). Siis täysin selvää pakettihävikkiä operaattorin verkossa.

- Ja jos joku ihmettelee, miksi MTU-arvon laskeminen omassa läppärissä voi vaikuttaa toimivuuteen, niin se johtuu siitä, että TCP-yhteyden avauksen yhteydessä käytetään MSS-optiota, millä kerrotaan oman pään MTU-arvo toiseen päähän ja näin palvelin pystyy laskemaan ko. TCP-yhteydelle käytettävää pakettikokoa normaalisti käyttämästään pakettikoosta. Tämäkin asia näkyi Wiresharkilla.

Eilen maanantaina sain soiton missä kerrottiin, että 3G-reititin oltiin saatu jumiin, mutta kun kyselin tarkemmin testauksesta niin kyseessä oli satunnainen laitteen kaatuminen kuormitustilanteessa. Ongelma pitää saada esille aivan tavallisessa www-sivun avauksessa ilman sen suurempaa kuormitusta.

Tänään sain soiton ja nyt oltiin vika onnistuttu toistamaan käsittääkseni juuri niin kuin se itsellänikin näkyy eli aivan "tavallisella surffauksella" ja asiaan pystyttiin vaikuttamaan vaihtamalla APN:ää tai säätämällä MTU-arvoa. Hienoa!

Sain myös kuulla että jossain, oli ko se nyt radioverkon puolella tms. asiasta ollaan tietoisia ja asiaa tutkitaan ja selvitellään. Kuulemma muitakin tikettejä oli aiheesta auki.

Vianselvitys on nyt siis lopulta saatu hyvin käyntiin ja käsittääkseni oikeille urille. Se on jo toinen juttu kauanko korjaus vie, varsinkin jos korjaus vaatii päivitettyä ohjelmistoa johonkin verkon komponenttiin. Uusi ohjelmisto, sitten kun se on saatavilla, kun tuskin korjaa vain tätä vikaa, vaan sillä voi olla vaikutuksia muihinkin asioihin ja niinpä sitä pitää testata ja kokeilla ennenkuin se uskalletaan ottaa käyttöön laajemmin. Voi tietty olla että löytyy joku vipu mitä säätämällä homma korjaantuu nopeamminkin.

Toivotaan, että saan jotain väliaikatietoja tilanteen kehittymisestä, varsinkin jos homma ei tule kuntoon nopealla aikataululla.
Käyttäjätaso 7
Kunniamerkki +2
Mielestäni tuo 1452 on oikea koko MTU:lle. Tähän lukuunhan päästään kun oletetaan, että "normaali" MTU olisi 1500. Tuosta pitää vähentää PPPoE:n tarvitsemat 8 tavua ja IP:n tarvitsemat 40 tavua (eli headerit). 

Sitten jos (kun) jossakin päin siirtoverkkoa on vielä ATM-laitteita, niin ne pilkkovat PPPoE paketit 53 tavun paketteihin (53 tavua - 5 tavua atm headerit, 48 tavun payload) eli lopputuoksena 30,25 ATM "solua" tai pakettia miten sen nyt haluaa kertoa. 0,25 ylimääräinen osuus on 12 tavua "jakojäännöstä" joka täytyy pistää lopuksi omaan ATM-soluunsa (joka siis on tuon 53 tavua aina). Tuohon pitää siis ATM-verkkolaitteen vielä pistää 36 tavua täytettä. Nämä kaikki kun vähennetään / summataan pyöritetään niin lopputuloksena olisi MTU 1440 lähtöpäässä, tällöin ATM:n kannalta kaikki olisi tehokkainta. Vaikka verkossa nyt onkin jossakin päin väärin konfiguroitu verkkolaite, niin jokatapauksessa mielestäni 1440 on kaikkein optimaalisin arvo =)

Huh, tulipas nyt analyysiä kerrakseen?
Käyttäjätaso 5
Kunniamerkki
PulinatBoys kirjoitti:

Sain myös kuulla että jossain, oli ko se nyt radioverkon puolella tms. asiasta ollaan tietoisia ja asiaa tutkitaan ja selvitellään. Kuulemma muitakin tikettejä oli aiheesta auki.

Vianselvitys on nyt siis lopulta saatu hyvin käyntiin ja käsittääkseni oikeille urille. Se on jo toinen juttu kauanko korjaus vie, varsinkin jos korjaus vaatii päivitettyä ohjelmistoa johonkin verkon komponenttiin. Uusi ohjelmisto, sitten kun se on saatavilla, kun tuskin korjaa vain tätä vikaa, vaan sillä voi olla vaikutuksia muihinkin asioihin ja niinpä sitä pitää testata ja kokeilla ennenkuin se uskalletaan ottaa käyttöön laajemmin. Voi tietty olla että löytyy joku vipu mitä säätämällä homma korjaantuu nopeamminkin.

Toivotaan, että saan jotain väliaikatietoja tilanteen kehittymisestä, varsinkin jos homma ei tule kuntoon nopealla aikataululla.


PulinatBoys asiasta jo kattavasti kertoikin. Tällä hetkellä tilanne on se, että mobiiliviankorjauksessa ollaan tietoisia tilanteesta ja tikettejä on asiaan liittyen tullut. Muutamaa asiakasta on asian tiimoilta kontaktoitu myös. Valitettavasti korjauksen aikataulusta emme kuitenkaan vielä pysty tarkemmin kertomaan. 
Käyttäjätaso 3
Hyvä että asia etenee .
Käyttäjätaso 5
Noniin, näihin internet4 apn -haasteisiin on nyt saatu korjausta meidän puolelta. Mikäli ongelmat eivät ole vielä korjautuneet, yhteyden katkaisemisen ja uudelleenluonnin pitäisi auttaa. Kannattaa tarvittaessa sammuttaa mobiililaajakaista-laitteet kokonaan ja yrittää toimivuutta uudemman kerran tämän jälkeen.
Käyttäjätaso 3
Kiitos. 

ftp://ftp.funet.fi/dev toimii nyt myös minulla vaikka käytössä on APN internet4.

🙂
Käyttäjätaso 1
Sain tänään iltapäivällä tekstarin missä kerrottiin jo täälläkin kerrotut asiat eli että vika on korjattu ja että yhteys pitää muodostaa uudestaan jotta homma alkaa toimia varmasti.

Testasin nyt illalla asiaa ja hyvin tuntuvat yhteydet toimivan vaikka PC:n MTU on 1500. Samoin yhteydet toimivat Android tabletilla millä aiemmin ei pystynyt yhteyttä käyttämään ollenkaan.

Tsekkasin myös Wiresharkilla miltä liikenne näyttää ja ei näkynyt fragmentoituneita paketteja eikä siis myöskään kadonnoita fragmentteja. Ei nyt ihan maksimi kokoisia paketteja sattunut näkymään mutta eipä paljoa puuttunutkaan ja toisaalta ei ole mikään pakko mennäkään aivan maksimi kokoisia paketteja - sovellukset/käyttis käyttävät arvoja mitä niihin on oletuksiksi laitettu. Tärkeintä on etteivät paketit fragmentoidu ja jumiudu sitten vaikka muuriin kun fragmentoidusta paketista ei löydykään  tarvittavia (otsikko)tietoja. Ja nyt ei siis fragmentoitumista tapahdu.

Homma siis vaikuttaa tulleen kuntoon. Kiitokset vian korjaajille!
Käyttäjätaso 7
Kunniamerkki +2
Eikä vienyt kuin 2 kuukautta :smileyshocked:
Käyttäjätaso 3
kimppikoo kirjoitti:
Eikä vienyt kuin 2 kuukautta :smileyshocked:

Kyllä siinä meni kauemmin kuin 2 kuukautta.

https:///t5/Tiedotteet/Mobiililaajakaistan-4G-k%C3%A4ytt%C3%A4j%C3%A4-lataa-laatumittari-ja-osallistut/td-p/268488/page/9

Varsinainen ongelmatilanne alkoi minulla jo viime vuoden puolella.

Osallistu keskusteluun