Vastattu

Saunalahden mokkulan kautta vain osa nettisivuista aukeaa?

  • 18 kesäkuu 2013
  • 66 kommenttia
  • 10758 katselukerrat

Käyttäjätaso 3
  • Tietolähde
  • 649 kommenttia
Mikähän nyt mättää, on mättänyt jo pari päivää. Eilen vielä huomattava osa sivuista aukesi kun jumin kohdalla laittoi uudestaan sivupyynnän päälle, mutta nyt ei enää sekään auta.

Esimerkiksi Tele Finlandin nettikauppa ei aukea, ja useita ulkomaisia ja kotimaisia sivuja jää täysin aukeamatta.

Ja kuitenkin moni sivusto aukeaa kuten tämä palsta ja speedtest joka näyttää liittymälle varsin hyvää nopeutta.

Näistä aukeamattomista sivuista Treceroute kertoo että "unknown host" mutta ne aukeavat sujuvasti TF:n mokkulaliittymällä.
icon

Vastauksen tähän kysymykseen jakoi -VJ- 18 kesäkuu 2013, 12:50

Löytyihän se syy, minulla olikin mokkulalla käytössä internet4 APN.

Vaihdoin sen internet.saunalahti -muotoon ja jo alkoivat sivut aueta.

Oikeastaan tässä on vasta puoli ratkaisua, pitäisihän myös internet4 apn:llä sivujen aueta?
Katso alkuperäinen viesti

66 kommenttia

Käyttäjätaso 1
Morjens!

Olipa hyvä että huomasin tämän keskustelun. Olin nimittäin jo aiemmin selvittänyt ongelman syyn, mutta vian sijainti oli epäselvä. Epäilin omia päätelaitteitani jne. mutta nyt tilanne on täysin selvä.

Voin vahvistaa, että ongelma on vain internet4 APN:ssä ja internet.saunalahti toimii ok.

Mutta se ongelma. Ongelma on se, että jos käyttää internet4 APN:ää, eivät maksimi kokoiset paketit (1500 tavua) mene läpi Saunalahden/Elisan verkosta. Tästä johtuu se, että vaikkapa DNS-kyselyt toimivat samoin kuin ping-vastaa, koska nämä sovellukset käyttävät pieniä pakettikokoja. Jos taas alat siirtää webbisivua tai katsomaan videota käytetään tyypillisesti mahdollisimman isoa pakettikokoa, jotta siirto olisi tehokasta ja kun nämä isot paketit eivät pääse läpi, tökkii yhteys pahemman kerran tai ei toimi ollenkaan.

Ongelman voi kiertää asettamalla omiin päätelaitteisiin pienemmän MTU arvon. Näin tein itsekin Windows laitteisiin, mutta eihän tämä konsti onnistu vaikkapa puhelimissa tai tableteissa tms. eksoottisimmissa laitteissa. En jaksanut hakea sitä suurinta pakettikokoa mikä toimii, vaan laitoin kerralla riittävän pienen MTU arvon eli 1400.

Ja jos siis käyttää internet.saunalahti APN:ää, niin mitään ongelmia ei ole millään päätelaitteella.

On siis aivan turha etsiä vikaa omista päätelaitteista, kun se on Elisan verkossa internet4 APN:ää käytettäessä.

Ja jos haluat kiertää ongelman siihen saakka kun Elisa sen korjaa, niin vaihda päätelaitteesi MTU arvo vaikka 1400 tavuun, mikäli se vaan on mahdollista. Tai käytä internet.saunalahti APN:ää.

Olen tänään tehnyt vikailmoituksen Saunalahdelle ja pyrin saamaan ongelman mahdollisimman pian oikeiden henkilöiden tietoon Elisalla, jotta ongelma saadaan korjauttua. Tyypillisesti MTU-ongelmat johtuvat konfigurointivirheestä runkoverkossa ja ovat näin ollen helppo korjata, kunhan vain se vikakohta ensin löytyy. Se voi olla kiinni vain yhdestä yhteysvälistä ja sen asetuksista.
Käyttäjätaso 1
Lisää väliaikatietoja...

Viime viikon keskiviikkona tuli tekstari missä kerrottiin, että häiriöilmoitus on käsitelty ja että liittymästä ei löydetty vikaa.

Soitin tietysti asiakaspalveluun ja varmistin mitä on tehty jos on tehty ja selvisi, että ongelmaa ei oltu onnistuttu toistamaan ja niinpä mitään korjaustakaan ei oltu tehty.

Avasin luonnollisesti uuden tiketin samasta ongelmasta. Selvittelin miten oli testattu ja testaus oli ilmeisesti tehty läppärillä missä on tikku kiinni. Kerroin, että ainakin itselläni on käytössä 3G-reititin missä tikku on kiinni ja en tiedä miten ongelma näkyy, jos testaus tehdään niin, että tikku on suoraan kiinni läppärissä. Testaukseen kun vaikuttaa käyttis ja sen asetukset ja mobiililaajakaista-ohjelmiston toiminta jne.

En nyt tarkkaan muista missä järjestyksessä asia aina vähitellen eteni, mutta testit aioittiin tehdä Saunalahdella nyt myös 3G-reitittimellä. Sain myös yhteydenottoja normaalia useammin ja tavoite oli siis ensivaiheessa se, että toistetaan ongelma myös Saunalahdella.

Viikonlopuna aikana testasin itsekin vielä asiaa todetakseni samat asiat vielä tarkemmin:

- n. 1440 tavun MTU-asetuksessa homma toimii ja n. 1450 tavun MTU-asetuksella homma ei toimi

- Analysoin Wiresharkilla liikennettä ja näin selkeästi, että IP-paketit fragmentoituvat jos MTU on isompi ja näistä fragmentoituneista paketeista osa ei tule serveriltä omalle läppärilleni asti ja lopulta läppäri lähettää ICMP:llä viestin palvelimelle, missä se kertoo, että aika, minkä kuluessa kaikkien fragmenttien pitäisi tulla läppärilleni, meni umpeen, joten siirto pitää tehdä uudestaan (mikä ei tietysti sekään auta asiaa). Siis täysin selvää pakettihävikkiä operaattorin verkossa.

- Ja jos joku ihmettelee, miksi MTU-arvon laskeminen omassa läppärissä voi vaikuttaa toimivuuteen, niin se johtuu siitä, että TCP-yhteyden avauksen yhteydessä käytetään MSS-optiota, millä kerrotaan oman pään MTU-arvo toiseen päähän ja näin palvelin pystyy laskemaan ko. TCP-yhteydelle käytettävää pakettikokoa normaalisti käyttämästään pakettikoosta. Tämäkin asia näkyi Wiresharkilla.

Eilen maanantaina sain soiton missä kerrottiin, että 3G-reititin oltiin saatu jumiin, mutta kun kyselin tarkemmin testauksesta niin kyseessä oli satunnainen laitteen kaatuminen kuormitustilanteessa. Ongelma pitää saada esille aivan tavallisessa www-sivun avauksessa ilman sen suurempaa kuormitusta.

Tänään sain soiton ja nyt oltiin vika onnistuttu toistamaan käsittääkseni juuri niin kuin se itsellänikin näkyy eli aivan "tavallisella surffauksella" ja asiaan pystyttiin vaikuttamaan vaihtamalla APN:ää tai säätämällä MTU-arvoa. Hienoa!

Sain myös kuulla että jossain, oli ko se nyt radioverkon puolella tms. asiasta ollaan tietoisia ja asiaa tutkitaan ja selvitellään. Kuulemma muitakin tikettejä oli aiheesta auki.

Vianselvitys on nyt siis lopulta saatu hyvin käyntiin ja käsittääkseni oikeille urille. Se on jo toinen juttu kauanko korjaus vie, varsinkin jos korjaus vaatii päivitettyä ohjelmistoa johonkin verkon komponenttiin. Uusi ohjelmisto, sitten kun se on saatavilla, kun tuskin korjaa vain tätä vikaa, vaan sillä voi olla vaikutuksia muihinkin asioihin ja niinpä sitä pitää testata ja kokeilla ennenkuin se uskalletaan ottaa käyttöön laajemmin. Voi tietty olla että löytyy joku vipu mitä säätämällä homma korjaantuu nopeamminkin.

Toivotaan, että saan jotain väliaikatietoja tilanteen kehittymisestä, varsinkin jos homma ei tule kuntoon nopealla aikataululla.
Käyttäjätaso 7
Kunniamerkki +2
Mielestäni tuo 1452 on oikea koko MTU:lle. Tähän lukuunhan päästään kun oletetaan, että "normaali" MTU olisi 1500. Tuosta pitää vähentää PPPoE:n tarvitsemat 8 tavua ja IP:n tarvitsemat 40 tavua (eli headerit). 

Sitten jos (kun) jossakin päin siirtoverkkoa on vielä ATM-laitteita, niin ne pilkkovat PPPoE paketit 53 tavun paketteihin (53 tavua - 5 tavua atm headerit, 48 tavun payload) eli lopputuoksena 30,25 ATM "solua" tai pakettia miten sen nyt haluaa kertoa. 0,25 ylimääräinen osuus on 12 tavua "jakojäännöstä" joka täytyy pistää lopuksi omaan ATM-soluunsa (joka siis on tuon 53 tavua aina). Tuohon pitää siis ATM-verkkolaitteen vielä pistää 36 tavua täytettä. Nämä kaikki kun vähennetään / summataan pyöritetään niin lopputuloksena olisi MTU 1440 lähtöpäässä, tällöin ATM:n kannalta kaikki olisi tehokkainta. Vaikka verkossa nyt onkin jossakin päin väärin konfiguroitu verkkolaite, niin jokatapauksessa mielestäni 1440 on kaikkein optimaalisin arvo =)

Huh, tulipas nyt analyysiä kerrakseen?
Käyttäjätaso 3
Oletko päivittänyt telakan ohjelmistoa?

http://support.netgear.com/product/aircard%2bhub" rel="nofollow" title="

Firmware Version 1.0.95.1 
vanha oli 1.0.95.0
Käyttäjätaso 5
Kuulostaapas ilkeältä vialta, eihän tuota APN:ää varmaan huvita vaihdella sen takia että jollekin tietylle sivulle sitten pääsisi.

Voisitko hellqvist laittaa tietoihisi tai vaikka minulle YV:nä asiakasnumeron tai puhelinnumeron missä tämä ongelma ilmenee niin tutkitaan asiaa tarkemmin. Tutkitaan -VJ- tuo sinunkin vika samalla, koska sama vika näissä nyt luultavasti on.
Käyttäjätaso 3
Löytyihän se syy, minulla olikin mokkulalla käytössä internet4 APN.

Vaihdoin sen internet.saunalahti -muotoon ja jo alkoivat sivut aueta.

Oikeastaan tässä on vasta puoli ratkaisua, pitäisihän myös internet4 apn:llä sivujen aueta?
Käyttäjätaso 6
Kunniamerkki
Sydeemi kirjoitti:
MTU nyt Dovadossa 1500 ja näkyy toimivan. Aamupäivällä oli muutaman hidastelun ja pätkimisen jälkeen pari tuntia yhteys täysin poikki. Mahtoiko johtua verkon säätämisestä?



En tiedä mistähän tämäkin johtuu? Minulla 4G yhteys Sierra mokkula + telakka ja eternet kaapelilla yhteys siihen, aikas usein, kun kommentoin esim. Facebook niin pätkäisee yhteyden ja käynnistyy uudelleen. Toistuu muuten joskus täällä Saunis sivuillakin kommentoidessa.
Käyttäjätaso 4
hellqvist kirjoitti:
Edelleen sama ongelma, kun apn on internet4 en pääse  ftp://ftp.funet.fi/dev sivulle.

Internet.saunalahti ja pääsen sivulle joka kerta.

Voin vahvistaa tämän, tuolla internet4:lla ei pääse edes ftp.funet.fi -hakemistoonkaan, APN:n muutos internet.saunalahteen  ja hakemisto avautuu heti. Yhteys SIerra 762S:llä DC-verkossa, kaikki muut pelaa suht normaalisti. (Ja nyt kun muuttelin APN:ää niin tipahdin taas  roamingiin... toivotaan että Norriksen testikortti auttaa tähän)
Käyttäjätaso 4
hellqvist kirjoitti:
Kiitos garfield69. Nyt vihdoinkin todistettu että myös muilla on sama ongelma ftp://ftp.funet.fi/dev kanssa.

 

Mielenkiintoista tässä on että molemmilla on MLK+Nopsa ja multisim ja molemmat käyttävät SIerra 762S DC-verkossa.

 

Voisitko kertoa missä päin Suomessa olet. Minun postinumero on 65630 Karperö.

 

Voisitko viellä kokeilla jos saat sivu aukeamaan tällä "systeemillä"?

 

Pääsen ftp://ftp.funet.fi/dev sivulle jos kopioin osoitetta useita kertoja nopeasti seilamen osoitekenttään ja painan enter nappulaa joka kerta. Tämä siis joutuu tehdä 3-4 kertaa 5 sekunnin sisällä, vain silloin saattaa sivua aukeamaan kun APN on internet4. 

51200 ja täällä Etelä-Savon / Keskisuomen rajamailla ;)

Testasin pikaisesti puhelimen yhteydellä (android) ja sillä tuo ftp aukesi myös internet4 APN:llä. Mutta puhelimessa on uusi, huhtikuussa tullut kortti, Sierrassa taasen vanha n. 2010 tienoilta oleva kortti. Tällä viikolla pitäisi tulla testattavaksi tuo uusi roamaamaton kortti tuohon Sierraan, täytyy testata sen kanssa.

Kokeilin nyt myös koneella tuota pikanaputtelua, ja hetkosen jälkeen hakemistokin avautui. Mielenkiintoista... Koneessa on käyttiksena Linux ja selain Firefox, eikä Chromenkaan käyttö vaikuta.

En nyt kyllä tätä ensimmäisenä Sierrankaan syyksi vierittäisi. Ennenminkin veikkaisin sim-kortin vaikutusta, mutta kohtahan tuo nähdään.
Käyttäjätaso 3
Kiitos. 

ftp://ftp.funet.fi/dev toimii nyt myös minulla vaikka käytössä on APN internet4.

🙂
Käyttäjätaso 3
Moi!

Laitoin tästä vielä kyselyä eteenpäin milloin tilanteeseen on tulossa korjausta. Vastailen tänne, kun saan asiasta lisätietoa. 

Hieno juttu että yhteyden saa toimimaan pienellä säädöllä paremmin! Tarkoitus olisi tietenkin saada palvelun sellaiseen kuntoon ettei ylimääräistä kikkailua tarvita. :)

Kiitos tästä!
Käyttäjätaso 3
Odottelen edelleen tarkempia tietoja tilanteesta.
Käyttäjätaso 1
Sain tänään iltapäivällä tekstarin missä kerrottiin jo täälläkin kerrotut asiat eli että vika on korjattu ja että yhteys pitää muodostaa uudestaan jotta homma alkaa toimia varmasti.

Testasin nyt illalla asiaa ja hyvin tuntuvat yhteydet toimivan vaikka PC:n MTU on 1500. Samoin yhteydet toimivat Android tabletilla millä aiemmin ei pystynyt yhteyttä käyttämään ollenkaan.

Tsekkasin myös Wiresharkilla miltä liikenne näyttää ja ei näkynyt fragmentoituneita paketteja eikä siis myöskään kadonnoita fragmentteja. Ei nyt ihan maksimi kokoisia paketteja sattunut näkymään mutta eipä paljoa puuttunutkaan ja toisaalta ei ole mikään pakko mennäkään aivan maksimi kokoisia paketteja - sovellukset/käyttis käyttävät arvoja mitä niihin on oletuksiksi laitettu. Tärkeintä on etteivät paketit fragmentoidu ja jumiudu sitten vaikka muuriin kun fragmentoidusta paketista ei löydykään  tarvittavia (otsikko)tietoja. Ja nyt ei siis fragmentoitumista tapahdu.

Homma siis vaikuttaa tulleen kuntoon. Kiitokset vian korjaajille!
Käyttäjätaso 7
Kunniamerkki +2
Eikä vienyt kuin 2 kuukautta :smileyshocked:
Käyttäjätaso 1
Viikko sitten tiistaina muutaman iterointikierroksen jälkeen tämä ongelma (eli se että isot paketit hukkuivat Elisan verkossa) saatiin korjattua. Vanhan tiketin tiedot löytyivät ja homma korjaantui tällä kertaa selvästi nopeammin. Kiitokset siitä.
Käyttäjätaso 7
Kunniamerkki
Ja lukutaitoiset voi myös miettiä sitäkin, kuinka ppp- yms.modeemi-yhteyksien MTU-arvojen muokkaus koneen asetuksissa vaikuttaa, kun käytetään reitittimiä tai "verkkokortti"-yhteyksiä.

Tätä samaa sivujen aukeamattomuus -ongelmaa setvittiin muistaakseni joskus pari vuotta sitten. Silloin operaattori löysi (tai oli löytävinään) jonkin ongelman omilta palvelimiltaan, jonka korjaus ilmeisesti ratkaisi ongelman. Ainakaan pitkään aikaan ei ole näkynyt vastaavia valituksia. Liekkö nytkin ongelma siellä päässä....
Käyttäjätaso 7
Kunniamerkki +2
1440 on osoittautunut ilmeisesti riittävän pieneksi.
Okei. Nyt sain toimimaan kaiken. Vähän sörkin asetuksia yhteys asetus manulle ei auttanut eikä mitkään muutkaan mutta heti kun siirsi autolle niin johan alko toimimaan. Jotain se kai resetoi vaikken olekkaan säätänyt mitää muuta kuin salasanan ja se on vieläkin sama. Internet4 asetus toimii myös.
Käyttäjätaso 5
Tällaista vikaa ei meillä ainakaan ole vielä tiedossa. Kokeilin myös esimerkiksi tuota mainitsemaasi nettikauppaa ja tuntui ainakin omalla mobiili-liittymällä aukeavan ihan hyvin. Olisiko muilla käyttäjillä ollut vastaavanlaisia ongelmia?
Käyttäjätaso 7
Kunniamerkki +5
Aukeaa täälläkin Telen laitekauppa. Elisan Dual Carrier.
Käyttäjätaso 3
https://kauppa.tele.fi/telefinland/valikoima/nettiliittyma.aspx?

Yllä on aukeamaton linkki. 

http://www.feeldesain.com/adzero-bamboo-smartphone-concept.html

Tässä toinen.

Mikähän näissä sitten mättää, ei koneen verkkoasetuksiinkaan ole tehty mitään muutoksia ja Huawei E589 mokkula on käytössä.
Käyttäjätaso 7
Kunniamerkki +5
Kummatkin toimivat tänne.

Kokeile irrottaa mokkula koneesta ja pistä se takaisin.
Käyttäjätaso 7
Kunniamerkki +3
Asiaa on näköjään pohdittu täällä Palstalla pitkin poikin, mutta kukaan ei ole vielä selittänyt asiaa noin kansantajuisesti. 

:worship::worship::worship:
Käyttäjätaso 4
koupo1 kommenttiin:

Wlan tukiasema hakee periaatteessa automaattisesti vapaan kanavan. Se automatiikka ei aina toimi kunnolla. Yleisemmät "naapurien" käyttämät kanavat on 6 ja 11. Eli manuaallisesti voisi kokeilla esim 3 kanavaa. Scannaamalla näkee, mitkä on varattuna, niin sen perusteella olisi helpoin valita vapaa.
Jos siis on samalla kanavalla, pätkii ja oikuttelee varmasti.
Mutta voihan olla, että oli jotain muutakin.
Mutta hienoa, että taas toimii. 🙂
Käyttäjätaso 3
Oletko saanut lisätietoa?

Edelleenkin en pääse ftp://ftp.funet.fi/dev sivulle kun APN on internet4. Jos käytän internet tai internet.saunalahti pääsen sivulle joka kerta.

Osallistu keskusteluun