Kysymys

SaunaVisioVBS

  • 2 heinäkuu 2009
  • 177 kommenttia
  • 12491 katselukerrat


Näytä ensimmäinen kirjoitus

177 kommenttia

Oikein veikkasit, ei toimi Elisaviihteessä, mutta SaunaVisio avautui toisen ja viimeisen rivin koodeilla. Sisältö on tietty sama, ulkoasu erinäköinen.

Tunnukset toimivat kenttiin kirjoitettaessa, eivät vain tule luetuksi automaattisesti scriptistä.


SaunaVision puolelle tunnuksen/salasanan voi antaa selaimen osoitekentässä.
(SaunaVisioVBS käyttää tuota tapaa kirjautumiseen).


http://www.saunavisio.fi/tvrecorder/index.sl?username=XXX&password=YYY

http://www.saunavisio.fi/tvrecorder/default.sl?username=XXX&password=YYY

Nuo kaikki vaihtoehdot toimivat selaimen osoitekenttään syötettäessä, siis SaunaVision puolella.

Ovatko nyt sitten suuressa viisaudessaan menneet poistamaan tämän ominaisuuden ElisaViihteen puolelta?
En tiedä, enkä pysty testaamaan kun on tunnukset pelkästään SaunaVisioon.

Kokeile siis antaa selaimen osoitekenttään


http://elisaviihde.fi/etvrecorder/index.sl?username=XXX&password=YYY

http://elisaviihde.fi/etvrecorder/default.sl?username=XXX&password=YYY

ja raportoi toimiiko, veikkaisin että ei toimi.

Pikaisesti kun vilkaisin ElisaViihteen sisäänkirjautumista niin näytti siltä että sinne on ripoteltu keksinmurusia joukkoon,
mikäs siinä, kyllä mulle keksit maistuu. Saattaa siis olla että SaunaVisioVBS vaatii pientä päivitystä.
Tunnukset toimivat kenttiin kirjoitettaessa, eivät vain tule luetuksi automaattisesti scriptistä.
Entäs nämä?


[url=http://elisaviihde.fi/etvrecorder/default.sl?username=XXX&password=YYY]http://elisaviihde.fi/etvrecorder/default.sl?username=XXX&password=YYY


Voisit kysellä tuolla ElisaViihteen palstalla pitäisikö noiden url-kentässä annettujen tunnus/salasana juttujen vielä toimia.
http://palsta.elisa.fi/index.php?board=23.0[/url]
Ei toimi. Pyytää edelleen tunnuksia.

SaunavisioVBS on alkanut kysyä tunnuksia viime aikoina ainakin Elisaviihteen puolella. Ongelma ei ole suuri mutta haitallinen.


Jos selaimen url-kenttään antaa

http://elisaviihde.fi/etvrecorder/index.sl?username=TUNNUS&password=SALASANA

niin toimiiko silloin? (TUNNUS ja SALASANA tietenkin omat)
SaunavisioVBS on alkanut kysyä tunnuksia viime aikoina ainakin Elisaviihteen puolella. Ongelma ei ole suuri mutta haitallinen.
Jahas tulipa vahingossa assennettua IE9. Nyt ei suostu enää avaamaan vlc:n activex -controllia ja skriptissäkin on mukamas joku virhe. MUTTA kun laittaa IE:n compatibility modeen niin toimii. (se revityn paperin näkönen) Jollain parametrillähän sen sais aukeemaan aina siihen modeen, ja ehkä samalla voisi "suojata" skriptin toimivuutta tulevien "parannusten" varalta. En vielä löytänyt parametriä mutta modeista on jotain http://www.rbsolutions.us/browsers/ie-8-compatibility.html ... Tai sitten yritän saada IE8:n takas. Hohhoijjaa.
Ärrinmurrin asensin uudestaan myös vlc:n, nyt se päästää activex:n läpi. Eli toimii. Mutta jokatapauksessa tolla compatibility modella sais ehkä jotain vakautta?
vlc:n parametrit pitää nykyään laittaa "--sub-language=fi", ei "--sub-language fi" enää. Mun parametrit on:
vlc_param   = "--sub-language=fi --sub-margin=-65px --global-key-subpos-down=down --global-key-subpos-up=up --deinterlace=1 --deinterlace-mode=yadif2x --http-caching=9000 --http-reconnect --fullscreen --high-priority" (joo tiedän että toi cache on iso mutta mulla talossa on huonot piuhat tai jotain)

Keksiikö kukaan miten vlc:n sais toistamaan minkä tahansa muun ääniraidan paitsi visual-impairedin eli netherlandin? Teeman leffoissa se on aika ärsyttävää kun se valitsee sen aina ensin. Tietysti "--global-key-audio-track=a" esim. on mukavampaa painaa a-nappulaa kun söhlää hiiren kanssa sormet dipissä =:)
Mikäs auttais ElisaViihteessä?
Koittakaas ne joilla on ongelmia VLC:n kanssa IE9:llä mennä Saunavision sivuille ja klikata yhteensopivuustilaa (osoiterivillä revityn paperin näköinen kuvake). Tuon jälkeen VLC videoita voi taas katsella sivuilla.

Tämä taisi lopulta olla se mikä korjasi myös SaunaVisioVBS:n toiminnankin itsellä.
Tulipa päivitettyä IE versioon 9. JA sitten ei enää VLC aukenekaan.

Ääni kyllä jostain alkoi kuulua ja loppui vasta, kun Tehtävänhallinnasta kävin tappamassa prsessin Internet Explorer.

WIN 7 64 bit.

Edit: Tallenne aukesi nyt selaimen ikkunassa (IE9) mutta ei VLC:ssä. Scriptivirheestä valitti, mutta en huomannut ottaa ilmoa talteen.
Mulla kanssa Win7x64 ja ongelmia IE8 ja IE9 kaikkien versioiden kanssa "Hardware YUV" -ikkunan kanssa kahdella eri koneella.  Nopeasti katsottuna maailmalla myös Mozilla-käyttäjillä on vastaavia ongelmia.

Tein itse yhden asetusmuutoksen ja en saanut kymmenellä testauskerralle enää virhettä toistumaan. Eli vaihdoin Asetukset->Video->Ulostulo -kohdasta Oletuksen sijasta Windows GDI Output. Sopii testata.

EDIT: paitsi että kuvanlaatuhan tolla GDI:llä muuttui susipaskaksi 😃 No tosta voi kuitenkin edetä.
EDIT2: Vaihdoin takaisin oletuksen, mutta laitoin DirectX Outputiin Oletuksen sijasta "display". Toinen vaihtoehto oli joku "\.DISPLAY1" tmv. Sillä taas useampi kokeilu onnistunut. Testailen lisää. Tuo jälkimmäinen näyttö lienee joku Virtual PC:n juttu, onko muillakin vian uhreilla XP Mode asennettuna?

EDIT3: Minusta tuo oletusnäytön määrittäminen VLC:n asetuksissa korjasi ongelman. Ei ainakaan esiintynyt noin 30 kerran testikokeilun aikana.
Mulla on win7x64, ja internet exploder 8... Sain siis toisellakin winx64 koneella sen ylimääräisen raw-ikkunan. Nyt uuden vlc 1.1.6:sen myötä äänen v***umainen napsuminen läks, täytyis ehkä stedaa uusinta skriptiäkin jos sekin vaikka toimis. Kantsii muuten laittaa toi --http-reconnect niin pausettaminenkin onnistuu paremmin. Mulla hukkas yhteyden jos pausetti puolta minuuttia pidempään.

Hei! Uusimmassa versiossa käy niin että kun sulkee vlc:n ja avaa toisen tallenteen niin vlc avaa ylimääräisen internet explorer-ikkunan jossa pyörii raw videota tai jotain, eikä sitä saa kiinni kun sulkemalla internet explorerin.


Mikä windows versio, 32 vai 64 bittinen?
Siis samalla koneelle uusin bugittaa mutta muokkaamasi toimii?
ElisaViihdettä en pysty testaamaan kun mulla on SaunaVisio.
Napsuuko muuten ääni muilla kun mulla? Sellanen pari kertaa minuutissa pieni rasahdus, ennen toimi ihan hyvin... Vlc väittää että kaikki on virheettömästi toistettu.
Päivitetty
- asetussivulla hiiren klikkaus aiheutti aina virheilmoituksen
Vastaankin itselleni: kokeilin taas eri VLC:n versiota ja kuinka ollakaan, kuvakin tuli näkyviin.
Nolo juttu vaivata taas pekkoa: asensin käyttiksen (Windows 7 64 bit) uudelleen (ei kannata kysyä miksi) ja SaunavisioVBS:n tallennuksessa VLC käynnistyy ilman kuvaa, ääntä tulee kyllä. VLC:n käynnistymistä jarruttaa pikku ikkunan ilmoitus: Building font cache.
Olen kokeillut muutamilla VLC:n versioilla, myös VLC 1.2 beetalla.
Kiitos jo etukäteen, jos sinulla on ratkaisu ja viitsit vastata.
Kiitos pekko!

Taas mennään.
Jos liittymä on esim. 8M ja haluaa antaa siitä puolet eli 4M wget ohjelmalle.
wget_param    = "-t0 -c -S --progress=dot:mega -o" & tmp & "SaunaVisioVBS_wget.log --limit-rate=400K"
Vaihdoin tähän uusimpaan kun lautukset ja katselu toimivat samasta ikkunasta.

Kaikki toimii, mutta ladatessa ilmeisesti WGET varaa koko kaistan niin että mikään muu ei toimi.

Koitin vanhasta scriptistä kopioida rivin, jossa oli määriteltynä limit, mutta ei toimi lainkaan. Koodauksesta en tajua mitään, joten rautalankaa, kiitos.
Huvikseni poistin, kun en ole käyttänyt sitä muuten. Asennan sen uudelleen tarvittaessa.
Kiitos vastauksesta.
SaunaVisioVBS vaatii InternetExplorerin toimiakseen.
ööö, miksikäs se InternetExplorer piti poistaa.

Kokeile tätä, sitä tosin ei ole päivitetty vähään aikaan.
http://palsta.saunalahti.fi/index.php/topic,12243.0.html
Poistin Internetexplorerin koneeltani eikä SaunaVisioVBS tykännyt siitä.
Onko mahdollista käyttää selaimena esimerkiksi Googlen Chromea? Ilmeisesti scriptiin pitää kirjoittaa jotakin muuta internetexplorer.applicationin tilalle.
Päivitetty:
- lisätty edellä mainittu korjaus

Osallistu keskusteluun