Huawei E3372 kokemuksia?



Näytä ensimmäinen kirjoitus

232 kommenttia

tarvitsee vain usbnet ja cdc_ether moduuleja. Jos sinulla ei toimi ilman jippoja, on huaweisi wanhempi kuin minulla.

Hardware version:CL1E3372SM
Software version:22.298.03.00.07
kun huawei on tunnistettu, tulee

[ 7.512240] cdc_ether 2-1.4.3:1.0 eth0: register 'cdc_ether' at usb-0000:00:1d.0-1.4.3, CDC Ethernet Device, 0c:5b:8f:23:45:67
[ 7.513465] usbcore: registered new interface driver cdc_ether
[ 7.517165] cdc_ether 2-1.4.3:1.0 enp0s29u1u4u3: renamed from eth0

jos et tykkää randomi laitteennimistä:
# cat /etc/udev/rules.d/70-persistent-net.rules
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="0c:5b:8f:23:45:67", NAME="lte"

sitten tulee:

[590402.966917] cdc_ether 5-1:1.0 lte: renamed from eth0

NetworkManager konffii huawein automaagisesti..  se toimii, kunhan usb_modeswitch ja usb_modeswitch-data on asennettu.

AT-komentoja en ole minnekään säätänyt.

mbim ei toimi tämän modeemin kanssa, pitää käyttää cdc_ether, valitettavasti.  
Tuollasta sanoo: ^HVER:"CL1E3372SM Ver.A", onko tuo Ver.A sitten ratkaiseva tekijä vai ilmoittaako vain eri tavalla?

Onko antaa linkkiä tuohon firmikseen? Kyseistä firmistä en googlettamalla ainakaan löydä, voisi vielä silläkin testata.
Ver. A:n merkityksellisyydestä ei ole tietoa.

Ei ole linkkiä firmikseen, kyseessä on Soneralta saatu laite vakiofirmiksellä.
Joopelis, vähän alkas näyttämään siltä että se on tuosta firmiksestä kiinni että alkaa toimimaan. Eipähän se auta kuin kiltisti ootella että tulee joskus julkiseen jakeluun, toimiipa se tuo PPP kikkarekkin sen aikaa.
Käyttäjätaso 7
Kunniamerkki
Kyllä sen saa toimimaan muillakin firmiksillä kuin tuolla Soneran 22.298-versiolla. Ja onneksi näin, koska Soneran versiolla ei taas toimi Winkku-puolella LTEWatchH-softa (mm. taajuuslukitus ja tarkat signaaliarvot). 

Sekä tuo Soneran että DNA:n versiot (22.286...182) toimivat samoin, vaikka tunnistuvatkin eri tavalla, eli PID on eri (157D vs. 1F01) ennen flip-floppia. Molemmat toimivat ilman kikkailuja "kiinteänä" eli cdc-ether-ajurilla.

Se puolestaan on vähän outoa, että muilla HiLink-firmiksillä (esim. generic 22.286.03:lla) pitää asentaa linux_mbb_install (tikun sis. muistista kopioimalla koneelle), ennenkuin lähtee pelaamaan samoin kuin em. versiot. Ja näin, vaikka tuokin tikku tunnistuu täsmälleen samalla PID:illä (1F01) ennen modeswitchiä. Moodivaihdon jälkeen kaikilla HiLinkeillä on sama PID eli 14DC.

Ja nopeuksien puolesta näyttää normi-firmikselläkin varustettu toimivan ihan riittävän nopeasti, vaikka ppp:llä menee...
Otimpa vielä kerran tikun päivityksen alle ja testasin 22. version firmiksellä, sieltähän se cdc_ether sen löysi mutta syaani vaan jatkaa vilkkumista vaikka tikku antaa IP:n koneelle ja vastaa pingiin. Ei nouse yhteys niin ei nouse.

Nyt kun meinasin että kokeillaan jotain toista firmistä niin Windows ei tajua tikusta enää mitään. Kokeiltu kahdella eri koneella, kaikki tarjoaa samaa. Päivitysohjelmat antaa virhe 10, myös se jolla portit pitäisi aueta. Onkos tähän jotain kikkakolmosta vai liipasenko tikun kankaalle?
Käyttäjätaso 7
Kunniamerkki
juuh kirjoitti:
Otimpa vielä kerran tikun päivityksen alle ja testasin 22. version firmiksellä, sieltähän se cdc_ether sen löysi mutta syaani vaan jatkaa vilkkumista vaikka tikku antaa IP:n koneelle ja vastaa pingiin. Ei nouse yhteys niin ei nouse.

Nyt kun meinasin että kokeillaan jotain toista firmistä niin Windows ei tajua tikusta enää mitään. Kokeiltu kahdella eri koneella, kaikki tarjoaa samaa. Päivitysohjelmat antaa virhe 10, myös se jolla portit pitäisi aueta. Onkos tähän jotain kikkakolmosta vai liipasenko tikun kankaalle?

Mikä 22-firmis? Niissäkin on kahta sorttia eli löytyy myös ns. Huawei Mobile -versio, joka toimii eri tavalla kuin HiLink?

Ajoitko sen linux_installin? Kuten edellä totesin, se TÄYTYY ajaa noilla muilla HiLink-22-firmiksillä paitsi Soneran ja DNA:n versioilla.

Minkä WebUI:n asensit tikulle firmis-muutoksen jälkeen? Asensitko Windows-koneelle Mobile Broadband -ajurit eli ajoit sen "cd-rommilla" olevan asennuksen ja tikku toimi HiLinkkinä ok Win-koneella? 
22.286.53.01.161 ja 17.100.06.00.03_HiLink, molemmat toimi eilen ongelmitta, tänään päivityksen jälkeen ei windows tajua tikusta mitään muuta kuin tuon muistikorttipaikan ja "CD"-aseman joka on täysin tyhjä.

Linuxissa testasin tuota mbb juttua, ei toimi sen kanssa eikä ilman, kiltisti tulee IP mutta syaani jatkaa vilkkumistaan.
Käyttäjätaso 7
Kunniamerkki
Satuitkin valitsemaan juuri sen HiLink-version (Beeline), joka on varmaan ongelmallisin tarjolla olevista. Ja tuo WebUI on tikun h-versiolle tarkoitettu, jonka ei tosin pitäisi edes asentua s-tikulle, mutta ilmeisesti asentuu. 

Tutkitusti toimiva yhdistelmä on generic-22.286. ja 16-sarjan WebUI.

Onko Windows-koneessa Mobile Broadband service varmasti käytössä? Tai sitten jotain häikkää asennuksessa, mihin en ole aikaisemmin törmännyt, jos "Sharing devicea" ei löydy.

Tuliko Linuxissa laitteen ip eli 192.168.8.1? Yrititkö päästä selaimella hallintasivulle?
Windowsissa ei ole tuota palvelua, tyhmänä poistin sen eilen kun ajattelin etten sitä enää tarvitse kun PPP toimi noin hyvin. Nyt en saa takaisin kun tikulta ei löydy mitään. Koitin googlella etsiä mutta aika heikosti tarjontaa. Tikku ei siis Windowsissa näy lainkaan, virtuaalikoneelle näkyy USB-laitteena xxxx muttei sitä voi "siirtää" virtuaali koneelle.

Linuxissa kun yrittää mennä tuohon 192.168.8.1 hallintasivulle niin miettii hetken ja sanoo "The page isn't redirecting properly" mbb:llä sekä ilman, tikun "CD-asemaa" mountatessa antaa virheen ettei ole mediaa.

Tuon firmware päivityksen jälkeen toimi vielä normaalisti, sitten boottasin koneen ja meni tuollaiseen tilaan.

Testannut eri linux distroja livecd:ta, mutta aina sama homma. Taitaa olla siis entinen tikku, onneks nuo Latvian tikut ei nyt mahottomia kustanna joten pistin tulemaan jo uuden tikun. Huvittavaa että koskaan sitä ei opi ettei kannata yrittää korjata toimivaa :)

edit: korjattu skandit
Nyt ei enää minkään valtakunnan firmis suostu asentumaan tikulle. Tulee virhekoodi 10 porttia ei löydy. Tulikohan tästä nyt avaimen perä.
Käyttäjätaso 7
Kunniamerkki
jukula84 kirjoitti:
Nyt ei enää minkään valtakunnan firmis suostu asentumaan tikulle. Tulee virhekoodi 10 porttia ei löydy. Tulikohan tästä nyt avaimen perä.

Voi olla, tai voi olla olemattakin. 10-koodi tulee kyllä joskus toimivallakin tikulla, eli kyseessä voi olla myös ongelmatilanne.
jukula84 kirjoitti:
Nyt ei enää minkään valtakunnan firmis suostu asentumaan tikulle. Tulee virhekoodi 10 porttia ei löydy. Tulikohan tästä nyt avaimen perä.

Kuten tuosta edeltä voit lukea niin sain tikun samaan tilaan jostain kumman syystä. Sain kuitenkin tuon HiLink softan asennettua koneelle (iso kiitos KoTe60) ja tikku rupesi portteja aukomaan kun päivityssoftaa pisti perään. Kerkesi tässä välissä tulla jo toinenkin E3372 tikku mutta ompahan varalla ainakin toimiva jos toisen saa taas juntturaan.

Vähän tuntuu ettei näitä Huihain tikkuja ihan täysin pilalle saa aivan helpolla, E392 kanssa myös joskus aikoinaan tuli hieman jännäkakka kun testailin eri firmiksiä ja sitten katosi kaikki mutta jollain kikalla sen taas sain elävien kirjoihin.
Nyt sain huawein pelaamaan. DC-Unlocker client nimisellä ohjelmalla sain jotenkin räpellettyä tikun tilaan että flashäys onnnistui. Millään muulla kikalla tikku ei suostunut tunnistautumaan.

Loppu hyvin kaikki hyvin.
Morjes,

sattuipa käteen ulkomailta puolivahingossa E3372, joka onkin mallia WCDMA900/2100MHZ, eikä näin ollen toimi Suomessa.

Onkohan tuo tikku taajuusalueriippuvainen firmwaren kautta, vai onko mokkulassa myös eri sisäkalut?

Eli laitanko eteenpäin jonnekin sellaiseen maahan missä se toimii, vai softaanko Suomessa toimivaksi?

Kiitos.
Käyttäjätaso 7
Kunniamerkki
 Hmm; WCDMA-taajuuksina nuo 900 ja 2100 on kyllä Suomessa käytössä. Vai onko tikun tiedoissa merkintä LTE900/2100, joista ainakin jälkimmäinen on jenkeillä käytössä ja 900 esim. Ruotsissa?

Huawein tikut on vähän sekalaista "sakkia". E3276 hyväksyy suurinpiirtein firmiksen kuin firmiksen, mutta E3372 tuntuu pitävän jonkinlaista rajaa, eikä esim. s-malli hyväksynyt h-mallin firmistä (siis E3372s vs. E3372h ero). Jonkin verran ilmeisesti myös vaikutusta alkuperäisen firmiksen versiolla. Uusin HiLink-firmis (22.298.xx) on hankalin, enkä itse ole vielä edes yrittänyt vaihtaa sitä muuksi (vielä; on ollut verrokkivehkeenä muille firmiksille).

Kovin isoja eroja en usko raudassa olevan, mutta piirisarja on varmasti koko ajan kehitysvaiheessa, joten eroja saattaa olla, ja pienikin ero voi olla firmiksen sopivuuden kannalta ongelma. Tuon em. 298-firmiksen outous panee jopa epäilemään, että Huawei yrittää jotenkin tiukemmin kontrolloida käyttäjien mahdollisuuksia tikkujen fläshäämisessä.  

Eli s.s.: Jos tikku on ns. normaali (21-firmis), niin kannattanee aluksi kokeilla ihan at-komennoilla, kuinka tikku reagoi taajuuspakotukseen (SYSCFGEX-komento) Suomessa käytettäville LTE-taajuuksille. Jos se on HiLink-mallia (22-firmis), kannattaa kokeilla, ymmärtääkö LTEWatchH-softa tikun päälle mitään ja onnistuuko sen avulla taajuuspakotukset. Firmiksen vaihdon suhteen voi sitten miettiä, minkä arvoinen tikku oli hankittaessa eli kuinka kallis briketti siitä tulisi, jos vaihto menee kiville.
Käyttäjätaso 2
Yleensä noissa on ihan rautaeroja. Nuo luettelemasi on 3G taajuuksia ja ovat kyllä käytössä Suomessakin. 4G:n osalta pitäisi löytyä FDD800/1800 ja mahdollisesti 2600.
OpenWRT:n foorumilla on vinkki, jota voisi kokeilla 21.x firmiksellä varustetussa E3372:ssa, jos viimein saisi E3372:n toimimaan OpenWRT:ssä kunnolla.

https://forum.openwrt.org/viewtopic.php?pid=277259#p277259

Minulla ei ole tällä hetkellä tikkua käytettävissä, joten en ole itse kokeillut tuota kikkaa.
IPv6 tukea ei taida löytyä tästä E3372 tikusta?
Käyttäjätaso 7
Joukki kirjoitti:
IPv6 tukea ei taida löytyä tästä E3372 tikusta?

http://consumer.huawei.com/en/mobile-broadband/dongles/features/e3372.htm
Tuon mukaan ilmeisesti pitäs toimia IPv6. Eipä toimi ainakaan minulla. Korttia käytin tabletissa missä sai laitettua IPv4/IPv6 päälle niin toimi IPv6. Mokkulassa taas ei.

Edit. Vai onko sitte firmiksestä kiinni. Dna vakio hilink firmis mokkulassa ja se kiinni tp link 3420v2 boxissa. Kokeilin myös ilman boxia ja ei ollut vaikutusta.
Ostin Verkkokauppa.com:sta Soneralle brändätyn E3372:n. Probleemana on, etten pääse ollenkaan tikun asetuspaneeliin (jos sitä edes on firmisversiolla 22.298.03.00.07) menemällä selaimella osoitteeseen 192.168.8.1. Muitakin IP:tä olen kokeillut eikä mikään toimi. Tavoitteena olisi siis forcea tikku käyttämään 4G:tä, sillä putoilee usein HSPA+:aan. Saunalahden Mobiililaajakaista 4.0 testattu toimimattomaksi.
Käyttäjätaso 7
Koponen942 kirjoitti:
Ostin Verkkokauppa.com:sta Soneralle brändätyn E3372:n. Probleemana on, etten pääse ollenkaan tikun asetuspaneeliin (jos sitä edes on firmisversiolla 22.298.03.00.07) menemällä selaimella osoitteeseen 192.168.8.1. Muitakin IP:tä olen kokeillut eikä mikään toimi. Tavoitteena olisi siis forcea tikku käyttämään 4G:tä, sillä putoilee usein HSPA+:aan. Saunalahden Mobiililaajakaista 4.0 testattu toimimattomaksi.

Soneran tikku E3372s näyttäisi olevan ns. selaimella hallittava HiLink-versio.

http://www.sonera.fi/etsi+apua+ja+tukea/ohjeet/Huawei-E3372S?id=6ac8b3aa-b64e-44a6-bdbd-26c49ca0f98c

Elisa/Saunalahden vastaava on perusversio E3372 , joka tarvitsee erillisen yhteysohjelman (joko Mobiililaajakaista 4 tai Mobile Partner)

http://asiakastuki.elisa.fi/ohje/516/

Näyttää siltä , että se HiLink-tikku ei toimi Saunalahden SIM-kortilla eikä tietenkään myöskään ymmärrä mitään Saunalahden yhteysohjelmista. No enpä ihan 100% varma ole asiasta , mutta ikävältä yhteensopivuusongelmalta asia vaikuttaa. Verkkokauppa.com kyllä väittää , että tikku toimii kaikkien operaattoreiden SIM-korteilla , mutta oletusasetukset ovat Soneran. En vain keksi miten niitä muutettaisiin , jos hallintaan ei pääse.

Edit:

Tästä tikusta lienee kyse.

http://www.verkkokauppa.com/fi/product/55760/fhmss/Huawei-E3372-3G-4G-nettitikku-Sonera

Tulipa mieleen , että jos olisi Soneran SIM käytettävissä , niin voisi testata ettei tikussa ole jotakin vikaa. Toinen vaihtoehto on vaihtaa tikku brändäämättömään esim. tähän.

http://www.verkkokauppa.com/fi/product/50430/fjmnh/Huawei-E3372-LTE-4G-3G-USB-modeemi
Tikku kyllä toimii SL:n SIM-kortilla ja surffailee mainiosti, mutta asetuksien säätäminen on koitunut ongelmaksi.

edit: Olisikohan firmiksen päivityksestä apua? (vaikka tietokoneihmisiä olenkin, niin ei hajuakaan miten mobiilitikkujen kanssa säädetään)
Käyttäjätaso 7
Koponen942 kirjoitti:
Tikku kyllä toimii SL:n SIM-kortilla ja surffailee mainiosti, mutta asetuksien säätäminen on koitunut ongelmaksi.

edit: Olisikohan firmiksen päivityksestä apua? (vaikka tietokoneihmisiä olenkin, niin ei hajuakaan miten mobiilitikkujen kanssa säädetään)

Kappas vaan kirjoittelimme vähän ristiin. No lisäsin edelliseen viestiini , että kannattaisi vaihtaa tikku Verkkokaupassa brändäämättömään.

Osallistu keskusteluun