Huawei E3372 kokemuksia?



Näytä ensimmäinen kirjoitus

232 kommenttia

LOISTAVAA!!! Siirryttyäni vähän pakonkin sanelemana 4G aikaan minua näissä HiLink-tikuissa on häirinnyt sisäverkon saavutettavuus ulkoa päin. Tai siis se, että ulkoa ei kotiverkkoon pääse. Nyt tuossa firmiksessä näyttäisi olevan roppakaupalla työkaluja, jolla tämän ongelman voisi korjata. Vielä en ennättänyt noita käytännössä kokeilla, mutta toimiessaan nämä pelastavat minut toisen tikun ostolta. DMZ tai Virtual Server -ominaisuudet pääsevät nyt testiin.

Minulla on nyt ollut TP-Linkin TL-MR3020 viimeisimmällä ROOTer firmiksellä. Tuo välillä kaatuilee, joten olen kasannus vanhasta atom mini PC:stä x86 pohjaista openwrt boxia (CC RC2). 

T: Teeq
Onkohan joku saanut tuota DMZ:a toimimaan? Minä en millään pääse ulkoverkosta kiinni routeriin, jossa tuo e3372 on kiinni. 

Tikulla DMZ on määritelty 192.168.8.2 ja routerin wan osoitteeksi on asetettu sama. Porttien uudelleen ohjaustakin on yritetty tuolle DMZ osoitteelle. Käytössä on DNA:n 4G liittymä, jossa avoimia portteja pitäisi olla ainakin TCP 500 ja 2222-2231. Sisäverkosta ssh toimii tuohon 192.168.8.2, mutta ulkoverkosta ei.

T: Teeq
Moi Olen lukenut koko ketjun läpi, mutta en löytänyt ongelmaani ratkaisua.

Hankin Latviasta E3372h-153 tikun joka itse asiassa kyllä toimi yhteen ROOterin  (OfModemsAndMen) MultiWebin viimeisimmän version kanssa heittämällä. Ainakin jollain tavalla. Kun tikku on reitittimessä sen hallintaan pääsee 192.168.8.1 osoitteen kautta kiinni ja voi tehdä profiilin ja jatkossa sitten yhteys muodostuu automaagisesti. Mutta kun aloin törmätä ongelmiin, että aivan kuin yhteys vain lakkaisi toimimasta vaikka tikun hallintapaneli väittää yhteyden olevan päällä, niin aloin etsimään jotain FW päivitystä tikulle. Ja niin päädyin tälle foorumille. Yritin sitten päivittää tikkua sillä lopputulemalla, että tikku on "bricked". Tai ei aivan. FW päivitys ei missään vaiheessa onnistunut, mutta kun sen nyt tuikkaa koneeseen kiinni, löytyy laitehallinnasta kaksi COM-porttia. Ja kun sen laittaa linukkaan tai OpenWrt reitittimeen, se tunnistuu ainakin jotenkin.

En tiedä mikä merkitys sillä on, että heti kun tikun työntää koneeseen se alkaa vilkuttamaan melko nopeaan tahtiin vihreää valoa. Oli sitten SIMmiä sisällä tai ei.

Olisiko kenelläkään ehdotuksia miten sen saisi takaisin elävien kirjoihin?
Käyttäjätaso 7
Kunniamerkki
Jos toinen noista tunnistuvista porteista on PC UI -niminen, niin firmispäivityksen pitäisi onnistua. Ja varminta niin, että myös se päivitysfirmis on h-mallille tarkoitettu. Vaikka en tiedäkään, onko h-malli kuinka tiukka tuon mallimerkinnän suhteen, mutta toisinpäin (s-malliin h-firmis) ei ainakaan onnistunut.

Jos päivitys ei onnistu, niin millaisen virheilmoituksen se antaa?

Tupla-vilkku-vihreä on resetoitumisen ja virhetilanteen merkkivalo. Jos laitehallinnassa ei näy muuta kuin ne pari COM-porttia, niin tikku on päivityksen epäonnistuessa jäänyt "vaiheeseen", eli se on määritetty vastaanottamaan firmispäivitys, jota ei virheen takia tullutkaan.
Toinen on tosiaan PC UI niminen ja minulla 21 alkuinen h firmis jota yritän flashata, mutta päättyy virhekoodiin 13. Ajatuksena oli, että tuolla olisi päässyt eroon HiLinkistä. 22 alkuista h firmistä en ainakaan vielä ole löytänyt.

Ja piti vielä tuosta vilkusta todeta, että se ei näytä minusta tuplavilkulta vaan yhtenäiseltä nopealta vilkkumiselta.
Käyttäjätaso 7
Kunniamerkki
Millä kikalla alunperin sait nuo portit auki? Ne ei nuo tässä ketjussa esitetyt systeemit välttämättä toimi h-mallilla, koska ainakin omat kokeilut on kaikki tehty s:llä.

Yhtenäinen nopea vilkku? Ilmeisesti tikku on fläsh-lukutilassa, eli luulee ottavansa koodia vastaan? Tuokin jo kertoo, että toiminta poikkeaa kaikesta kokemastani.

Koska epäilit tikusta tulleen jo "briketti", niin kannattaisi ehkä kokeilla laittaa uudelleen sisään HiLink-firmis ja/tai ladata WebUI uudelleen, josko tuolla tavalla saisi tikun toimimaan taas edes HiLinkkinä. 3Ginfo.ru-sivustolla muistelen nähneeni h-sarjalle sekä 21- että 22-alkuiset firmikset ja WebUI:n.
Kokeilin E3372h-153_Update_22.180.05.00.00 firmiksellä samoin tuloksin.

Jos muistan oikein, niin tilanne tuli päälle kun yritin päivittää WebUI:ta. Nyt (n. 10 minuuttia sitten) löysin 3GInfo saitiltaWebUI:n (Update_WEBUI_17.100.06.00.03_Hilink_V7R2_9x25_CPIO) jonka lataus tikulle onnistui :)

Nyt WebUI device information kertoo

Device name:    E3372
Hardware version:    CL2E3372HM
Software version:    22.200.03.00.17
Web UI version:    17.100.06.00.03

Meinasi jo usko mennä että saanko tikkua enää elävien kirjoihin. Niin montaa eri versiota latasin ja yritin päivittää :)

Taidan tällä haavaa hyväksyä tikun tuollaisena. Pitää vielä tarkistaa, että oliko aiemmin ongelmani tuon tikun ja OpenWrt:n epäyhteensopivuus vaiko käytössäni olleen reitittimen WLAN vika.
Eli tiedoksi muillekin, että nyt minulla on E3372h-153 (edellisen viestin FW:llä ja UI:lla) kiinni TP-Linkin TL-MR3420 reitittimessä johon on asennettu ROOter FunnelWeb 2014-04-14a / LuCI Trunk (svn-r9964). ROOter tuntuu nielevän tikun mukisematta ja sitten tikkuun kiinni WebUI:n kautta (192.168.8.1) ja sinne asetukset kohdalleen. Netti pelittää hienosti 🙂 Aiemmin minulla oli tikku kiinni TL-WR1043ND reitittimessä jossa oli myös ROOter (uusin Multiweb) jossa se itse asiassa toimi myös, mutta taitaa tuon reitittimen WLAN olla olla jotenkin viella (tai muu vika reitittimessä).

Yksi syy fw päivitykseen tosin minulla oli alunperin, että saisin yhteyden sisäverkkoon ulkoa päin. No siihen vaivaan pitäisi toimia myös reverse ssh ja siihen tunnelointi. Kun noilla operaattoreilla on usein vielä portit kiinni tai 4G kokonaan natattuna.
Moi,

onko mahdollsita saada E3372 Huawei ja TP-LINK TL-MRSA3420 toimimaan yhdessä? ei näytä yhdistyvän, vaikka reitittimen sivuilla näyttäisi asetukset olevan ok.
Laitetaanpa tännekin tiedoksi, kun löytyi hyvin toimiva combo tälle tikulle. Toimii ihan heittämällä OpenWRT:n uusimman RC:n kanssa (Chaos Calmer 15.05-rc3). Purkkina D-Link DIR-825 rev. B2. Tikku on Elisalta ostettu non-HiLink ja täysin koskematon tehdasfirmis.

OpenWRT:ssä en muuta tehnyt kuin asentanut usb-ajurit

opkg update
opkg install comgt kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwansekä 3G guin

opkg install luci-proto-3gjonka jälkeen kaikki konffaus hoitui suoraan web-liittymän kautta.

Yhteys tuntuu pysyvän vakaasti ylhäällä ja se myös muodostuu noin 15 sekunnissa vaikka tikun ottaisi lennosta irti ja takaisin kiinni (jopa senkin kerran kun vaihdoin lennosta Elisan simmin dna:n simmiin, molemmissa sama PIN).

Ainoa huono puoli on, että OpenWRT:n kälistä ei irtoa käytännössä mitään dataa yhteyden tilasta. Jos tuonne vielä saisi jotenkin puukotettua ROOterin inforuudut...
OpenWrt Chaos Calmer 15.05 on julkaistu, mutta sen NCM-tuki E3372:lle on edelleen rikkinäinen. Puolalaiselta sivustolta löytyy onneksi toimiva versio. Sivuston osoite on: http://eko.one.pl/

Tuolta kannattaa ladata CC:n luci-versio.

http://dl.eko.one.pl/luci/chaos_calmer/

Esim. Netgear WNDR3700v2:

http://dl.eko.one.pl/luci/chaos_calmer/ar71xx/luci-15.05-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin

Firmiksen asennuksen jälkeen pääteyhteyden kautta esim. komennot:

uci delete network.wan
uci set network.wan=interface
uci set network.wan.proto=ncm
uci set network.wan.device=/dev/ttyUSB0
uci set network.wan.pincode=1234
uci set network.wan.apn=internet
uci commit network
reboot

Nämä komennot korvaavat eth1:ssä olevan wan-yhteyden. Yhteyden tilasta saa tietoa, kun asentaa 3ginfo-nimisen ohjelman komennoilla:

opkg update
opkg install  3ginfo

Minun osalta puolen vuoden tappelu E3372:n on loppunut. Väliaikaisena ratkaisuna ollut Dovado lähtee pois, koska sen toiminta on ollut WLAN-verkon ja DDNS-palvelun osalta epävakaa. 

Lisäyksenä vielä, että mikäli yhteyden haluaa pakottaa LTE-moodiin, niin seuraava komento pitää ajaa:

uci set network.wan.option=lte
uci commit network

Nopeus Soneran täysnopeusliittymällä on 90/25Mbps ja ping 22ms Speedtestin mukaan, joten asetukset näyttäisi olevan kunnossa.
Heinäkussa 27. päivä ajettiin trunkkiin patchi, joka korjasi E3372:n käyttöön liittyneen ongelman ncm-ajurissa: https://lists.openwrt.org/pipermail/openwrt-devel/2015-July/034723.html (selaa ketjua taaksepäin jos haluat tarkempaa tietoa).

CC 15.05 paketit on buildattu 15.9. joten tämän patchin pitäisi löytyä myös siitä. Itse käytän tällä hetkellä nightly buildia r46815 joka buildattu joskus syyskuun alkupuolella ja ncm hyrrää kuin junan vessa.

Tosin sellainen pikkuvika vielä on, että jos mokkula jostain syystä tiputtaa yhdeyden, sitä ei saa takaisin ylös mitenkään muuten kuin boottaamalla koko reitittimen. Onneksi pätkimistä ei ainakaan tällä hetkellä juurikaan ole (ehkä kerran kadessa viikossa). Tämäkin ongelma on kehittäjien tiedossa: https://lists.openwrt.org/pipermail/openwrt-devel/2015-February/031461.html

Tuossa aiemmin laittamani kommentti liittyy siis PPP-protokollan käyttöön, jonka itsekin lopulta totesein hitaaksi. Etenkin uppikaista jäi puoleen siitä mitä tikku antoi suoraan pc:hen kiinnitettynä tai nyt ncm:n kanssa. En suosittele.

LTE-pakotuksen voi tehdä myös siten, että laittaa tikun kiinni windows koneeseen ja käyttää MDMA-nimistä softaa: http://www.nerve.org.za/mdma/
Tällä pitäisi onnistua myös taajuuspakotukset. Näitä asetuksiahan muutettaessa, ne jäävät modeemiin "päälle" eli eivät muutu vaika tikun vaihtaa laitteesta toiseen.
Pitää kokeilla vakioimagea uudestaan, mutta mielestäni se ei toiminut vastaavalla konfiguraatiolla. Tuossa puolalaisessa imagessa on vielä kaikki tarvittava valmiiksi asennettuna.

Tikkujen jumitukseen olen käyttänyt skriptiä, joka testaa yhteyden toimintaa ja resetoi reitittimen tarvittaessa. Reset ei tosin auta kaikkiin tapauksiin, jos reititin ei katkaise USB-portin sähköä resetin yhteydessä. TP-Linkin WDR4300 osaa ainakin katkaista sähkö USB-väylästä resetin yhteydessä, joten sen kanssa saa hyvin toimivan yhteyden rakennettua.
Olihan se vähän hakuammuntaa mitä paketteja piti asentaa ennen kuin lähti toimimaan. Mitään dokumentaatiota näistä kun ei ole. En edes tajunnut kirjata ylös kaikkia paketteja mitä erikseen asensin, mutta tässä listaus koko setupista josko siitä olisi jollekulle apua: http://pastebin.com/buA3qjsU

ja /etc/config/network:

config interface 'wan'
option proto 'ncm'
option ifname 'wwan0'
option device '/dev/cdc-wdm0'
option apn 'internet'
option pincode '1234Jotain skriptiä itsekin suunnittelin, joka tekisi rebootin mikäli yhteys katkeaa. Miten testaat yhteyden tomintaa? Pingaat jotain palvelinta, esim. Googlen dns 8.8.8.8 ?
Kokeilin asennella tarvittavat paketit puhtaaseen OpenWRT:n. Tikku näkyy ja wwan0 interface nousee ylös, mutta se ei saa IP-osoitetta. Sama ongelma on ollut aikaisemminkin, kun olen kokeillut trunk-versiota. Voihan tosin olla, että lataan jonkun väärän modulin järjestelmää. /etc/config/network-tiedosto on muuten samanlainen, mutta /dev/cdc-wdm0 laitenimellä ei wwan0 interface nouse ylös. Kokeilin myös syöttää sinne komentoja minicomin kanssa, mutta ei sekään toiminut, vaikka laitenimi näkyy dev-hakemistossa.

Tässä vielä kokeilemani komennot:

opkg update

opkg install usb-modeswitch chat comgt-ncm kmod-usb-net-cdc-ncm kmod-usb-serial kmod-usb-serial-option kmod-usb-net-huawei-cdc-ncm

uci delete network.wan
uci set network.wan=interface
uci set network.wan.ifname=wwan0
uci set network.wan.proto=ncm
uci set network.wan.device=/dev/ttyUSB0
uci set network.wan.pincode=1234
uci set network.wan.apn=internet
uci commit network
reboot

Nettiyhteyden tarkistamiseen olen käyttänyt Siptunen vanhaan Asusin reitittimeen tehtyjä skriptejä, joka on OpenWRT-pohjainen. OpenWRT on GPL-lisenssin alainen, joten skritit voinee laittaa tänne näkyviin:

/usr/sbin/wan-wd:

#!/bin/sh

# WAN watchdog by Anttu v.100915
# Inner 1 min loop inits modem, outer 1+2 min loop reboots

    sleep 60
    while :
    do
      modinit=0
      while [ $modinit -eq 0 ]
      do
        sleep 60
        RESP=`ping -c 3 google.com`
        if [ "$RESP" = "" ]
        then
          /etc/init.d/network restart
          modinit=1
        fi
      done  
      sleep 120
      RESP=`ping -c 3 google.com`
      if [ "$RESP" = "" ]
      then
        reboot
      fi
    done

/etc/init.d/wan-watchdog:

#!/bin/sh /etc/rc.common
# Modeemien asetukset, ATu 100911

START=98
start() {
    wan-wd &
}

Tuo wan-watchdog pitää sitten pistää päälle esim. komennolla:

/etc/init.d/wan-watchdog enable
Onko E3372h:n IPV6 tuesta käytännön kokemuksia vielä?

Hankin tuollaisen hiljattain, ja konvertoin non-hilink firmwaren käyttöön näiden ohjeiden mukaisesti. Tikku toimii hienosti Openwrt:n perässä (Rooter), mutta IPV6 tuki näyttää puuttuvan.

AT+CGDCONT=? näyttää tukevan vain IP ja PPP tyyppejä, eikä laisinkaan IPV6 tai IPV4V6 tyyppejä. Ymmärtääkseni IPV6 käyttö on mahdollista vain näitä käyttämällä.
Ainakin Openwrt 15.05 versiolla toimii IPv6 dna:n liittymällä. Käytössä tosin s-versio tikusta.
tpahula kirjoitti:
Ainakin Openwrt 15.05 versiolla toimii IPv6 dna:n liittymällä. Käytössä tosin s-versio tikusta.
Toimiiko myös IPv6 prefix delegaatio? Eli saatko /56 blockin, vai /64:sen? Aikaisemmalla E3276:lla sain kyllä /64 osoitteen, mutta en saanut PD:tä toimimaan.
Itse-itselleni vastaten, ilmeisesti IPv6 tuki tosiaan puuttuu tästä 21.180.01.00.00 general firmwaresta.

En ole löytänyt E3372h-153:lle uudempaa general firmistä, ja operaattori spesifisten firmwarejen, kuten 21.200.07.00.209, flashaus tämän general firmwaren päälle ei ainakaan suoraan onnistu.

Onko kellään kokemusta miten tuon uudemman non-hilink firmwaren saisi flashattua tähän?
Onko kellään kokemusta Zyxel SBG3300 ja Huawei E3372 yhtennsopivuudesta?

Kuulin että joku oli saanut ne toimimaan yhdessä mutta Zyxell ei tue sitä virallisesti.
jamu kirjoitti:
tpahula kirjoitti:
Ainakin Openwrt 15.05 versiolla toimii IPv6 dna:n liittymällä. Käytössä tosin s-versio tikusta.
Toimiiko myös IPv6 prefix delegaatio? Eli saatko /56 blockin, vai /64:sen? Aikaisemmalla E3276:lla sain kyllä /64 osoitteen, mutta en saanut PD:tä toimimaan.

DNA:lta tulee /64 osoite. Minulla on 21.286.03.01.209 Megafon firmis tikussa ladattuna.
jamu kirjoitti:
Itse-itselleni vastaten, ilmeisesti IPv6 tuki tosiaan puuttuu tästä 21.180.01.00.00 general firmwaresta.

En ole löytänyt E3372h-153:lle uudempaa general firmistä, ja operaattori spesifisten firmwarejen, kuten 21.200.07.00.209, flashaus tämän general firmwaren päälle ei ainakaan suoraan onnistu.

Onko kellään kokemusta miten tuon uudemman non-hilink firmwaren saisi flashattua tähän?

Ei ole kokemusta h-mallista, mutta oletko katsonut seuraavalta sivulta löytyviä firmiksiä ja ohjeita ?

http://www.lteforum.at/mobilfunk/firmware-versionen-hi-non-hilink-e3372h-inkl-mod.2691/
Mikäs olisi hyvä non-hilink firmis e3372s tikulle? ROOter multiweb käytössä reitittimessä. Tarvisi saada lukittua tuo tikku tiettyyn soluun.
Etsin e3372s-mallin firmiksiä ja uusin löytämäni oli 21.300.05.00.00. Huawein Release Notesin mukaan tämä on viides firmware versio. Paketti löytyy osoitteesta:

http://turbobit.net/download/free/xqmn4h3yjo2r#

Onko kukaan kokeillut tämän toimintaa ?
Testasin 21.300.05.00.00 firmiksen ja ei ainakaan yhteysnopeus huonontunut :)



Tikku on kiinni Netgear WNDR3700v2 reittimessä, jossa OpenWRT CC 15.05. Samalla tuli löydettyä ratkaisu ongelmani originaalin OpenWRT:n kanssa. Kahdella komennolla yhteysongelma ratkesi.

echo 6000 > /sys/class/net/wwan0/cdc_ncm/tx_max

echo 0 > /sys/class/net/wwan0/cdc_ncm/min_tx_pkt

Lähde:

http://lists.freedesktop.org/archives/modemmanager-devel/2016-January/002489.html

Osallistu keskusteluun