Vastattu

Serveri hylkää lähtevät postit

  • 20 helmikuu 2019
  • 9 kommenttia
  • 443 katselukerrat

  • Uusi OmaYhteisön jäsen
  • 5 kommenttia
Minulla on Saunalahden 100M taloyhtiölaajakaista ja Zyxel Wireless VDSL2 modeemi. Käytän kotona iPhone 7 ja iPad mini 4 - laitteita enimmäkseen WLAN-yhteydellä. Minulla on Telian @pp.inet.fi sähköposti, jota käytän Applen sähköpostiohjelmalla molemmilla laitteilla. Ongelmana on, että yksikään sähköposti ei lähde WLAN-verkossa, koska palvelin hylkää ne (rejected by server). Kun katkaisen WLAN-yhteyden, viesti lähtee välittömästi Telian mobiiliverkon kautta. Saapuva sähköpostiliikenne toimii normaalisti. Onko nyt palomuuri esteenä vai hylkivätkö keskenään kilpailevat operaattorit toistensa sähköpostipalvelimia? Eikö Saunalahden verkko suostu lähettämään mail.inet.fi - palvelimelta saapuvaa sähköpostia eteenpäin, vai hylkääkö Telian palvelin Saunalahden verkon kautta saapuvan viestin? Itselleni lähettämäni viestit menevät läpi ilman ongelmia.
icon

Vastauksen tähän kysymykseen jakoi Telisa 20 helmikuu 2019, 19:50

Kiitos Sokrates
Käyttäjätunnuksen ja salasanan lisääminen korjasi ongelman ja postit lähtevät nyt myös WLAN-verkossa.
Jäi alussa mainitsematta, että minulla oli aiemmin omakotitalossa Telian laajakaista eikä siellä ollut mitään ongelmaa, kun laajakaista ja sähköpostitili olivat samalta operaattorilta.
Katso alkuperäinen viesti

9 kommenttia

Käyttäjätaso 7
Minulla on Saunalahden 100M taloyhtiölaajakaista ja Zyxel Wireless VDSL2 modeemi. Käytän kotona iPhone 7 ja iPad mini 4 - laitteita enimmäkseen WLAN-yhteydellä. Minulla on Telian @pp.inet.fi sähköposti, jota käytän Applen sähköpostiohjelmalla molemmilla laitteilla. Ongelmana on, että yksikään sähköposti ei lähde WLAN-verkossa, koska palvelin hylkää ne (rejected by server). Kun katkaisen WLAN-yhteyden, viesti lähtee välittömästi Telian mobiiliverkon kautta. Saapuva sähköpostiliikenne toimii normaalisti. Onko nyt palomuuri esteenä vai hylkivätkö keskenään kilpailevat operaattorit toistensa sähköpostipalvelimia? Eikö Saunalahden verkko suostu lähettämään mail.inet.fi - palvelimelta saapuvaa sähköpostia eteenpäin, vai hylkääkö Telian palvelin Saunalahden verkon kautta saapuvan viestin? Itselleni lähettämäni viestit menevät läpi ilman ongelmia.
Telian postissa pitäisi käyttää lähtevänä palvelimena Telian autentikoivaa palvelinta.

https://www.telia.fi/asiakastuki/palvelut/telia-sahkoposti/kayttoonotto-sahkoposti
Kiitos,
Lähtevän postin palvelin on SMTP- palvelin mail.inet.fi, portti 465, SSL-salauksella ja se on käsittääkseni autentikoiva palvelin.
Lisätietona vielä, että Gmail.com - sovelluksesta ja Telian verkkosähköpostista viestit lähtevät ihan normaalisti sekä langattoman modeemin että mobiiliverkon kautta.
Tuon linkin ohjeen mukaan iPadiin voisi kai luoda Telian sähköpostitilin uudelleen, mutta en uskaltanut tehdä sitä, kun pelkään, että menetän kaiken datan.
Käyttäjätaso 7
Kiitos,
Lähtevän postin palvelin on SMTP- palvelin mail.inet.fi, portti 465, SSL-salauksella ja se on käsittääkseni autentikoiva palvelin.
Lisätietona vielä, että Gmail.com - sovelluksesta ja Telian verkkosähköpostista viestit lähtevät ihan normaalisti sekä langattoman modeemin että mobiiliverkon kautta.
Tuon linkin ohjeen mukaan iPadiin voisi kai luoda Telian sähköpostitilin uudelleen, mutta en uskaltanut tehdä sitä, kun pelkään, että menetän kaiken datan.

Hmmm..

Kuulostaa siltä , että lähtevän postin asetukset ovat kuten pitääkin. Portti 465 ja SSL-salaus tarkoittavat autentikointia eli palvelin edellyttää käyttäjätunnusta ja salasanaa. Onhan lähtevän postin käyttäjätunnus ja salasana samat kuin tulevassa postissa? Niillä pitäisi toimia verkossa kuin verkossa.

Toinen mahdollisuus on , että palvelin tulkitsee postin roskapostiksi eikä päästä sitä läpi. Saat ilmeisesti lähettäessä paluupostina virheilmoituksen. Siinä olevan vikakoodin avulla kenties pääsee häiriön jäljille.

https://serversmtp.com/smtp-error/
Sitä tavanomaista virheilmoitusta ei tule, vain ilmoitus:
“Cannot send mail. A copy has been placed in your outbox. The recipient ab@gmail.com Was rejected by the server.”
Käyttäjätaso 7
Sitä tavanomaista virheilmoitusta ei tule, vain ilmoitus:
“Cannot send mail. A copy has been placed in your outbox. The recipient ab@gmail.com Was rejected by the server.”

Jaahas.

Yrität siis lähettää viestiä Gmail-tilille? Kokeile lähettää testiviesti jollekin muulle kuin Gmail-tilille Elisan verkon kautta. Jos menee perille , niin syylllinen löytynee Googlen puolelta. Gmail välillä blokkaa ihan tavallisiakin posteja. Jos ei viestit mene perille muillekaan tileille Elisan verkon kautta , niin sitten ongelma on joko Elisalla tai Telialla.

PS. Yksi mahdollisuus on käyttää Elisan ei-autentikoivaa lähtevän postin palvelinta , mutta silloin ei posti toimi kuin Elisan verkossa.

Palvelin smtp.kolumbus.fi
Portti 25
Ei käyttäjätunnuksia eikä salausta

https://elisa.fi/asiakaspalvelu/aihe/sahkoposti-kotisivut/ohje/sahkopostin-asetukset/
Käyttäjätaso 7
Kunniamerkki +3
Portti 465 ja SSL-salaus tarkoittavat autentikointia eli palvelin edellyttää käyttäjätunnusta ja salasanaa.

SSL-salaus ja kirjautuminen ovat kaksi eri asiaa. Voit ottaa SSL-yhteyden Telian postipalvelimelle Telian liittymästä kirjautumatta. Muusta kuin Telian liittymästä yhteyden ottaminen edellyttää kirjautumisen.

Kannattaa siis tarkastaa, että smtp-asetuksissa on varmasti Telialta saatu oma käyttäjätunnus ja salasana käytössä.

Nyt vaikuttaa siltä, että asetukset ovat muuten kunnossa, mutta smtp-asetuksita puuttuu käyttäjätunnus ja salasana.

Joissakin laitteissa on lisäksi erillinen kirjautumistäppä, joka tulee ruksia päälle. Use login credentials, log in to send mail tjms. Mikäli laite ehdottaa mahdollisuutta käyttää samaa tunnusta sekä postin vastaanottoon että lähettämiseen, kannattaa kokeilla kytkeä valinta päälle.
Kiitos taas,
lähtevät viestit eivät mene perille mihinkään muuhun sp-osoitteeseen, kuin omaan pp.inet.fi -sähköpostiin. Yritin saada tuolla gmail-kokeilulla virheilmoituksesta kuvakaappauksen, jonka yritin liittää viestiin, mutta en onnistunut. Kirjoitin sen sitten itse.
Käyttäjätunnus ja salasana olivat vain saapuvan postin palvelimessa. Lisäsin ne nyt myös lähtevään. Kokeilen onko siitä apua, kun palaan WLAN-verkon piiriin. Palaan sitten asiaan.
Kiitos Sokrates
Käyttäjätunnuksen ja salasanan lisääminen korjasi ongelman ja postit lähtevät nyt myös WLAN-verkossa.
Jäi alussa mainitsematta, että minulla oli aiemmin omakotitalossa Telian laajakaista eikä siellä ollut mitään ongelmaa, kun laajakaista ja sähköpostitili olivat samalta operaattorilta.
Ja kiitos myös irritukselle!

Osallistu keskusteluun