Zte mc801a 5g porttiohjaus ei toimi

  • 1 tammikuu 2021
  • 6 kommenttia
  • 531 katselukerrat

Hei, yritin saada 3D printterin monitorointia pystyy julkisella IP:llä, mutta porttiohjaus ei toimi.
Pääsen kyllä IP:llä ulkoverkosta ZTE hallintapaneeliin joten IP kyllä toimii.
Tein porttiohjaukset laitteen IP osoitteen perusteella ja porttialue oli 55000 - 55000.
Varmistin vielä että laitteen serveri toimi sisäverkosta hyvin ja se ohjautuu portti 80:lle.
Mitähän muuta en ole ottanut huomioon? Eikös näillä tiedoilla pitäisi toimia?

AndreiDev 17 päivää sitten

Sain toimimaan portti ohjauksen NAS:iin OpenVPN:llä.
Mitä tein:
1. APN asetuksissa vaihdoin PDP Type IPv4 sekä APN internet4
2.  Port Forwarding asetuksista NAS:in paikallinen IP osoite ja ohjaus portille sekä Protocol TCP
3. Exporttasin NAS:ista openvpn asetukset siten, että setenv CLIENT_CERT 0 lisättiin conffiin.

Toimii 🎉

Katso alkuperäinen viesti

6 kommenttia

Käyttäjätaso 7
Kunniamerkki +3

Olethan sallinut etäkäytön 3D-tulostimen hallintalaitteesta?

Mikäli hallintaohjelmisto pyörii tavallisessa tietokoneessa, olethan avannut portin 55000 käyttöjärjestelmän palomuurista?

Mm. Windowsin palomuurissa on nykyään oletuksena, että ainoastaan samasta aliverkosta avattu liikenne sallitaan. Tässä tapauksessa siis 192.168.100.1 – 192.168.100.255 on sallittu, kaikki muut ip-osoitteet on estetty.

Olethan sallinut etäkäytön 3D-tulostimen hallintalaitteesta?

Mikäli hallintaohjelmisto pyörii tavallisessa tietokoneessa, olethan avannut portin 55000 käyttöjärjestelmän palomuurista?

Mm. Windowsin palomuurissa on nykyään oletuksena, että ainoastaan samasta aliverkosta avattu liikenne sallitaan. Tässä tapauksessa siis 192.168.100.1 – 192.168.100.255 on sallittu, kaikki muut ip-osoitteet on estetty.

 

3D-hallinta pyörii RPI jossa pitäisi tietääkseni olla 192.168.100.1:80 sallittu. Eli varmaan pitää avaa se 55000 portti.

RPI jossa tämä pyörii on kaapelilla kiinni RJ45 jakajaan ja siitä ZTE reitittimeen.

Käyttäjätaso 7
Kunniamerkki +3

3D-hallinta pyörii RPI jossa pitäisi tietääkseni olla 192.168.100.1:80 sallittu.

ZTE:n reitittimellä, jonka ip-osoite tuossa on, ei voi hallita 3D-tulostinta. Hallintaohjelmassa tulee sallia ne ip-osoiteet, mistä aiot tulostinta hallita. Mikäli et tiedä etukäteen osoitteita, joudut sallimaan kaikki osoitteet, tai suojaamaan yhteyden tulostimelle muilla tavoin, kuten vpn-tunnelilla.

Huomioi, että NAT muuntaa ainoastaan oman sisäverkkosi osoitteet – ei muita osoitteita. Sisäverkostasi tullaan tänne OmaYhteisöön osoitteella 205.251.219.28, ei 192.168.100.1, vaikka ZTE:ssäsi on osoitemuunnos käytössä.

Samoin, jos esim. 203.0.113.114 otetaan tulostimesi hallintaan yhteyttä, 203.0.113.114 pitää sallia hallintapaneelissa, eikä 192.168.100.1.

Eli varmaan pitää avaa se 55000 portti.

Jos ZTE:n portinohjaus kääntää 55000:n 80:ksi, portti 80 täytyy avata tulostimen hallinnasta.

Jos taas tulostimen hallinta on oikeasti portissa 55000, ZTE:n portinohjaus tulee tehdä portista 55000 porttiin 55000 ja tulostimen hallinnasta portti 55000 avataan.

Nostan tämän uudelleen ylös.
En jostain syystä saanut toimimaan edes NAS portti ohjausta.
Eli pitääkö ZTE:n Port Forwarding sallita sisäinen IP ja portti vai ulkoinen? 
Access device:ssa näkyy NAS:in sisäinen IP osoite jossa pyörii OpenVPN johon yritän päästä käsiksi ulkoverkosta porttiohjauksella. 

Täällä sama juttu, ei toiminut aluksi vaikka oli porttiohjaus olemassa ja Elisalta laitettu aktiiviseksi tuo julkinen vaihtuva ip-palvelu. Kun keksin vaihtaa fyysisen ethernet-piuhan porttiin 1, lähti saman tien toimimaan.

 

Minulla on OpenVPN palvelin sisäverkossa ja ZTE:n paneelista tuo “Portinsiirto” käytössä ja sinne on laitettu ip-osoitteeksi sisäverkon IP jossa tuo OpenVPN palvelin pyörii. Porttialue on yksi portti jossa OpenVPN kuuntelee. Minulla sama portti menee läpi eli esim. 55000 olisi sinun tapauksessasi määritetty sekä tulostimen kuunteluportiksi että ZTE:en hallinnasta porttialueeksi.

Sain toimimaan portti ohjauksen NAS:iin OpenVPN:llä.
Mitä tein:
1. APN asetuksissa vaihdoin PDP Type IPv4 sekä APN internet4
2.  Port Forwarding asetuksista NAS:in paikallinen IP osoite ja ohjaus portille sekä Protocol TCP
3. Exporttasin NAS:ista openvpn asetukset siten, että setenv CLIENT_CERT 0 lisättiin conffiin.

Toimii 🎉

Osallistu keskusteluun